summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-09-14 21:14:19 +0100
committerPatrick McLean <chutzpah@gentoo.org>2021-09-21 17:05:11 -0700
commitbed361b9aaf3ef583b5362d05f381d819ee72290 (patch)
tree3819e8ed6891a99e5b570674dcfd6e0b021ccdaa /app-misc/openrgb
parentdev-util/conf2struct: Correct ~mips keyword (diff)
downloadgentoo-bed361b9aaf3ef583b5362d05f381d819ee72290.tar.gz
gentoo-bed361b9aaf3ef583b5362d05f381d819ee72290.tar.bz2
gentoo-bed361b9aaf3ef583b5362d05f381d819ee72290.zip
app-misc/openrgb: drop 0.6-r0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/openrgb')
-rw-r--r--app-misc/openrgb/openrgb-0.6.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-misc/openrgb/openrgb-0.6.ebuild b/app-misc/openrgb/openrgb-0.6.ebuild
deleted file mode 100644
index c356d7aff6fb..000000000000
--- a/app-misc/openrgb/openrgb-0.6.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
-else
- SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
- S="${WORKDIR}/OpenRGB-release_${PV}"
- KEYWORDS="~amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
-fi
-
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
-HOMEPAGE="https://gitlab.com/CalcProgrammer1/OpenRGB/"
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="
- dev-libs/hidapi:=
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- virtual/libusb:1
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/nlohmann_json
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES+=(
- "${FILESDIR}"/OpenRGB-0.6-pkgconf.patch
-)
-
-src_prepare() {
- default
- rm -r dependencies/{hidapi,libusb,json}* || die
-}
-
-src_configure() {
- eqmake5 INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
-}
-
-src_install() {
- emake INSTALL_ROOT="${ED}" install
-
- dodoc README.md OpenRGB.patch
-}