summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <stha09@googlemail.com>2020-02-18 16:11:39 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-03-09 21:33:36 +0100
commitab51e719f086daa2684c155321b4359f97f7b5ba (patch)
tree7ce659081da2626ae358adc365c8e3c25495010e /app-misc/ttyrec
parentdev-util/diffuse: Drop 0.4.8-r1 (diff)
downloadgentoo-ab51e719f086daa2684c155321b4359f97f7b5ba.tar.gz
gentoo-ab51e719f086daa2684c155321b4359f97f7b5ba.tar.bz2
gentoo-ab51e719f086daa2684c155321b4359f97f7b5ba.zip
app-misc/ttyrec: fix building with glibc 2.30.
Closes: https://bugs.gentoo.org/691908 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Stephan Hartmann <stha09@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/14692 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc/ttyrec')
-rw-r--r--app-misc/ttyrec/files/ttyrec-1.0.8-glibc-2.30.patch30
-rw-r--r--app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild5
2 files changed, 34 insertions, 1 deletions
diff --git a/app-misc/ttyrec/files/ttyrec-1.0.8-glibc-2.30.patch b/app-misc/ttyrec/files/ttyrec-1.0.8-glibc-2.30.patch
new file mode 100644
index 000000000000..174fc7786e19
--- /dev/null
+++ b/app-misc/ttyrec/files/ttyrec-1.0.8-glibc-2.30.patch
@@ -0,0 +1,30 @@
+diff --git a/ttyrec.c b/ttyrec.c
+index 3392f70..86a59ee 100644
+--- a/ttyrec.c
++++ b/ttyrec.c
+@@ -57,7 +57,9 @@
+
+ #if defined(SVR4)
+ #include <fcntl.h>
++#if !(defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__) || defined(__linux__))
+ #include <stropts.h>
++#endif
+ #endif /* SVR4 */
+
+ #include <sys/time.h>
+@@ -449,6 +451,7 @@ getslave()
+ perror("open(fd, O_RDWR)");
+ fail();
+ }
++#ifndef __linux__
+ if (isastream(slave)) {
+ if (ioctl(slave, I_PUSH, "ptem") < 0) {
+ perror("ioctl(fd, I_PUSH, ptem)");
+@@ -466,6 +469,7 @@ getslave()
+ #endif
+ (void) ioctl(0, TIOCGWINSZ, (char *)&win);
+ }
++#endif
+ #else /* !SVR4 */
+ #ifndef HAVE_openpty
+ line[strlen("/dev/")] = 't';
diff --git a/app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild b/app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild
index df5351688d2e..e3f42c0d0d33 100644
--- a/app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild
+++ b/app-misc/ttyrec/ttyrec-1.0.8-r2.ebuild
@@ -12,7 +12,10 @@ SRC_URI="http://0xcc.net/ttyrec/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-PATCHES=( "${FILESDIR}/${P}-flags.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-flags.patch"
+ "${FILESDIR}/${P}-glibc-2.30.patch"
+)
src_compile() {
# Bug 106530