summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-09 20:52:35 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-09 20:53:34 +0200
commitc038828bc49567ab7b882eb4803fabda02a35a6c (patch)
tree2cd9484c7ac4955ab689ca317dc5dea478e8d347 /app-office/homebank
parentapp-office/calligra: drop 3.2.1-r9, dropping stable keywords (diff)
downloadgentoo-c038828bc49567ab7b882eb4803fabda02a35a6c.tar.gz
gentoo-c038828bc49567ab7b882eb4803fabda02a35a6c.tar.bz2
gentoo-c038828bc49567ab7b882eb4803fabda02a35a6c.zip
app-office/homebank: add 5.8.3
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-office/homebank')
-rw-r--r--app-office/homebank/Manifest1
-rw-r--r--app-office/homebank/homebank-5.8.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-office/homebank/Manifest b/app-office/homebank/Manifest
index 5f5d4e199afe..e2c27b4d75ee 100644
--- a/app-office/homebank/Manifest
+++ b/app-office/homebank/Manifest
@@ -1,2 +1,3 @@
DIST homebank-5.8.1.tar.gz 3722739 BLAKE2B 23042c8fc952faf2da039934f4b82c9c5949649647bac1861cf291dc360929911316fa912e676bd1b2d87f7290e0b6a4fdce035b1e7ca6558bf613365f71e8d6 SHA512 900228b813c79bd4a5f1257a51e422e4748c7b7e9945d6d9c72c04097caf2275dd8294fd901a55fa6110c8c75be418e89a3a541a3350d350ef01b052e0cfb1f6
DIST homebank-5.8.2.tar.gz 3771644 BLAKE2B b660ebbab36ce7f42f9db662e0f2dc62fbac425ea91e2335bbcea14bce799f6b2e79fe130a56e47880cf0b55c86095fecc1b9583f91738126122f94e2ba1c241 SHA512 f241a8569209b9504e1a68b3c72168147641666e838a3a0160e56efcf2070c016a1ae906d7fcea8ac26e6785a74f5bf571a3f14f82bd8daa1f0cf33b0c7be983
+DIST homebank-5.8.3.tar.gz 3773027 BLAKE2B 0af8b22b113c1be391cee455666ed767c9edefbba3973cdbdd85ca020611a5a8d992d85ee7b5e39ec56ea6693b4ee147cc05591623cb10d71b17466e7c205db2 SHA512 20b08c2329c7f11a4317b460be3e3b99072dab618965f9c96b21ed9355843e3cbb68730fa1517a5c6c90f9ab9fa53f7ed1e4f6d5af62a32d7d92e82acf342944
diff --git a/app-office/homebank/homebank-5.8.3.ebuild b/app-office/homebank/homebank-5.8.3.ebuild
new file mode 100644
index 000000000000..b794b4f11bfc
--- /dev/null
+++ b/app-office/homebank/homebank-5.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="
+ https://www.gethomebank.org/
+ https://launchpad.net/homebank
+"
+SRC_URI="https://www.gethomebank.org/public/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+ofx"
+
+RDEPEND="
+ >=dev-libs/glib-2.39:2
+ net-libs/libsoup:3.0
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}