summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-17 20:53:11 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-17 20:53:11 +0100
commitc426e264624fa437662096ad5d142949276532f8 (patch)
treec0a286df559dbc32a839a1aa236a6b3b4a08d77c /app-office
parentmedia-tv/kodi: mesa 22.3.0 compatibility (diff)
downloadgentoo-c426e264624fa437662096ad5d142949276532f8.tar.gz
gentoo-c426e264624fa437662096ad5d142949276532f8.tar.bz2
gentoo-c426e264624fa437662096ad5d142949276532f8.zip
app-office/libreoffice: backport patch for boost 1.81
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-7.3.7.2-boost-1.81-locale.patch41
-rw-r--r--app-office/libreoffice/libreoffice-7.3.7.2.ebuild3
2 files changed, 44 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-7.3.7.2-boost-1.81-locale.patch b/app-office/libreoffice/files/libreoffice-7.3.7.2-boost-1.81-locale.patch
new file mode 100644
index 000000000000..18b2222fd313
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-7.3.7.2-boost-1.81-locale.patch
@@ -0,0 +1,41 @@
+From 23dcd4339428e4080029ec5ae658e75f01e79a62 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
+ <congdanhqx@gmail.com>
+Date: Sun, 27 Nov 2022 18:59:24 +0700
+Subject: [PATCH] i18n: fix build with Boost 1.81.0
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Boost.Locale since 1.81.0 switch to enum classes for facet type [1].
+Switch our resource manager accordingly.
+
+1: https://github.com/boostorg/locale/commit/e5ed439ea39a4de915e9fb939cca95cae7d9d8d1
+
+Change-Id: Ief215363ceb79b2019606b20a7cde55c8df6a042
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/143343
+Reviewed-by: Heiko Becker <heirecka@exherbo.org>
+Tested-by: Caolán McNamara <caolanm@redhat.com>
+Reviewed-by: Caolán McNamara <caolanm@redhat.com>
+---
+ unotools/source/i18n/resmgr.cxx | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/unotools/source/i18n/resmgr.cxx b/unotools/source/i18n/resmgr.cxx
+index ddedf5b9e8a2f..3a71163500624 100644
+--- a/unotools/source/i18n/resmgr.cxx
++++ b/unotools/source/i18n/resmgr.cxx
+@@ -127,8 +127,13 @@ namespace Translate
+ if (aFind != aCache.end())
+ return aFind->second;
+ boost::locale::generator gen;
++#if BOOST_VERSION < 108100
+ gen.characters(boost::locale::char_facet);
+ gen.categories(boost::locale::message_facet | boost::locale::information_facet);
++#else
++ gen.characters(boost::locale::char_facet_t::char_f);
++ gen.categories(boost::locale::category_t::message | boost::locale::category_t::information);
++#endif
+ #if defined(ANDROID)
+ OString sPath(OString(lo_get_app_data_dir()) + "/program/resource");
+ #else
diff --git a/app-office/libreoffice/libreoffice-7.3.7.2.ebuild b/app-office/libreoffice/libreoffice-7.3.7.2.ebuild
index dddc49045f08..9f590961fe49 100644
--- a/app-office/libreoffice/libreoffice-7.3.7.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.7.2.ebuild
@@ -294,6 +294,9 @@ PATCHES=(
# 7.4 branch
"${FILESDIR}/${PN}-7.3.5.2-gpgme-1.18.0.patch"
+
+ # backport
+ "${FILESDIR}/${P}-boost-1.81-locale.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"