summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-09 20:15:18 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-09 20:29:20 +0200
commitf0b6a44466702df5581551fd2d1626ce6844c0a0 (patch)
tree74e5646dafa7f0d12ad3c7ed1306f9a79159d9c3 /app-office
parentdev-util/hipify-clang: strip incompatible flag due to compiler switch (diff)
downloadgentoo-f0b6a44466702df5581551fd2d1626ce6844c0a0.tar.gz
gentoo-f0b6a44466702df5581551fd2d1626ce6844c0a0.tar.bz2
gentoo-f0b6a44466702df5581551fd2d1626ce6844c0a0.zip
app-office/calligra: add 4.0.1
Closes: https://bugs.gentoo.org/939296 Closes: https://bugs.gentoo.org/903532 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calligra/Manifest1
-rw-r--r--app-office/calligra/calligra-4.0.1.ebuild153
-rw-r--r--app-office/calligra/metadata.xml1
3 files changed, 155 insertions, 0 deletions
diff --git a/app-office/calligra/Manifest b/app-office/calligra/Manifest
index d7c2d4419fe5..5cf5a8973143 100644
--- a/app-office/calligra/Manifest
+++ b/app-office/calligra/Manifest
@@ -1,2 +1,3 @@
DIST calligra-3.2.1-patchset-1.tar.xz 11924 BLAKE2B 5a71a7960a6d2a4d5e55129f4812fb13a2fb56613283d4582266e1836f107b711be43cb158e29c440fbda6992c03a3f4907f0600d21522fd9ab07c66354234a9 SHA512 26ec818f2415c43b116b716557710361621e1e4446087fe123e29107f82400ec82f19ab3a76dde9b749ed4b9f15da9c05c3fa6137fc814241c48ffc12f5628fc
DIST calligra-3.2.1.tar.xz 55207684 BLAKE2B 332629f18adbee649e8d25a1eedf4ee48af7d8cbb79382c70678bacfa89d9a10797eb0ff42cb5aad51ef2c28aa7071e687bd34053cadcc40ac1936bb9a40dc20 SHA512 e53a939aa1b277c2291cfd626868c77085fc9cc7774df160b5b1afceb33314b4381fa8ffe03636cbde6e35cc2abd170a51e7f9c1a99191339313b9c9c3b1526f
+DIST calligra-4.0.1.tar.xz 57780728 BLAKE2B 0ea82f5b21d36e04222db4ee282048b61a6d144630cc26d007d722fa8fc3081ee38e8f54b7256f9e722cccedc7ddc7489e3a3bd7dff34263d81cd5a7081aa6b2 SHA512 79569a1e75d5c70c8b2c3e5c7cf88d26d9b7a81be52c131c932521c65d1712a531829bcd29f7233f1ee7601fa363ca9ce2c4783a76dfdc5abe3c8b04b5741b78
diff --git a/app-office/calligra/calligra-4.0.1.ebuild b/app-office/calligra/calligra-4.0.1.ebuild
new file mode 100644
index 000000000000..f27d1244b2d1
--- /dev/null
+++ b/app-office/calligra/calligra-4.0.1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHECKREQS_DISK_BUILD="4G"
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit check-reqs ecm kde.org
+
+DESCRIPTION="KDE Office Suite"
+HOMEPAGE="https://calligra.org/"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+PATCHSET="${PN}-3.2.1-patchset-1"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}.tar.xz"
+
+CAL_FTS=( karbon sheets stage words )
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+charts +crypt +fontconfig gsl +import-filter +lcms okular +pdf phonon
+ +truetype webengine X $(printf 'calligra_features_%s ' ${CAL_FTS[@]})"
+
+RESTRICT="test"
+
+# TODO: Not packaged: Cauchy (https://bitbucket.org/cyrille/cauchy)
+# Required for the matlab/octave formula tool
+COMMON_DEPEND="
+ dev-lang/perl
+ >=dev-libs/qtkeychain-0.14.2:=[qt6(-)]
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6[widgets]
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=dev-qt/qttools-${QTMIN}:6[designer]
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/kguiaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/kitemviews-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/knotifyconfig-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/sonnet-${KFMIN}:6
+ sys-libs/zlib
+ virtual/libiconv
+ charts? ( dev-libs/kdiagram:6 )
+ crypt? ( dev-libs/openssl:= )
+ fontconfig? ( media-libs/fontconfig )
+ gsl? ( sci-libs/gsl:= )
+ import-filter? (
+ app-text/libetonyek
+ app-text/libodfgen
+ app-text/libwpd:*
+ app-text/libwpg:*
+ >=app-text/libwps-0.4
+ dev-libs/librevenge
+ media-libs/libvisio
+ )
+ lcms? ( media-libs/lcms:2 )
+ okular? ( kde-apps/okular:6 )
+ pdf? ( app-text/poppler:=[qt6] )
+ phonon? ( >=media-libs/phonon-4.12.0[qt6(-)] )
+ truetype? ( media-libs/freetype:2 )
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:6[widgets] )
+ calligra_features_sheets? ( dev-cpp/eigen:3 )
+ calligra_features_words? ( dev-libs/libxslt )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+ lcms? ( dev-libs/imath:3 )
+ test? ( >=kde-frameworks/threadweaver-${KFMIN}:6 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !${CATEGORY}/${PN}:5
+ calligra_features_karbon? ( media-gfx/pstoedit[plotutils] )
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=( "${WORKDIR}"/${PATCHSET}/${PN}-3.1.89-no-arch-detection.patch ) # downstream
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ ecm_pkg_setup
+ check-reqs_pkg_setup
+}
+
+src_configure() {
+ local cal_ft myproducts
+
+ # applications
+ for cal_ft in ${CAL_FTS[@]}; do
+ use calligra_features_${cal_ft} && myproducts+=( "${cal_ft^^}" )
+ done
+
+ use lcms && myproducts+=( PLUGIN_COLORENGINES )
+ use okular && myproducts+=( OKULAR )
+
+ local mycmakeargs=(
+ -DPACKAGERS_BUILD=OFF
+ -DRELEASE_BUILD=ON
+ -DWITH_Iconv=ON
+ -DWITH_Imath=ON # w/ LCMS: 16 bit floating point Grayscale colorspace
+ -DCMAKE_DISABLE_FIND_PACKAGE_Cauchy=ON
+ -DPRODUCTSET="${myproducts[*]}"
+ $(cmake_use_find_package charts KChart6)
+ $(cmake_use_find_package crypt OpenSSL)
+ -DWITH_Fontconfig=$(usex fontconfig)
+ -DWITH_GSL=$(usex gsl)
+ -DWITH_LibEtonyek=$(usex import-filter)
+ -DWITH_LibOdfGen=$(usex import-filter)
+ -DWITH_LibRevenge=$(usex import-filter)
+ -DWITH_LibVisio=$(usex import-filter)
+ -DWITH_LibWpd=$(usex import-filter)
+ -DWITH_LibWpg=$(usex import-filter)
+ -DWITH_LibWps=$(usex import-filter)
+ $(cmake_use_find_package phonon Phonon4Qt6)
+ -DWITH_LCMS2=$(usex lcms)
+ -DWITH_Okular6=$(usex okular)
+ -DWITH_Poppler=$(usex pdf)
+ -DWITH_Eigen3=$(usex calligra_features_sheets)
+ -DBUILD_UNMAINTAINED=$(usex calligra_features_stage)
+ -DWITH_Freetype=$(usex truetype)
+ $(cmake_use_find_package webengine Qt6WebEngineWidgets)
+ )
+
+ ecm_src_configure
+}
diff --git a/app-office/calligra/metadata.xml b/app-office/calligra/metadata.xml
index b581a8d5393a..e6718f9f6204 100644
--- a/app-office/calligra/metadata.xml
+++ b/app-office/calligra/metadata.xml
@@ -22,5 +22,6 @@
<flag name="okular">Enable bindings for <pkg>kde-apps/okular</pkg></flag>
<flag name="phonon">Build stage/eventplugins and videoshape plugin using <pkg>media-libs/phonon</pkg></flag>
<flag name="spacenav">Enable support for the 3Dconnexion spacenav input device via <pkg>dev-libs/libspnav</pkg></flag>
+ <flag name="webengine">Enable Braindump support using <pkg>dev-qt/qtwebengine</pkg></flag>
</use>
</pkgmetadata>