summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-07-26 15:44:34 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-07-26 15:44:34 +0300
commit0de9029e16f64c8aac31f6104fa2f375d41bc0b4 (patch)
tree02ec8bf3ca0783ec89ff53812b66a3f1a6b818ac /app-officeext/ooofbtools/ooofbtools-2.51.ebuild
parentoffice-ext-r1.eclass: add support for EAPI 6 (diff)
downloadgentoo-0de9029e16f64c8aac31f6104fa2f375d41bc0b4.tar.gz
gentoo-0de9029e16f64c8aac31f6104fa2f375d41bc0b4.tar.bz2
gentoo-0de9029e16f64c8aac31f6104fa2f375d41bc0b4.zip
app-officeext/ooofbtools: version bump
Reported-by: Sergey S. Starikoff <Ikonta@yandex.ru> Gentoo-Bug: 624530 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-officeext/ooofbtools/ooofbtools-2.51.ebuild')
-rw-r--r--app-officeext/ooofbtools/ooofbtools-2.51.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-officeext/ooofbtools/ooofbtools-2.51.ebuild b/app-officeext/ooofbtools/ooofbtools-2.51.ebuild
new file mode 100644
index 000000000000..0c5234aaa3d0
--- /dev/null
+++ b/app-officeext/ooofbtools/ooofbtools-2.51.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="OOoFBTools"
+
+OFFICE_EXTENSIONS=(
+ "${MY_PN}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="OpenOffice extension for the FictionBook2 format with validation"
+HOMEPAGE="https://sourceforge.net/projects/fbtools/"
+SRC_URI="mirror://sourceforge/fbtools/files/release/${MY_PN}-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/libxml2
+ app-arch/zip"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+OFFICE_EXTENSIONS_LOCATION="${S}"
+
+src_prepare() {
+ # Remove Windows cruft
+ pushd "${WORKDIR}/${MY_PN}.oxt" &>/dev/null || die
+ rm -r win32 || die
+ popd &>/dev/null || die
+
+ eapply_user
+}
+
+src_install() {
+ office-ext-r1_src_install
+ dodoc ChangeLog*
+}