summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-06 09:23:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-06 09:32:53 +0100
commit584c23ef2b4b0d3fac3dba07a30c2650af65a80b (patch)
treed08028ee01c91dd0e22cf2371baaf662b2808d28 /app-portage
parentprofiles: Drop mask for removed app-editors/emacs:25 (diff)
downloadgentoo-584c23ef2b4b0d3fac3dba07a30c2650af65a80b.tar.gz
gentoo-584c23ef2b4b0d3fac3dba07a30c2650af65a80b.tar.bz2
gentoo-584c23ef2b4b0d3fac3dba07a30c2650af65a80b.zip
app-portage/nattka: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/nattka/Manifest1
-rw-r--r--app-portage/nattka/nattka-0.4.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-portage/nattka/Manifest b/app-portage/nattka/Manifest
index 26beb076a0b1..b0a0df9005c2 100644
--- a/app-portage/nattka/Manifest
+++ b/app-portage/nattka/Manifest
@@ -1 +1,2 @@
DIST nattka-0.4.1.gh.tar.gz 95941 BLAKE2B 4037c2b364c091e10f4684e8c1e59c26c7af943c6cf230058b115d4518f9b7589ca845a5174f6f99280b2cb1655544afe3ba727ef6276570a00fcd3e6117c382 SHA512 d490999b6a4b4938f85081750c9b67f3876b666c99f6b36eada32a66c0111fc2f1be231b49b08754b1213b616b854d5bb4865ea8e3540e2d48b504fdb7047d2f
+DIST nattka-0.4.2.gh.tar.gz 101891 BLAKE2B 33f1b3746d79a5945ab764cd6cbbc33773c3935c1e18627e2be7d1b740cf7dac95b0884989cf2a7189237b505ea38bb84e57d72ba7a97a29789e6ec372224d80 SHA512 6c1281aeb11d2a576f6474203df7a8dceb8451d243812da972c03ad282e2fb46272ee8f797f5f9f002b9953bf9cb2f8843754ee871adf56b11468f75f7108a4d
diff --git a/app-portage/nattka/nattka-0.4.2.ebuild b/app-portage/nattka/nattka-0.4.2.ebuild
new file mode 100644
index 000000000000..13f8fd3432cb
--- /dev/null
+++ b/app-portage/nattka/nattka-0.4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="
+ https://github.com/projg2/nattka/
+ https://pypi.org/project/nattka/
+"
+SRC_URI="
+ https://github.com/projg2/nattka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="depgraph-order"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ dev-vcs/git
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ depgraph-order? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ >=dev-python/flit-core-3.7.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+EPYTEST_XDIST=1
+distutils_enable_tests pytest