summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-08-19 15:46:16 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-08-19 15:46:35 +0200
commit7824cefa9f0352fbba3775e4c11db0b0a5e074c6 (patch)
tree260649e0e6b193e35f9b802858b6a0a58a19cc6c /app-portage
parentnet-wireless/kismetmobiledashboard: update EAPI 7 -> 8 (diff)
downloadgentoo-7824cefa9f0352fbba3775e4c11db0b0a5e074c6.tar.gz
gentoo-7824cefa9f0352fbba3775e4c11db0b0a5e074c6.tar.bz2
gentoo-7824cefa9f0352fbba3775e4c11db0b0a5e074c6.zip
app-portage/getuto: add 1.1
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/getuto/Manifest1
-rw-r--r--app-portage/getuto/getuto-1.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/getuto/Manifest b/app-portage/getuto/Manifest
index a50e57772012..bf27dbb478d9 100644
--- a/app-portage/getuto/Manifest
+++ b/app-portage/getuto/Manifest
@@ -1,2 +1,3 @@
DIST getuto-1.0.tar.gz 8218 BLAKE2B 9579bce48cb746db6aabe13b1e809ec73ddd1ea6ed859bbe5b6b860659a2e3747dc8f408c67531854ba6b7f4aa6fc31ac788122eb30d2100213176777d2ca4b3 SHA512 b6de03eef95802d678504321f37093a491a17673ae31b03834bc29a85815aab593fd7e2fe396ac21b83e804939932557c99e69d94d0599e2dbbfb410e1708e2e
+DIST getuto-1.1.tar.gz 9394 BLAKE2B 50a129826a98d1a43e1bee68f4d12707334de6e7dd0408685e4e5b727affe86560199745a65bc810d857afc972ef0e2aab6b712c67061e1379add1b48494c4b5 SHA512 94f88b6562d763aa2b5cea407409e617d9c1bc89db5779fe12cebabf3db22873d60f36e98ca90ce8bbbc4a1f06bb734a1ee059b5735f54cdba24db9f041cc13c
DIST libc-1-r1-1.gpkg.tar 20480 BLAKE2B b2c184e20c1a29ff66240e992f9f81219285f525eb63cea081372685cf03a2e231a2edb528259617e74c655fbe61b6e0d8fc0bbdbd8452b6098de58432f019d7 SHA512 ce52f398ea8979ec16161381803740d49a4294c77303880f54090c379ba5eb8e545a3d3550f229cacc18c7763dc3adf7936561ba1c64b43c87692ec66084e4e6
diff --git a/app-portage/getuto/getuto-1.1.ebuild b/app-portage/getuto/getuto-1.1.ebuild
new file mode 100644
index 000000000000..860cc3595dd0
--- /dev/null
+++ b/app-portage/getuto/getuto-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Stand-alone gentoo install trust anchor generation tool"
+HOMEPAGE="https://github.com/projg2/getuto"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projg2/getuto"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/projg2/getuto/archive/refs/tags/${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+=" test? ( https://mirror.bytemark.co.uk/gentoo/releases/amd64/binpackages/17.1/x86-64/virtual/libc/libc-1-r1-1.gpkg.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/gnupg
+ dev-libs/openssl
+ sec-keys/openpgp-keys-gentoo-release
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ # Don't mangle test data
+ unpack ${P}.tar.gz
+ fi
+
+ if use test ; then
+ cp "${DISTDIR}"/libc-1-r1-1.gpkg.tar "${S}" || die
+ fi
+}
+
+src_install() {
+ dobin getuto
+}