summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-09-03 15:09:04 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-09-03 15:09:29 +0200
commitfc020aad1d952778afed47318cfb6993679cfc5a (patch)
tree205265a38e4f96e4f328e0fb1bdff7c0d6dda6de /app-portage
parentapp-misc/sdate: Fix *.la removal (diff)
downloadgentoo-fc020aad1d952778afed47318cfb6993679cfc5a.tar.gz
gentoo-fc020aad1d952778afed47318cfb6993679cfc5a.tar.bz2
gentoo-fc020aad1d952778afed47318cfb6993679cfc5a.zip
app-portage/getuto: add 1.5
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/getuto/Manifest1
-rw-r--r--app-portage/getuto/getuto-1.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/getuto/Manifest b/app-portage/getuto/Manifest
index 080a51a77efb..b682ffbeedd8 100644
--- a/app-portage/getuto/Manifest
+++ b/app-portage/getuto/Manifest
@@ -1,3 +1,4 @@
DIST getuto-1.3.tar.gz 9589 BLAKE2B 79f95e263d3a18e58122bb418a3f7e4fe2f28b9e1c0e1cdd21c02df6cb1d0daec233c496ad0191ee4808ccad751b0e76212168454202da03d35bb74a100b24c4 SHA512 c7be7c992da2d3817240e20e47ee195a88eeb63a9a8a886e3b526b7a464fa6b2fe932b056aa0140960a9f104c34a6d4bafe483d10bf02da3c8ce9b7e3e4c3b26
DIST getuto-1.4.tar.gz 9702 BLAKE2B a81f474cc9202cdeffa90280c4dd3fa0710dafcad7c70f5887d61f10cd3f2f0a4bf0dda60b4e2eaa7299677b33bb73191066968ca0775d887ceb64ab1c1926d4 SHA512 c4f8089986b65056250404242eb31acd8db03a2cf5215d26167d8396befdd96a3d625b3b88958f397dff03b5f5d78c9b1437ff9be58b3502ba9446753473252e
+DIST getuto-1.5.tar.gz 9706 BLAKE2B cc31775c89d9beadd1ac32fa5596833e71d8e9aa2ea3229d7bdea4caf23de2e79c76bb74975e13953b6226f806fd547c76b38de71f1b4084dce1a92ce2c217bb SHA512 78da4ca097b87c05980895d3491722e739505e1ce0614fd39242255712e705c3e7455636b67e328980bbc15fe85e6826d6d4a1b1804670f219675a67f4999904
DIST libc-1-r1-1.gpkg.tar 20480 BLAKE2B b2c184e20c1a29ff66240e992f9f81219285f525eb63cea081372685cf03a2e231a2edb528259617e74c655fbe61b6e0d8fc0bbdbd8452b6098de58432f019d7 SHA512 ce52f398ea8979ec16161381803740d49a4294c77303880f54090c379ba5eb8e545a3d3550f229cacc18c7763dc3adf7936561ba1c64b43c87692ec66084e4e6
diff --git a/app-portage/getuto/getuto-1.5.ebuild b/app-portage/getuto/getuto-1.5.ebuild
new file mode 100644
index 000000000000..860cc3595dd0
--- /dev/null
+++ b/app-portage/getuto/getuto-1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Stand-alone gentoo install trust anchor generation tool"
+HOMEPAGE="https://github.com/projg2/getuto"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projg2/getuto"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/projg2/getuto/archive/refs/tags/${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+=" test? ( https://mirror.bytemark.co.uk/gentoo/releases/amd64/binpackages/17.1/x86-64/virtual/libc/libc-1-r1-1.gpkg.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/gnupg
+ dev-libs/openssl
+ sec-keys/openpgp-keys-gentoo-release
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ # Don't mangle test data
+ unpack ${P}.tar.gz
+ fi
+
+ if use test ; then
+ cp "${DISTDIR}"/libc-1-r1-1.gpkg.tar "${S}" || die
+ fi
+}
+
+src_install() {
+ dobin getuto
+}