summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/bibus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/bibus')
-rw-r--r--app-text/bibus/Manifest2
-rw-r--r--app-text/bibus/bibus-1.5.1.ebuild73
-rw-r--r--app-text/bibus/bibus-1.5.2-r1.ebuild81
-rw-r--r--app-text/bibus/bibus-1.5.2.ebuild80
-rw-r--r--app-text/bibus/files/bibus-1.5.0-install.patch262
-rw-r--r--app-text/bibus/files/bibus-1.5.2-install.patch110
-rw-r--r--app-text/bibus/metadata.xml8
7 files changed, 616 insertions, 0 deletions
diff --git a/app-text/bibus/Manifest b/app-text/bibus/Manifest
new file mode 100644
index 000000000000..ad03eda7a867
--- /dev/null
+++ b/app-text/bibus/Manifest
@@ -0,0 +1,2 @@
+DIST bibus-1.5.1.tar.gz 4989431 SHA256 1e6e6895124d2ab4147be83f2f87d0b1e78b2786f27345b3d1a3976d13d4c70d SHA512 9181dcc332ea139f31c44c10d084581c2d12ce2333c263eede30f2800e155cdaf0d649a6747cf30d7a259ef172d5370a351c5d747200ae7e5dfe88606f95089c WHIRLPOOL 65d9448b6d3e0ec38932b76d3e7c73ef696b9e00733b65810a1d8f789878e4c0a06378dc00b8e1c881c71c64270b44d50b97370129745dcfcf45a1bdc5b1e175
+DIST bibus_1.5.2.orig.tar.gz 5411889 SHA256 c6c66d6bdce403b7791bf58cc16eeaae9f0e9d1c3f0ba8411f9f3e694d740f02 SHA512 33d091dacc707859a11010fcba57691a3e2726ae7579d601720b4398f7be29b580be978da8cd058fab491ec5b52dd3ce33c964a8d5077f8e80d8f0f387ffa2c4 WHIRLPOOL 964f13902a8a20d9e838784cf1f0a032bb2327cd28f3b2470c35a7394ae7f7536a7884d798a8308049a02f6976183ffb1c56cc4d8b20dce13f98033668a90d38
diff --git a/app-text/bibus/bibus-1.5.1.ebuild b/app-text/bibus/bibus-1.5.1.ebuild
new file mode 100644
index 000000000000..35f0fd453c01
--- /dev/null
+++ b/app-text/bibus/bibus-1.5.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH=sqlite
+
+inherit multilib eutils python versionator
+
+DESCRIPTION="Bibliographic and reference management software, integrates with OO.o and MS Word"
+HOMEPAGE="http://bibus-biblio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}-biblio/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="mysql"
+
+# Most of this mess is designed to give the choice of sqlite or mysql
+# but prefer sqlite. We also need to default to sqlite if neither is requested.
+# Cannot depend on virtual/ooo
+# bibus fails to start with app-office/openoffice-bin (bug #288232).
+RDEPEND="
+ app-office/libreoffice
+ =dev-python/wxpython-2.8*
+ dev-db/sqliteodbc
+ dev-db/unixODBC
+ mysql? (
+ dev-python/mysql-python
+ dev-db/myodbc
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.0-install.patch
+
+ sed \
+ -e "s:gentoo-python:python$(python_get_version):g" \
+ -i Makefile Setup/Makefile Setup/bibus.cfg Setup/bibus.sh \
+ || die "Failed to adjust python paths"
+
+ # Disable byte-compilation of Python modules.
+ sed -e '/\$(compile)/d' -i Makefile || die "sed failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ oopath="/usr/$(get_libdir)/openoffice/program" \
+ prefix='$(DESTDIR)/usr' \
+ sysconfdir='$(DESTDIR)/etc' \
+ install || die "emake install failed"
+ emake \
+ DESTDIR="${D}" \
+ oopath="/usr/$(get_libdir)/openoffice/program" \
+ prefix='$(DESTDIR)/usr' \
+ sysconfdir='$(DESTDIR)/etc' \
+ install-doc-en || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize bibus
+}
+
+pkg_postrm() {
+ python_mod_cleanup bibus
+}
diff --git a/app-text/bibus/bibus-1.5.2-r1.ebuild b/app-text/bibus/bibus-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..1cc6cc272cb7
--- /dev/null
+++ b/app-text/bibus/bibus-1.5.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils fdo-mime multilib python-r1 versionator
+
+DESCRIPTION="Bibliographic and reference management software, integrates with L/OO.o and MS Word"
+HOMEPAGE="http://bibus-biblio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}-biblio/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="mysql"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Most of this mess is designed to give the choice of sqlite or mysql
+# but prefer sqlite. We also need to default to sqlite if neither is requested.
+# Cannot depend on virtual/ooo
+# bibus fails to start with app-office/openoffice-bin (bug #288232).
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-office/libreoffice
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ dev-db/sqliteodbc
+ dev-db/unixODBC
+ mysql? (
+ dev-python/mysql-python[${PYTHON_USEDEP}]
+ dev-db/myodbc
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ -d "/usr/$(get_libdir)/openoffice" ]] ; then
+ OFFICESUITE="/usr/$(get_libdir)/openoffice"
+ else
+ OFFICESUITE="/usr/$(get_libdir)/libreoffice"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ einfo "Installing for ${OFFICESUITE}"
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ oopath="${OFFICESUITE}/program" \
+ ooure="${OFFICESUITE}/ure-link/lib" \
+ oobasis="${OFFICESUITE}/program" \
+ sysconfdir="${EPREFIX}/etc" \
+ pythondir="$(python_get_sitedir)" \
+ python=${PYTHON} \
+ install install-doc-en
+ }
+ python_foreach_impl installation
+ python_parallel_foreach_impl python_optimize
+
+ python_parallel_foreach_impl python_newscript bibusStart.py ${PN}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-text/bibus/bibus-1.5.2.ebuild b/app-text/bibus/bibus-1.5.2.ebuild
new file mode 100644
index 000000000000..3c398225eb4d
--- /dev/null
+++ b/app-text/bibus/bibus-1.5.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
+PYTHON_USE_WITH=sqlite
+
+inherit eutils fdo-mime multilib python versionator
+
+DESCRIPTION="Bibliographic and reference management software, integrates with L/OO.o and MS Word"
+HOMEPAGE="http://bibus-biblio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}-biblio/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql"
+
+# Most of this mess is designed to give the choice of sqlite or mysql
+# but prefer sqlite. We also need to default to sqlite if neither is requested.
+# Cannot depend on virtual/ooo
+# bibus fails to start with app-office/openoffice-bin (bug #288232).
+RDEPEND="
+ app-office/libreoffice
+ =dev-python/wxpython-2.8*
+ dev-db/sqliteodbc
+ dev-db/unixODBC
+ mysql? (
+ dev-python/mysql-python
+ dev-db/myodbc
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_pkg_setup
+ if [[ -d "/usr/$(get_libdir)/openoffice" ]] ; then
+ OFFICESUITE="/usr/$(get_libdir)/openoffice"
+ else
+ OFFICESUITE="/usr/$(get_libdir)/libreoffice"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ einfo "Installing for ${OFFICESUITE}"
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ oopath="${OFFICESUITE}/program" \
+ ooure="${OFFICESUITE}/ure-link/lib" \
+ oobasis="${OFFICESUITE}/program" \
+ sysconfdir="${EPREFIX}/etc" \
+ pythondir="$(python_get_sitedir)" \
+ python=$(PYTHON -a) \
+ install install-doc-en
+ }
+ python_execute_function installation
+}
+
+pkg_postinst() {
+ python_mod_optimize bibus
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup bibus
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-text/bibus/files/bibus-1.5.0-install.patch b/app-text/bibus/files/bibus-1.5.0-install.patch
new file mode 100644
index 000000000000..3b2b438d4739
--- /dev/null
+++ b/app-text/bibus/files/bibus-1.5.0-install.patch
@@ -0,0 +1,262 @@
+diff -Naur bibus-1.5.0/Makefile bibus-1.5.0.new/Makefile
+--- bibus-1.5.0/Makefile 2009-10-08 16:53:13.000000000 -0400
++++ bibus-1.5.0.new/Makefile 2009-11-05 23:33:57.000000000 -0500
+@@ -1,24 +1,25 @@
+ # you presumably will only have to change the three first lines below
+-DESTDIR = /usr/local
++DESTDIR = ${D}usr
+ python = /usr/bin/python
+ oopath = /usr/lib/openoffice/program
+-ooure = /usr/lib/openoffice.org/basis-link/ure-link/lib
++ooure = /usr/lib/openoffice/basis-link/ure-link/lib
+ oobasis = /usr/lib/openoffice/basis-link/program
+ #
+ prefix = $(DESTDIR)
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+ datadir = $(prefix)/share
+-sysconfdir = /etc
++pythondir = $(prefix)/lib/gentoo-python/site-packages
++sysconfdir = ${D}etc
+ mandir = $(prefix)/share/man
+ man1dir = $(mandir)/man1
+
+ define install-files
+- install -d $(datadir)/bibus
+- install -m644 *.py MySQL_Bibus.ini $(datadir)/bibus/
++ install -d $(pythondir)/bibus
++ install -m644 *.py MySQL_Bibus.ini $(pythondir)/bibus/
+ #
+ for dir in Export Format Import StyleEditor FirstStart bibOOo db_models Pixmaps Data LyX Utilities; do \
+- find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(datadir)/bibus/'{}' ';' ; \
++ find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(pythondir)/bibus/'{}' ';' ; \
+ done
+ install -m644 Setup/UnoConnectionListener.odg -D $(datadir)/bibus/Setup/UnoConnectionListener.odg
+ # locale files. We look for all the directory in locale/
+@@ -35,41 +36,38 @@
+ # freedesktop icon and shortcut
+ install -m644 Pixmaps/bibus.png -D $(datadir)/icons/hicolor/48x48/apps/bibus.png
+ install -m644 Setup/bibus.desktop -D $(datadir)/applications/bibus.desktop
+- # The following lines are presumably not needed since icons/desktop are in standard locations
+- #echo 'Exec=$(bindir)/bibus' >> $(datadir)/applications/bibus.desktop
+- #echo 'Icon=$(datadir)/icons/hicolor/48x48/apps/bibus.png' >> $(datadir)/applications/bibus.desktop
+
+ # bibus command
+ install -d $(bindir)
+- ln -sf $(datadir)/bibus/bibusStart.py $(bindir)/bibus
+- chmod 755 $(datadir)/bibus/bibusStart.py
++ ln -sf $(pythondir)/bibus/bibusStart.py $(bindir)/bibus
++ chmod 755 $(pythondir)/bibus/bibusStart.py
+
+ # basic doc files
+- install -m755 -d $(datadir)/doc/bibus
+- install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/bibus
++ install -m755 -d $(datadir)/doc/${PF}
++ install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/${PF}
+
+ # generating bibus.cfg file
+- echo '[PATH]' > $(datadir)/bibus/bibus.cfg
+- echo 'python = $(python)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oopath = $(oopath)' >> $(datadir)/bibus/bibus.cfg
+- echo 'ooure = $(ooure)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oobasis = $(oobasis)' >> $(datadir)/bibus/bibus.cfg
+- echo 'docdir = $(datadir)/doc/bibus/html' >> $(datadir)/bibus/bibus.cfg
+- echo 'licence = $(datadir)/doc/bibus/copying' >> $(datadir)/bibus/bibus.cfg
+- echo 'localedir = $(datadir)/locale' >> $(datadir)/bibus/bibus.cfg
+- echo 'systemconf = $(sysconfdir)/bibus.config' >> $(datadir)/bibus/bibus.cfg
++ echo '[PATH]' > $(pythondir)/bibus/bibus.cfg
++ echo 'python = $(python)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'oopath = $(oopath)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'ooure = $(ooure)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'oobasis = $(oobasis)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'docdir = /usr/share/doc/${PF}/html' >> $(pythondir)/bibus/bibus.cfg
++ echo 'licence = /usr/share/doc/${PF}/copying' >> $(pythondir)/bibus/bibus.cfg
++ echo 'localedir = /usr/share/locale' >> $(pythondir)/bibus/bibus.cfg
++ echo 'systemconf = /etc/bibus.config' >> $(pythondir)/bibus/bibus.cfg
+ endef
+
+ define install-doc-en
+ # copying docs in from Docs/html/en/ for bibus-doc-en
+ cd Docs;\
+- find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/bibus/'{}' ';'
++ find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/${PF}/'{}' ';'
+ endef
+
+ define compile
+- # compile recursively all the python files located in $(datadir)/bibus
+- $(python) -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
+- $(python) -O -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
++ # compile recursively all the python files located in $(pythondir)/bibus
++ $(python) -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
++ $(python) -O -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
+ endef
+
+ install-files:
+@@ -85,13 +83,15 @@
+
+ # write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
+ echo "#!/bin/sh" > $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(bindir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(man1dir)/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/doc/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm -rf /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm -rf /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "find /usr/share/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /etc/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/man/man1/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm -rf /usr/share/doc/${PF}" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
+ chmod 744 $(datadir)/bibus/Setup/uninstall.sh
+ # end uninstaller
+diff -Naur bibus-1.5.0/Setup/Makefile bibus-1.5.0.new/Setup/Makefile
+--- bibus-1.5.0/Setup/Makefile 2009-10-08 16:53:13.000000000 -0400
++++ bibus-1.5.0.new/Setup/Makefile 2009-11-05 22:25:14.000000000 -0500
+@@ -1,24 +1,25 @@
+ # you presumably will only have to change the three first lines below
+-DESTDIR = /usr/local
++DESTDIR = ${D}/usr
+ python = /usr/bin/python
+ oopath = /usr/lib/openoffice/program
+-ooure = /usr/lib/openoffice.org/basis-link/ure-link/lib
++ooure = /usr/lib/openoffice/basis-link/ure-link/lib
+ oobasis = /usr/lib/openoffice/basis-link/program
+ #
+ prefix = $(DESTDIR)
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+ datadir = $(prefix)/share
+-sysconfdir = /etc
++pythondir = $(prefix)/lib/gentoo-python/site-packages
++sysconfdir = ${D}etc
+ mandir = $(prefix)/share/man
+ man1dir = $(mandir)/man1
+
+ define install-files
+- install -d $(datadir)/bibus
+- install -m644 *.py MySQL_Bibus.ini $(datadir)/bibus/
++ install -d $(pythondir)/bibus
++ install -m644 *.py MySQL_Bibus.ini $(pythondir)/bibus/
+ #
+ for dir in Export Format Import StyleEditor FirstStart bibOOo db_models Pixmaps Data LyX Utilities; do \
+- find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(datadir)/bibus/'{}' ';' ; \
++ find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(pythondir)/bibus/'{}' ';' ; \
+ done
+ install -m644 Setup/UnoConnectionListener.odg -D $(datadir)/bibus/Setup/UnoConnectionListener.odg
+ # locale files. We look for all the directory in locale/
+@@ -35,41 +36,38 @@
+ # freedesktop icon and shortcut
+ install -m644 Pixmaps/bibus.png -D $(datadir)/icons/hicolor/48x48/apps/bibus.png
+ install -m644 Setup/bibus.desktop -D $(datadir)/applications/bibus.desktop
+- # The following lines are presumably not needed since icons/desktop are in standard locations
+- #echo 'Exec=$(bindir)/bibus' >> $(datadir)/applications/bibus.desktop
+- #echo 'Icon=$(datadir)/icons/hicolor/48x48/apps/bibus.png' >> $(datadir)/applications/bibus.desktop
+-
++
+ # bibus command
+ install -d $(bindir)
+- ln -sf $(datadir)/bibus/bibusStart.py $(bindir)/bibus
+- chmod 755 $(datadir)/bibus/bibusStart.py
++ ln -sf $(pythondir)/bibus/bibusStart.py $(bindir)/bibus
++ chmod 755 $(pythondir)/bibus/bibusStart.py
+
+ # basic doc files
+- install -m755 -d $(datadir)/doc/bibus
+- install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/bibus
++ install -m755 -d $(datadir)/doc/${PF}
++ install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/${PF}
+
+ # generating bibus.cfg file
+- echo '[PATH]' > $(datadir)/bibus/bibus.cfg
+- echo 'python = $(python)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oopath = $(oopath)' >> $(datadir)/bibus/bibus.cfg
+- echo 'ooure = $(ooure)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oobasis = $(oobasis)' >> $(datadir)/bibus/bibus.cfg
+- echo 'docdir = $(datadir)/doc/bibus/html' >> $(datadir)/bibus/bibus.cfg
+- echo 'licence = $(datadir)/doc/bibus/copying' >> $(datadir)/bibus/bibus.cfg
+- echo 'localedir = $(datadir)/locale' >> $(datadir)/bibus/bibus.cfg
+- echo 'systemconf = $(sysconfdir)/bibus.config' >> $(datadir)/bibus/bibus.cfg
++ echo '[PATH]' > $(pythondir)/bibus/bibus.cfg
++ echo 'python = $(python)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'oopath = $(oopath)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'ooure = $(ooure)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'oobasis = $(oobasis)' >> $(pythondir)/bibus/bibus.cfg
++ echo 'docdir = /usr/share/doc/${PF}/html' >> $(pythondir)/bibus/bibus.cfg
++ echo 'licence = /usr/share/doc/${PF}/copying' >> $(pythondir)/bibus/bibus.cfg
++ echo 'localedir = /usr/share/locale' >> $(pythondir)/bibus/bibus.cfg
++ echo 'systemconf = /etc/bibus.config' >> $(pythondir)/bibus/bibus.cfg
+ endef
+
+ define install-doc-en
+ # copying docs in from Docs/html/en/ for bibus-doc-en
+ cd Docs;\
+- find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/bibus/'{}' ';'
++ find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/${PF}/'{}' ';'
+ endef
+
+ define compile
+ # compile recursively all the python files located in $(datadir)/bibus
+- $(python) -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
+- $(python) -O -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
++ $(python) -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
++ $(python) -O -c "import compileall ; compileall.compile_dir('$(pythondir)/bibus')"
+ endef
+
+ install-files:
+@@ -85,13 +83,15 @@
+
+ # write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
+ echo "#!/bin/sh" > $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(bindir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(man1dir)/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/doc/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm -rf /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm -rf /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/lib/gentoo-python/site-packages/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "find /usr/share/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /etc/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/man/man1/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm -rf /usr/share/doc/${PF}" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
++ echo "rm /usr/share/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
+ chmod 744 $(datadir)/bibus/Setup/uninstall.sh
+ # end uninstaller
+diff -Naur bibus-1.5.0/Setup/bibus.cfg bibus-1.5.0.new/Setup/bibus.cfg
+--- bibus-1.5.0/Setup/bibus.cfg 2009-10-08 16:53:13.000000000 -0400
++++ bibus-1.5.0.new/Setup/bibus.cfg 2009-11-05 22:14:50.000000000 -0500
+@@ -1,7 +1,7 @@
+ [PATH]
+ python = /usr/bin/python
+ oopath = /usr/lib/openoffice/program
+-docdir = /usr/local/share/doc/bibus/html
+-licence = /usr/local/share/doc/bibus/copying
+-localedir = /usr/local/share/locale
+-systemconf = /usr/local/etc/bibus.config
++docdir = /usr/share/doc/bibus-1.4.3.2-r1/html
++licence = /usr/share/doc/bibus-1.4.3.2-r1/copying
++localedir = /usr/share/locale
++systemconf = /etc/bibus.config
+diff -Naur bibus-1.5.0/Setup/bibus.sh bibus-1.5.0.new/Setup/bibus.sh
+--- bibus-1.5.0/Setup/bibus.sh 2009-10-08 16:53:13.000000000 -0400
++++ bibus-1.5.0.new/Setup/bibus.sh 2009-11-05 22:14:50.000000000 -0500
+@@ -1,4 +1,4 @@
+ #!/bin/sh
+-export LD_LIBRARY_PATH=/usr/lib/openoffice/program
+-export PYTHONPATH=/usr/lib/openoffice/program
+-exec /usr/bin/python /usr/local/share/bibus/bibus.py
++export LD_LIBRARY_PATH=/usr/lib/openoffice/program:/usr/lib/openoffice/basis-link/program:/usr/lib/openoffice/basis-link/ure-link/lib
++export PYTHONPATH=/usr/lib/openoffice/program:/usr/lib/openoffice/basis-link/program:/usr/lib/openoffice/basis-link/ure-link/lib
++exec /usr/bin/python /usr/lib/gentoo-python/site-packages/bibus/bibus.py
diff --git a/app-text/bibus/files/bibus-1.5.2-install.patch b/app-text/bibus/files/bibus-1.5.2-install.patch
new file mode 100644
index 000000000000..5225fcd6c3d8
--- /dev/null
+++ b/app-text/bibus/files/bibus-1.5.2-install.patch
@@ -0,0 +1,110 @@
+ Makefile | 62 ++++++++++++++++++++++++--------------------------------------
+ 1 files changed, 24 insertions(+), 38 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d41b12d..b07cdff 100755
+--- a/Makefile
++++ b/Makefile
+@@ -14,62 +14,60 @@ mandir = $(prefix)/share/man
+ man1dir = $(mandir)/man1
+
+ define install-files
+- install -d $(datadir)/bibus
+- install -m644 *.py MySQL_Bibus.ini $(datadir)/bibus/
++ install -d $(DESTDIR)$(pythondir)/bibus
++ install -m644 *.py MySQL_Bibus.ini $(DESTDIR)/$(pythondir)/bibus/
+ #
+ for dir in Export Format Import StyleEditor FirstStart bibOOo db_models Pixmaps Data LyX Utilities; do \
+- find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(datadir)/bibus/'{}' ';' ; \
++ find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(DESTDIR)/$(pythondir)/bibus/'{}' ';' ; \
+ done
+- install -m644 Setup/UnoConnectionListener.odg -D $(datadir)/bibus/Setup/UnoConnectionListener.odg
++ install -m644 Setup/UnoConnectionListener.odg -D $(DESTDIR)/$(datadir)/bibus/Setup/UnoConnectionListener.odg
+ # locale files. We look for all the directory in locale/
+ for dir in $(wildcard locale/*); do \
+ if [ -d $$dir ] && [ $$dir != "locale/CVS" ]; then \
+- install -m644 $$dir/LC_MESSAGES/bibus.mo -D $(datadir)/$$dir/LC_MESSAGES/bibus.mo ; \
++ install -m644 $$dir/LC_MESSAGES/bibus.mo -D $(DESTDIR)/$(datadir)/$$dir/LC_MESSAGES/bibus.mo ; \
+ fi; \
+ done
+ # bibus.config in /etc
+- install -m644 bibus.config -D $(sysconfdir)/bibus.config
++ install -m644 bibus.config -D $(DESTDIR)/$(sysconfdir)/bibus.config
+ # man page
+- install -m644 Setup/bibus.1 -D $(man1dir)/bibus.1
++ install -m644 Setup/bibus.1 -D $(DESTDIR)/$(man1dir)/bibus.1
+
+ # freedesktop icon and shortcut
+- install -m644 Pixmaps/bibus.png -D $(datadir)/icons/hicolor/48x48/apps/bibus.png
+- install -m644 Setup/bibus.desktop -D $(datadir)/applications/bibus.desktop
++ install -m644 Pixmaps/bibus.png -D $(DESTDIR)$(datadir)/pixmaps/bibus.png
++ install -m644 Setup/bibus.desktop -D $(DESTDIR)/$(datadir)/applications/bibus.desktop
+ # The following lines are presumably not needed since icons/desktop are in standard locations
+ #echo 'Exec=$(bindir)/bibus' >> $(datadir)/applications/bibus.desktop
+ #echo 'Icon=$(datadir)/icons/hicolor/48x48/apps/bibus.png' >> $(datadir)/applications/bibus.desktop
+
+ # bibus command
+- install -d $(bindir)
+- ln -sf $(datadir)/bibus/bibusStart.py $(bindir)/bibus
+- chmod 755 $(datadir)/bibus/bibusStart.py
++ install -d $(DESTDIR)/$(bindir)
++ ln -sf $(pythondir)/bibus/bibusStart.py $(DESTDIR)/$(bindir)/bibus
++ chmod 755 $(DESTDIR)$(pythondir)/bibus/bibusStart.py
+
+ # basic doc files
+- install -m755 -d $(datadir)/doc/bibus
+- install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/bibus
++ install -m755 -d $(DESTDIR)/$(datadir)/doc/${PF}
++ install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(DESTDIR)/$(datadir)/doc/${PF}
+
+ # generating bibus.cfg file
+- echo '[PATH]' > $(datadir)/bibus/bibus.cfg
+- echo 'python = $(python)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oopath = $(oopath)' >> $(datadir)/bibus/bibus.cfg
+- echo 'ooure = $(ooure)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oobasis = $(oobasis)' >> $(datadir)/bibus/bibus.cfg
+- echo 'docdir = $(datadir)/doc/bibus/html' >> $(datadir)/bibus/bibus.cfg
+- echo 'licence = $(datadir)/doc/bibus/copying' >> $(datadir)/bibus/bibus.cfg
+- echo 'localedir = $(datadir)/locale' >> $(datadir)/bibus/bibus.cfg
+- echo 'systemconf = $(sysconfdir)/bibus.config' >> $(datadir)/bibus/bibus.cfg
++ echo '[PATH]' > $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'python = $(python)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'oopath = $(oopath)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'ooure = $(ooure)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'oobasis = $(oobasis)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'docdir = $(datadir)/doc/${PF}/html' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'localedir = $(datadir)/locale' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'systemconf = $(sysconfdir)/bibus.config' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
+ endef
+
+ define install-doc-en
+ # copying docs in from Docs/html/en/ for bibus-doc-en
+ cd Docs;\
+- find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/bibus/'{}' ';'
++ find html/en/* -type f -exec install -m644 '{}' -D $(DESTDIR)/$(datadir)/doc/${PF}/'{}' ';'
+ endef
+
+ define compile
+ # compile recursively all the python files located in $(datadir)/bibus
+- $(python) -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
+- $(python) -O -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
++ echo "No compilation"
+ endef
+
+ install-files:
+@@ -83,15 +81,3 @@ install:
+ $(install-doc-en)
+ $(compile)
+
+- # write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
+- echo "#!/bin/sh" > $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(bindir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(man1dir)/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/doc/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
+- chmod 744 $(datadir)/bibus/Setup/uninstall.sh
+- # end uninstaller
diff --git a/app-text/bibus/metadata.xml b/app-text/bibus/metadata.xml
new file mode 100644
index 000000000000..3786591536b4
--- /dev/null
+++ b/app-text/bibus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <upstream>
+ <remote-id type="sourceforge">bibus-biblio</remote-id>
+ </upstream>
+</pkgmetadata>