summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-12-26 14:22:00 +0100
committerFabian Groffen <grobian@gentoo.org>2020-12-26 14:23:05 +0100
commite3cfabe13e91df178207d14493ef57a52fa1c19d (patch)
treead300bd04522d0f17c6ce0cad222fd9cb74e856f /app-text/enscript
parentsys-power/bbswitch: drop myself from maintainers. (diff)
downloadgentoo-e3cfabe13e91df178207d14493ef57a52fa1c19d.tar.gz
gentoo-e3cfabe13e91df178207d14493ef57a52fa1c19d.tar.bz2
gentoo-e3cfabe13e91df178207d14493ef57a52fa1c19d.zip
app-text/enscript: add Prefix changes
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-text/enscript')
-rw-r--r--app-text/enscript/enscript-1.6.6.ebuild3
-rw-r--r--app-text/enscript/files/enscript-1.6.4-fsf-gcc-darwin.patch37
2 files changed, 39 insertions, 1 deletions
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6.ebuild
index 7c4cc7ab16e2..d84f32db4b8f 100644
--- a/app-text/enscript/enscript-1.6.6.ebuild
+++ b/app-text/enscript/enscript-1.6.6.ebuild
@@ -9,7 +9,7 @@ DESCRIPTION="Powerful text-to-postscript converter"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
HOMEPAGE="https://www.gnu.org/software/enscript/enscript.html"
-KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
SLOT="0"
LICENSE="GPL-3"
IUSE="nls ruby"
@@ -24,6 +24,7 @@ RDEPEND="nls? ( virtual/libintl )"
src_prepare() {
epatch "${FILESDIR}"/enscript-1.6.4-ebuild.st.patch
epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
+ epatch "${FILESDIR}"/enscript-1.6.4-fsf-gcc-darwin.patch
use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
sed -i src/tests/passthrough.test -e 's|tail +2|tail -n +2|g' || die
default
diff --git a/app-text/enscript/files/enscript-1.6.4-fsf-gcc-darwin.patch b/app-text/enscript/files/enscript-1.6.4-fsf-gcc-darwin.patch
new file mode 100644
index 000000000000..3ea4bf97efd0
--- /dev/null
+++ b/app-text/enscript/files/enscript-1.6.4-fsf-gcc-darwin.patch
@@ -0,0 +1,37 @@
+darwin: __private_extern__ is an Apple-ism, we really don't want
+
+In particular FSF GCC barfs about this, which is much preferred over
+ancient gcc-apple (4.2.1).
+
+--- compat/regex.c
++++ compat/regex.c
+@@ -5539,9 +5539,6 @@
+ It returns 0 if it succeeds, nonzero if it doesn't. (See regex.h for
+ the return codes and their meanings.) */
+
+-#ifdef __APPLE__
+-__private_extern__
+-#endif
+ int
+ regcomp (preg, pattern, cflags)
+ regex_t *preg;
+@@ -5620,9 +5617,6 @@
+
+ We return 0 if we find a match and REG_NOMATCH if not. */
+
+-#ifdef __APPLE__
+-__private_extern__
+-#endif
+ int
+ regexec (preg, string, nmatch, pmatch, eflags)
+ const regex_t *preg;
+@@ -5728,9 +5722,6 @@
+
+ /* Free dynamically allocated space used by PREG. */
+
+-#ifdef __APPLE__
+-__private_extern__
+-#endif
+ void
+ regfree (preg)
+ regex_t *preg;