summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-06 21:37:16 +0000
committerSam James <sam@gentoo.org>2021-02-06 21:47:06 +0000
commite5ffb0981b1e222e55cf30e3274150ddcaeb2f9b (patch)
treea9189ffccb4b8f3142b0918c2e5a7d1599dd7f8d /app-text/pelican
parentdev-ml/jbuilder: fix dep for test (diff)
downloadgentoo-e5ffb0981b1e222e55cf30e3274150ddcaeb2f9b.tar.gz
gentoo-e5ffb0981b1e222e55cf30e3274150ddcaeb2f9b.tar.bz2
gentoo-e5ffb0981b1e222e55cf30e3274150ddcaeb2f9b.zip
app-text/pelican: fix DEPEND typo in earlier versions
Fixed in 4.5.3 anyway but let's do this just to be consistent. Closes: https://bugs.gentoo.org/648650 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/pelican-4.2.0-r1.ebuild (renamed from app-text/pelican/pelican-4.2.0.ebuild)15
-rw-r--r--app-text/pelican/pelican-4.5.1-r1.ebuild (renamed from app-text/pelican/pelican-4.5.1.ebuild)15
2 files changed, 18 insertions, 12 deletions
diff --git a/app-text/pelican/pelican-4.2.0.ebuild b/app-text/pelican/pelican-4.2.0-r1.ebuild
index d7e224477c45..78bf8edfb8c3 100644
--- a/app-text/pelican/pelican-4.2.0.ebuild
+++ b/app-text/pelican/pelican-4.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,6 +15,12 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="doc examples markdown test"
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ )
+"
DEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
@@ -26,11 +32,8 @@ DEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- )"
-RDEPEND=""
+"
+RDEPEND="${DEPEND}"
RESTRICT="test"
DOCS=( README.rst )
diff --git a/app-text/pelican/pelican-4.5.1.ebuild b/app-text/pelican/pelican-4.5.1-r1.ebuild
index 5f35be70237f..b43b78f34e59 100644
--- a/app-text/pelican/pelican-4.5.1.ebuild
+++ b/app-text/pelican/pelican-4.5.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples markdown test"
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ )
+"
DEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
@@ -27,11 +33,8 @@ DEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- )"
-RDEPEND=""
+"
+RDEPEND="${DEPEND}"
RESTRICT="test"
DOCS=( README.rst )