summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-03 19:39:40 +0100
committerSam James <sam@gentoo.org>2022-05-03 19:40:47 +0100
commite56156ff6b5bb4c6d78661151aa44dfa6a0f2271 (patch)
tree2ce47d846667815361856ebcb7d5ea938da411c5 /app-text/scdoc
parentapp-text/scdoc: fix incorrect prefix in pc file (diff)
downloadgentoo-e56156ff6b5bb4c6d78661151aa44dfa6a0f2271.tar.gz
gentoo-e56156ff6b5bb4c6d78661151aa44dfa6a0f2271.tar.bz2
gentoo-e56156ff6b5bb4c6d78661151aa44dfa6a0f2271.zip
app-text/scdoc: sync live, drop 1.11.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/scdoc')
-rw-r--r--app-text/scdoc/scdoc-1.11.2.ebuild45
-rw-r--r--app-text/scdoc/scdoc-9999.ebuild4
2 files changed, 2 insertions, 47 deletions
diff --git a/app-text/scdoc/scdoc-1.11.2.ebuild b/app-text/scdoc/scdoc-1.11.2.ebuild
deleted file mode 100644
index b2ab9d346396..000000000000
--- a/app-text/scdoc/scdoc-1.11.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="Standalone tool for generating man pages with a simple syntax"
-HOMEPAGE="https://git.sr.ht/~sircmpwn/scdoc"
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/scdoc"
- inherit git-r3
-else
- SRC_URI="https://git.sr.ht/~sircmpwn/scdoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-src_prepare() {
- default
-
- sed -e 's/-Werror//' \
- -i Makefile || die 'Failed to patch Makefile'
-}
-
-src_compile() {
- local MY_HS="./scdoc"
- if tc-is-cross-compiler; then
- tc-export_build_env
- MY_HS="./hostscdoc"
- emake scdoc HOST_SCDOC="./hostscdoc" OUTDIR="${S}/.build.host" CC="$(tc-getBUILD_CC)" \
- CFLAGS="${BUILD_CFLAGS} -DVERSION='\"${PV}\"'" LDFLAGS="${BUILD_LDFLAGS}"
- mv scdoc hostscdoc || die 'Failed to rename host scdoc'
- fi
-
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" HOST_SCDOC="${MY_HS}"
-}
-
-src_install() {
- emake DESTDIR="${ED}" PREFIX="/usr" HOST_SCDOC="${MY_HS}" \
- PCDIR="/usr/$(get_libdir)/pkgconfig" install
-}
diff --git a/app-text/scdoc/scdoc-9999.ebuild b/app-text/scdoc/scdoc-9999.ebuild
index b2ab9d346396..c40dcd50d0fa 100644
--- a/app-text/scdoc/scdoc-9999.ebuild
+++ b/app-text/scdoc/scdoc-9999.ebuild
@@ -36,10 +36,10 @@ src_compile() {
mv scdoc hostscdoc || die 'Failed to rename host scdoc'
fi
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" HOST_SCDOC="${MY_HS}"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}"
}
src_install() {
- emake DESTDIR="${ED}" PREFIX="/usr" HOST_SCDOC="${MY_HS}" \
+ emake DESTDIR="${ED}" PREFIX="${EPREFIX}/usr" HOST_SCDOC="${MY_HS}" \
PCDIR="/usr/$(get_libdir)/pkgconfig" install
}