summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-09-04 19:06:47 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-10-13 15:40:43 +0200
commit57eb11233b9f0c89c517e4b5c647f12924470614 (patch)
treef572471fc7d9d4bf15314b96e639cbb0fda995a5 /app-text
parentdev-python/spyder: remove unused patch (diff)
downloadgentoo-57eb11233b9f0c89c517e4b5c647f12924470614.tar.gz
gentoo-57eb11233b9f0c89c517e4b5c647f12924470614.tar.bz2
gentoo-57eb11233b9f0c89c517e4b5c647f12924470614.zip
app-text/wv2: delete unused libtool files
Closes: https://bugs.gentoo.org/841964 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/38438 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wv2/wv2-0.4.2-r4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/wv2/wv2-0.4.2-r4.ebuild b/app-text/wv2/wv2-0.4.2-r4.ebuild
new file mode 100644
index 000000000000..991e3e04721b
--- /dev/null
+++ b/app-text/wv2/wv2-0.4.2-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Excellent MS Word filter lib, used in most Office suites"
+HOMEPAGE="https://wvware.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/wvware/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="zlib"
+
+RDEPEND="dev-libs/glib
+ >=gnome-extra/libgsf-1.8:=
+ virtual/libiconv
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glib.patch
+ "${FILESDIR}"/${P}-libgsf.patch
+)
+
+DOCS=( AUTHORS ChangeLog README RELEASE THANKS TODO )
+
+src_configure() {
+ # Due to ICU 59 requiring C++11 now
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DWITH_ZLIB=$(usex zlib)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ find "${ED}" -name '*.la' -delete || die
+}