summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-27 13:28:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-27 13:28:02 +0300
commitd8bd703761f19feaa27f07f7e083fbab97f70849 (patch)
tree0fe30515f71790bd600b5cc14b962522e72b0430 /app-text
parentgui-apps/waypipe: add 0.9.1 (diff)
downloadgentoo-d8bd703761f19feaa27f07f7e083fbab97f70849.tar.gz
gentoo-d8bd703761f19feaa27f07f7e083fbab97f70849.tar.bz2
gentoo-d8bd703761f19feaa27f07f7e083fbab97f70849.zip
app-text/feathernotes: add 1.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/feathernotes/Manifest1
-rw-r--r--app-text/feathernotes/feathernotes-1.3.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-text/feathernotes/Manifest b/app-text/feathernotes/Manifest
index e7f3dcef6859..853797035663 100644
--- a/app-text/feathernotes/Manifest
+++ b/app-text/feathernotes/Manifest
@@ -1 +1,2 @@
DIST feathernotes-1.2.0.tar.gz 926273 BLAKE2B ae945ae6adb95d3cd8ef42becfcd68a591ef62f97f05d514f19a9c07e6900b2230e89361b65abfc2082797755bcb8b6c521b72a6406a21886ba6ab386f23295f SHA512 f6aabc0d4bee5f3af20a86035befbc27eddedc5ec37c9a353723a80fb0f691af6ad57d5f50a0e8504336c141822227f8287ed61e52d084b34e3b8ab5246315c0
+DIST feathernotes-1.3.0.tar.gz 926547 BLAKE2B 5fe3475793a28a8e4c41c669c7fdde5785abdc4b93b14ca47bf531d5bf246c7ec064c3d5f756b184a45a39d5f02047cca90ad0c37c050c7a1ef363148705c592 SHA512 1036a4ed37e90cbf7e2e7839abcbe5d544a3e162839b05461ec0cea475a4cb3cce44941246e30f3aed6839e4fe9832392f33bfe87b19588d822ce19983dacc2e
diff --git a/app-text/feathernotes/feathernotes-1.3.0.ebuild b/app-text/feathernotes/feathernotes-1.3.0.ebuild
new file mode 100644
index 000000000000..3f3075fd6e7a
--- /dev/null
+++ b/app-text/feathernotes/feathernotes-1.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION=" Lightweight Qt Notes-Manager for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherNotes"
+SRC_URI="https://github.com/tsujan/FeatherNotes/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherNotes-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="spell X"
+
+RDEPEND="
+ dev-qt/qtbase:6[dbus,gui,network,widgets,xml,X?]
+ dev-qt/qtsvg:6
+ spell? ( app-text/hunspell:= )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ -DWITH_HUNSPELL=$(usex spell)
+ )
+ cmake_src_configure
+}