summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 17:48:03 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:43 +0200
commit2aa32f09bf0ef14505f97452fa81e4d9f4d05e62 (patch)
tree6455068ee6d018c53c4e662f031ce4ca27043338 /app-vim
parentapp-vim/pfsyntax: EAPI8 bump (diff)
downloadgentoo-2aa32f09bf0ef14505f97452fa81e4d9f4d05e62.tar.gz
gentoo-2aa32f09bf0ef14505f97452fa81e4d9f4d05e62.tar.bz2
gentoo-2aa32f09bf0ef14505f97452fa81e4d9f4d05e62.zip
app-vim/phpdocs: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/phpdocs/phpdocs-0.26-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/phpdocs/phpdocs-0.26-r2.ebuild b/app-vim/phpdocs/phpdocs-0.26-r2.ebuild
new file mode 100644
index 000000000000..6309b5e44090
--- /dev/null
+++ b/app-vim/phpdocs/phpdocs-0.26-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: PHPDoc Support in VIM"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=520"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+VIM_PLUGIN_HELPURI="https://www.vim.org/scripts/script.php?script_id=520"
+
+src_prepare() {
+ default
+ sed -i 's/\r$//' "${S}"/plugin/phpdoc.vim || die "sed failed"
+}