summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-07-04 15:31:01 +0200
committerDavid Seifert <soap@gentoo.org>2024-07-04 15:31:01 +0200
commit28be685dab7ff1520f00815fc6653093d995cf9f (patch)
treeac53055d2747c16cd0e3a62327b7d5ec0d48266d /dev-build
parentmedia-gfx/graphviz: add 12.0.0 (diff)
downloadgentoo-28be685dab7ff1520f00815fc6653093d995cf9f.tar.gz
gentoo-28be685dab7ff1520f00815fc6653093d995cf9f.tar.bz2
gentoo-28be685dab7ff1520f00815fc6653093d995cf9f.zip
dev-build/b2: add 5.2.1
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/b2/Manifest1
-rw-r--r--dev-build/b2/b2-5.2.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-build/b2/Manifest b/dev-build/b2/Manifest
index ba055543ca84..db60a05ceaf1 100644
--- a/dev-build/b2/Manifest
+++ b/dev-build/b2/Manifest
@@ -1 +1,2 @@
DIST b2-5.0.0.tar.gz 1015818 BLAKE2B 87b6f34733002479f91f658aee4f776930ae6441f33b2540b82049e18c4199280e73047afafa90dc156cc75db8b587c5bb9e2ce65d93c493775ac4107ce3201b SHA512 37403f0bd863753c5313393405dd8514a4f8d9f0839ccd397ee1856e02af6116bd238d345e5b766512441ca1c0b09883386588e270bd982eca45235eef1b01b7
+DIST b2-5.2.1.tar.gz 1189393 BLAKE2B 26ddc5fa038e899c8e08a27cd79d9b3e39f7a7b6244ea77be4dbe2dff3a7d7309936898362759197850c38789a97c27ca2bf2995ceb14e223fc7045d645328c9 SHA512 5ff2f5735cb34159acc0f8b39a45787bb46731a819658d9374971e8a87e65997249d542c44fe7c7ee197d24ef380c4f523f8c946ac43a97a6ea7a86c91538a36
diff --git a/dev-build/b2/b2-5.2.1.ebuild b/dev-build/b2/b2-5.2.1.ebuild
new file mode 100644
index 000000000000..0b95e8de55af
--- /dev/null
+++ b/dev-build/b2/b2-5.2.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo flag-o-matic toolchain-funcs
+
+MY_PV="$(ver_rs 1- _)"
+
+DESCRIPTION="A system for large project software construction, simple to use and powerful"
+HOMEPAGE="https://www.bfgroup.xyz/b2/"
+SRC_URI="https://github.com/bfgroup/b2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples"
+RESTRICT="test"
+
+RDEPEND="!dev-util/boost-build"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.9.2-disable_python_rpath.patch
+ "${FILESDIR}"/${PN}-4.9.2-darwin-gentoo-toolchain.patch
+ "${FILESDIR}"/${PN}-4.9.2-add-none-feature-options.patch
+ "${FILESDIR}"/${PN}-4.9.2-no-implicit-march-flags.patch
+)
+
+src_configure() {
+ # need to enable LFS explicitly for 64-bit offsets on 32-bit hosts (#761100)
+ append-lfs-flags
+}
+
+src_compile() {
+ cd engine || die
+
+ # don't call windres since it leads to broken relocations
+ export B2_DONT_EMBED_MANIFEST=1
+
+ # upstream doesn't want separate flags for CPPFLAGS/LDFLAGS
+ # https://github.com/bfgroup/b2/pull/187#issuecomment-1335688424
+ edo ${CONFIG_SHELL:-${BASH}} ./build.sh cxx \
+ --cxx="$(tc-getCXX)" \
+ --cxxflags="-pthread ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS}" \
+ -d+2 \
+ --without-python
+}
+
+src_test() {
+ # Forget tests, b2 is a lost cause
+ :
+}
+
+src_install() {
+ dobin engine/b2
+
+ insinto /usr/share/b2/src
+ doins -r "${FILESDIR}/site-config.jam" \
+ build-system.jam ../example/user-config.jam \
+ build contrib options tools util
+
+ find "${ED}"/usr/share/b2/src -iname '*.py' -delete || die
+
+ dodoc ../notes/{changes,release_procedure,build_dir_option,relative_source_paths}.txt
+
+ if use examples; then
+ docinto examples
+ dodoc -r ../example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}