summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-17 16:08:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-17 18:14:50 +0100
commit2a669a90ef23015afd8008e70bc5d39cf0994e1e (patch)
treef8dbefb48499af1132d887ea7fd4508ce360957d /dev-build
parentMove {dev-util → dev-build}/scons (diff)
downloadgentoo-2a669a90ef23015afd8008e70bc5d39cf0994e1e.tar.gz
gentoo-2a669a90ef23015afd8008e70bc5d39cf0994e1e.tar.bz2
gentoo-2a669a90ef23015afd8008e70bc5d39cf0994e1e.zip
Move {sys-devel → dev-build}/qconf
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/qconf/Manifest1
-rw-r--r--dev-build/qconf/metadata.xml15
-rw-r--r--dev-build/qconf/qconf-2.5.ebuild39
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-build/qconf/Manifest b/dev-build/qconf/Manifest
new file mode 100644
index 000000000000..87fc52a38213
--- /dev/null
+++ b/dev-build/qconf/Manifest
@@ -0,0 +1 @@
+DIST qconf-2.5.tar.gz 100704 BLAKE2B 01dcca053e020cfc76e8595927dd3cedb6c82ade24381c95935c87994037ca5129f5e9e0ec58dd0e0fc6815b1500249b767367fbf7a16549459f814bb1591368 SHA512 4ce032eb5b9ba2d584807b3283b0dd5cf973c2fdd6792dfec13c54bb7c639d23eeaab03eb52f1a395113d973d2b01d87bf713d717e691641203865b934c7da5e
diff --git a/dev-build/qconf/metadata.xml b/dev-build/qconf/metadata.xml
new file mode 100644
index 000000000000..ad30d60d9ef0
--- /dev/null
+++ b/dev-build/qconf/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>rion4ik@gmail.com</email>
+ <name>Sergey Ilinykh</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">psi-plus/qconf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-build/qconf/qconf-2.5.ebuild b/dev-build/qconf/qconf-2.5.ebuild
new file mode 100644
index 000000000000..9da668afb0f6
--- /dev/null
+++ b/dev-build/qconf/qconf-2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="https://github.com/psi-im/qconf"
+SRC_URI="https://github.com/psi-im/qconf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ppc64 ~sparc x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # not autotools configure, so don't use econf
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --qtdir="$(qt5_get_libdir)/qt5" \
+ --extraconf=QMAKE_STRIP= \
+ --verbose || die "configure failed"
+
+ # just to set all the Gentoo toolchain flags
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ dodoc -r examples
+}