summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2023-06-14 21:31:01 +0200
committerSam James <sam@gentoo.org>2023-06-14 20:41:38 +0100
commit7988d3b88a7b4ec99a57886f2ec8bed6fc7a2b45 (patch)
tree0bbbce56c02ea8eef42c87f198391c0d42f38dbf /dev-cpp/jwt-cpp
parentprofiles/license_groups: drop now unused license (diff)
downloadgentoo-7988d3b88a7b4ec99a57886f2ec8bed6fc7a2b45.tar.gz
gentoo-7988d3b88a7b4ec99a57886f2ec8bed6fc7a2b45.tar.bz2
gentoo-7988d3b88a7b4ec99a57886f2ec8bed6fc7a2b45.zip
dev-cpp/jwt-cpp: add patch for gcc 13
Closes: https://bugs.gentoo.org/908497 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Closes: https://github.com/gentoo/gentoo/pull/31438 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/jwt-cpp')
-rw-r--r--dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch14
-rw-r--r--dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild3
2 files changed, 17 insertions, 0 deletions
diff --git a/dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch b/dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch
new file mode 100644
index 000000000000..3fef24536a86
--- /dev/null
+++ b/dev-cpp/jwt-cpp/files/jwt-cpp-0.6.0-gcc13.patch
@@ -0,0 +1,14 @@
+From: Hannu Lounento <hannu.lounento@vaisala.com>
+Bug: https://github.com/Thalhammer/jwt-cpp/pull/287
+
+Fix build with GCC 13.
+
+--- a/include/jwt-cpp/base.h
++++ b/include/jwt-cpp/base.h
+@@ -3,6 +3,7 @@
+
+ #include <array>
++#include <cstdint>
+ #include <stdexcept>
+ #include <string>
+
diff --git a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild b/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
index c7f9802a739a..8d2bc1f2fe86 100644
--- a/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
+++ b/dev-cpp/jwt-cpp/jwt-cpp-0.6.0.ebuild
@@ -34,6 +34,9 @@ RESTRICT="
!picojson? ( test )
!test? ( test )
"
+PATCHES=(
+ "${FILESDIR}"/"${PN}"-0.6.0-gcc13.patch
+)
DOCS=( README.md docs/{faqs,ssl,traits}.md )
src_prepare() {