summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-08-28 12:56:49 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-09-13 10:20:39 +0300
commitb661d30cd35229acb54f42c208b226bdd59286aa (patch)
tree267886ef6e479b2c8ee8ed4864ab3884b1e2e541 /dev-cpp
parentdev-cpp/valijson: add 1.0.3 (diff)
downloadgentoo-b661d30cd35229acb54f42c208b226bdd59286aa.tar.gz
gentoo-b661d30cd35229acb54f42c208b226bdd59286aa.tar.bz2
gentoo-b661d30cd35229acb54f42c208b226bdd59286aa.zip
dev-cpp/valijson: clean up old
Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/38314 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/valijson/Manifest1
-rw-r--r--dev-cpp/valijson/files/1.0-fix-macro-typos.patch77
-rw-r--r--dev-cpp/valijson/valijson-1.0.ebuild24
3 files changed, 0 insertions, 102 deletions
diff --git a/dev-cpp/valijson/Manifest b/dev-cpp/valijson/Manifest
index da5681470d90..2827b7834556 100644
--- a/dev-cpp/valijson/Manifest
+++ b/dev-cpp/valijson/Manifest
@@ -1,3 +1,2 @@
DIST valijson-1.0.2.tar.gz 723131 BLAKE2B ada64202d1c82f4e24c8fb3935a070ee40a24e8b75712fd4392f19c93c363d293db788cd1481ed3a857721fcd6f87e2d91c3b9779863fb6e2421ba4ee4f1d1f7 SHA512 c1141e533d6a791a01883c5b7ab9501eebc39057a850d784670a4bcf99bff3fee4c3120107128dcaa9db0505adf2ae794700620c02163b3e636f0b635031df80
DIST valijson-1.0.3.tar.gz 727517 BLAKE2B c0bf5bc3aedf1462ae7cf30d64acc6d91e620cdd747f13f05f25df07074731dc2b611a07cb6204a5883641bd73c80dc4042a5a804e2aac23a24464add378ea7e SHA512 5ab67d27c8906c116e65198831ebfc3e5a1772087b7cfe316bde7d2bbd78a7ec3bf0e8fc803fc4528779fe2515e72711b8cb14f05ca6f5bf01af2b5e9ca396fa
-DIST valijson-1.0.tar.gz 721078 BLAKE2B 74f4a061266a6ee8fba9d93b4e1df20dc828d85169f865bdb60ba9f5217ee422324a09788b02b4ddd18a92d906c64863a5bd7c1250f8bdb62fd9f00f3d73c7e7 SHA512 a206954b11e92cbebbebf094e6f0925a270ebd6bec49cbdb7adda5a4cec93587a5a61ebbce105846c3950cf5df74bfdd5f5bb1ffbf73315f45c7a6cda2b77db9
diff --git a/dev-cpp/valijson/files/1.0-fix-macro-typos.patch b/dev-cpp/valijson/files/1.0-fix-macro-typos.patch
deleted file mode 100644
index f90e88dabe92..000000000000
--- a/dev-cpp/valijson/files/1.0-fix-macro-typos.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-
-Patch from:
-https://github.com/tristanpenman/valijson/commit/f1ff3518281fe347c97b78384d6bb645dbdd4788
-
-From f1ff3518281fe347c97b78384d6bb645dbdd4788 Mon Sep 17 00:00:00 2001
-From: Austin Haigh <austin.haigh@hach.com>
-Date: Tue, 1 Nov 2022 13:29:16 -0600
-Subject: [PATCH] fix typos in preprocessor macros
-
----
- examples/valijson_nlohmann_bundled.hpp | 2 +-
- include/valijson/utils/boost_json_utils.hpp | 4 ++--
- include/valijson/utils/nlohmann_json_utils.hpp | 2 +-
- include/valijson/utils/property_tree_utils.hpp | 2 +-
- 4 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/examples/valijson_nlohmann_bundled.hpp b/examples/valijson_nlohmann_bundled.hpp
-index 806f329..915bebb 100644
---- a/examples/valijson_nlohmann_bundled.hpp
-+++ b/examples/valijson_nlohmann_bundled.hpp
-@@ -10561,7 +10561,7 @@ inline bool loadDocument(const std::string &path, nlohmann::json &document)
- }
-
- // Parse schema
--#if VALIJSON_USE_EXCEPTION
-+#if VALIJSON_USE_EXCEPTIONS
- try {
- document = nlohmann::json::parse(file);
- } catch (std::invalid_argument const& exception) {
-diff --git a/include/valijson/utils/boost_json_utils.hpp b/include/valijson/utils/boost_json_utils.hpp
-index 1168903..0fbd6c3 100644
---- a/include/valijson/utils/boost_json_utils.hpp
-+++ b/include/valijson/utils/boost_json_utils.hpp
-@@ -20,7 +20,7 @@ inline bool loadDocument(const std::string &path, boost::json::value &document)
- }
-
- // Parse schema
--#if VALIJSON_USE_EXCEPTION
-+#if VALIJSON_USE_EXCEPTIONS
- try {
- #endif
- boost::json::error_code errorCode;
-@@ -30,7 +30,7 @@ inline bool loadDocument(const std::string &path, boost::json::value &document)
- std::cerr << "Boost.JSON parsing error: " << errorCode.message();
- return false;
- }
--#if VALIJSON_USE_EXCEPTION
-+#if VALIJSON_USE_EXCEPTIONS
- } catch (std::exception const & exception) {
- std::cerr << "Boost.JSON parsing exception: " << exception.what();
- return false;
-diff --git a/include/valijson/utils/nlohmann_json_utils.hpp b/include/valijson/utils/nlohmann_json_utils.hpp
-index b3cbe20..77e5771 100644
---- a/include/valijson/utils/nlohmann_json_utils.hpp
-+++ b/include/valijson/utils/nlohmann_json_utils.hpp
-@@ -20,7 +20,7 @@ inline bool loadDocument(const std::string &path, nlohmann::json &document)
- }
-
- // Parse schema
--#if VALIJSON_USE_EXCEPTION
-+#if VALIJSON_USE_EXCEPTIONS
- try {
- document = nlohmann::json::parse(file);
- } catch (std::invalid_argument const& exception) {
-diff --git a/include/valijson/utils/property_tree_utils.hpp b/include/valijson/utils/property_tree_utils.hpp
-index 2317f12..7438980 100644
---- a/include/valijson/utils/property_tree_utils.hpp
-+++ b/include/valijson/utils/property_tree_utils.hpp
-@@ -24,7 +24,7 @@
- #include <valijson/utils/file_utils.hpp>
- #include <valijson/exceptions.hpp>
-
--#if !VALIJSON_USE_EXCEPTION
-+#if !VALIJSON_USE_EXCEPTIONS
-
- namespace boost {
-
diff --git a/dev-cpp/valijson/valijson-1.0.ebuild b/dev-cpp/valijson/valijson-1.0.ebuild
deleted file mode 100644
index bc4327b63333..000000000000
--- a/dev-cpp/valijson/valijson-1.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Header-only C++ library for JSON Schema validation"
-HOMEPAGE="https://github.com/tristanpenman/valijson"
-SRC_URI="https://github.com/tristanpenman/valijson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2 Boost-1.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-fix-macro-typos.patch
-)
-
-src_install() {
- # there is no target for installing headers, so do it manually
- doheader -r include/*
-}