summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-04-04 21:59:14 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-06-07 16:15:06 +0300
commitbb540883769f6387fa4bf7e69392b60145076767 (patch)
treef1de8894d90dadaaf17e67c3a1c5e5c227789cd1 /dev-cpp
parentdev-cpp/asio: drop 1.28.0 (diff)
downloadgentoo-bb540883769f6387fa4bf7e69392b60145076767.tar.gz
gentoo-bb540883769f6387fa4bf7e69392b60145076767.tar.bz2
gentoo-bb540883769f6387fa4bf7e69392b60145076767.zip
dev-cpp/asio: add 1.30.1
Removed IUSE=doc because docs are only available in tarball published on sourcefourge, not in auto tarballs from github; but versions after 1.28.1 are not available on sourcefourge, but only as git tags. Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/36111 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.30.1.ebuild58
-rw-r--r--dev-cpp/asio/files/asio-1.30.1-pkgconfig.patch24
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index 2a55d1eb389a..a58dd01a51e8 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1 +1,2 @@
+DIST asio-1-30-1.tar.gz 2842718 BLAKE2B b99f6e1ab03c4da9bc802e04d66b46ac2374f7da9f65dd98dd3da3cf1cf507548ae2645343a63378ab91d665fc6e2efe5c5262f33757e851973534e23291abb1 SHA512 6b5f41479e20500dff6c535d8e3b096e11815784923bb4c0f68f69be59c80d7ad99c7e0380a1de4dd350e6cc6a79315d4645378a9b8d70d9f8d28a17f1cc68af
DIST asio-1.28.1.tar.bz2 3383257 BLAKE2B 9d98152a6cf8b0e2a807275092b23f6198d8175fd7260499be7561cea2e6723c1a8478107315b7163cdc31d6eecab552550393ab3b1cfb686dcb4157d1e91fe4 SHA512 fadd7748675743ba9110f873bf57f2400a5c9c0dc03c1d6cd7f0988bc70ccbbff6cb6140f5dd236d2d874fc82a6f216406e8892808e915aae5119fe9d95743de
diff --git a/dev-cpp/asio/asio-1.30.1.ebuild b/dev-cpp/asio/asio-1.30.1.ebuild
new file mode 100644
index 000000000000..064e9c09bbe5
--- /dev/null
+++ b/dev-cpp/asio/asio-1.30.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="https://github.com/chriskohlhoff/asio/archive/refs/tags/asio-${PV//./-}.tar.gz"
+S="${WORKDIR}/asio-asio-${PV//./-}/asio"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/asio-1.30.1-pkgconfig.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-cpp/asio/files/asio-1.30.1-pkgconfig.patch b/dev-cpp/asio/files/asio-1.30.1-pkgconfig.patch
new file mode 100644
index 000000000000..c58b2a9df86d
--- /dev/null
+++ b/dev-cpp/asio/files/asio-1.30.1-pkgconfig.patch
@@ -0,0 +1,24 @@
+Install .pc file to /usr/share instead of /usr/lib because there are no .so files
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,6 @@
+ AUTOMAKE_OPTIONS = foreign dist-bzip2 dist-zip
+
+-pkgconfig_DATA = asio.pc
+-pkgconfigdir = $(libdir)/pkgconfig
++noarch_pkgconfig_DATA = asio.pc
+
+ SUBDIRS = include src
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -8,7 +8,7 @@ AM_PROG_CC_C_O
+ AC_PROG_CXX
+ AC_LANG(C++)
+ AC_PROG_RANLIB
+-PKG_INSTALLDIR
++PKG_NOARCH_INSTALLDIR
+
+ AC_DEFINE(_REENTRANT, [1], [Define this])
+