summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-01-18 10:26:32 +0100
committerDavid Seifert <soap@gentoo.org>2024-01-18 10:26:32 +0100
commitc52b95a02d0a8139e55c053b07b9bd8aa7e94761 (patch)
treeb3a27e635190a5a5e2336e41b4c9115668cfcbe5 /dev-cpp
parentapp-backup/borgmatic: Keyword 1.8.5 arm64, #920668 (diff)
downloadgentoo-c52b95a02d0a8139e55c053b07b9bd8aa7e94761.tar.gz
gentoo-c52b95a02d0a8139e55c053b07b9bd8aa7e94761.tar.bz2
gentoo-c52b95a02d0a8139e55c053b07b9bd8aa7e94761.zip
dev-cpp/catch: add 3.5.2
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-3.5.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
index c2a90ab4889f..57f4ff1bb23e 100644
--- a/dev-cpp/catch/Manifest
+++ b/dev-cpp/catch/Manifest
@@ -2,3 +2,4 @@ DIST Catch-1.12.2.tar.gz 377265 BLAKE2B bc27b4daee950f8fb93d65f3aed032e72bc856ee
DIST Catch2-2.13.8.tar.gz 661711 BLAKE2B 973cc73c1d158140645003e76c0baf85a65252041fdcae3c6ecb1857021f2d24d8e879fec5f00368f4f458e69b450603a1613ac587417725980f1dbfe3ff2e65 SHA512 68a45efa47beb3c85d2d7b8a8eba89b8ec1664b4a72bb223227fef1632778aeaf5cf5cc09f40e47aef50426c8661c7d6a69c2dab0b88fbbf7d9a6b2974d6e32e
DIST Catch2-3.4.0.tar.gz 1112790 BLAKE2B 0e3680b6e9d01d7661243097ec4a8e20d06a145acfe381cedc8eb2507c5df1bfb2b2907a9ae2771ffd94b66a0aa8f746aae4419ed4f469bea27c3bfca366ca3e SHA512 3b452378201ac53c9ffba7801231aa3b32c5fb496f01d670fcee25baf95f405e565ae2aafba49ea5694f906fc61a8b04592c68b9fb12839767070587a48c89fa
DIST Catch2-3.5.1.tar.gz 1159629 BLAKE2B 54a7bee21a7874ba03813854b2f12f277def7a3823647abc3cf6638f7717e82bd3089f2b630c06a7b7a35aeffbf7cc02c8fb20a9392127ce9435c0d3396a89ce SHA512 90c5fcf2d4b9771f5b30e027099da0d15e294b85d28702020435606efda2a4edc96b3d2007b60e5a32178248ad129b4aba0fb96582156244d62e1edacda6ce7d
+DIST Catch2-3.5.2.tar.gz 1159985 BLAKE2B 6aa810926f68098a8ac18bf3b045b0bf1be3632e3b34a59561c337312d0501199df7baf49d242c0dd6eeb3f4a9ca77c5545b86092e10865452f7bacaa13ea2a3 SHA512 1b9d5f35144f6c7acef0e76558a4adf3ff41c2c2292fbdcb3e2c2917fa2deb7fba593738105dd3c111f02ee8aca64010cf68f69bb8fb1815dbf771b509ab0576
diff --git a/dev-cpp/catch/catch-3.5.2.ebuild b/dev-cpp/catch/catch-3.5.2.ebuild
new file mode 100644
index 000000000000..cde2d006ed7f
--- /dev/null
+++ b/dev-cpp/catch/catch-3.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-any-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/catchorg/Catch2.git"
+else
+ MY_P=${PN^}2-${PV}
+ SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/catchorg/Catch2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCATCH_DEVELOPMENT_BUILD=ON
+ -DCATCH_ENABLE_WERROR=OFF
+ -DCATCH_BUILD_TESTING=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+}