summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-05-23 02:00:33 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-05-23 02:00:33 -0500
commitfcb2ebb167a148788105c74491aaa33cb510a5b4 (patch)
treecb6a528593d545ab66053ff79262d34d88717b8d /dev-cpp
parentdev-ruby/faraday: add 1.0.1 (diff)
downloadgentoo-fcb2ebb167a148788105c74491aaa33cb510a5b4.tar.gz
gentoo-fcb2ebb167a148788105c74491aaa33cb510a5b4.tar.bz2
gentoo-fcb2ebb167a148788105c74491aaa33cb510a5b4.zip
dev-cpp/cpp-taskflow: new package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpp-taskflow/Manifest1
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild27
-rw-r--r--dev-cpp/cpp-taskflow/metadata.xml20
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-cpp/cpp-taskflow/Manifest b/dev-cpp/cpp-taskflow/Manifest
new file mode 100644
index 000000000000..4c62f183ab25
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/Manifest
@@ -0,0 +1 @@
+DIST cpp-taskflow-2.4.0.tar.gz 76993334 BLAKE2B 8f257165ab72dbe6c1cf6a86886669008e9f16f1dfd4871defc452bdb9dfa3e45ab9bfbbdc874b4ba566a2a7d8984a666ce2933b2c6d2215467f7fbfa03ac520 SHA512 dd6c7500e39d7058871280d12e120bd28d9609e5289f1d7851b3b59e2c1bfe74d3040d902bd5b26895e558b563c8abad878e7bc343e199e7356940c02a64217f
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild
new file mode 100644
index 000000000000..a41d26101436
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+HTML_DOCS=( docs/. )
+
+src_install() {
+ insinto /usr/include
+ doins -r taskflow
+
+ if $(use doc); then
+ einstalldocs
+ fi
+}
diff --git a/dev-cpp/cpp-taskflow/metadata.xml b/dev-cpp/cpp-taskflow/metadata.xml
new file mode 100644
index 000000000000..8406ef2081f1
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Cpp-Taskflow is faster, more expressive, and easier for drop-in
+ integration than many of existing task programming frameworks in
+ handling complex parallel workloads.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">cpp-taskflow/cpp-taskflow</remote-id>
+ </upstream>
+</pkgmetadata>