summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeaaru <geaaru@gmail.com>2018-08-28 22:09:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-01 00:12:32 +0200
commit94b2b8a10c2b8710a6059eba385544e893621e4c (patch)
treefe13c7cfdf7a6392a6499e4091d2f1ed6058b6b6 /dev-db/cpp-driver/cpp-driver-2.9.0.ebuild
parentmedia-gfx/opentoonz: remove unused patch. (diff)
downloadgentoo-94b2b8a10c2b8710a6059eba385544e893621e4c.tar.gz
gentoo-94b2b8a10c2b8710a6059eba385544e893621e4c.tar.bz2
gentoo-94b2b8a10c2b8710a6059eba385544e893621e4c.zip
dev-db/cpp-driver: version bump to 2.9.0.
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9723
Diffstat (limited to 'dev-db/cpp-driver/cpp-driver-2.9.0.ebuild')
-rw-r--r--dev-db/cpp-driver/cpp-driver-2.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-db/cpp-driver/cpp-driver-2.9.0.ebuild b/dev-db/cpp-driver/cpp-driver-2.9.0.ebuild
new file mode 100644
index 000000000000..66d76de1def7
--- /dev/null
+++ b/dev-db/cpp-driver/cpp-driver-2.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="DataStax C/C++ Driver for Cassandra"
+HOMEPAGE="https://datastax.github.io/cpp-driver/"
+SRC_URI="https://github.com/datastax/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl ssl"
+
+RDEPEND="
+ dev-libs/libuv:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCASS_USE_OPENSSL=$(usex ssl) )
+ cmake-utils_src_configure
+}