summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-01-05 15:40:35 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-01-05 15:41:41 +0100
commit9d66db3f16330d24435db055f6f97e660efbe9a0 (patch)
tree43c7ae1955c45e873cd8ca5da60ddf6860282ff3 /dev-db/etcd
parentdev-libs/libpqxx: Bump to 6.0.0 (diff)
downloadgentoo-9d66db3f16330d24435db055f6f97e660efbe9a0.tar.gz
gentoo-9d66db3f16330d24435db055f6f97e660efbe9a0.tar.bz2
gentoo-9d66db3f16330d24435db055f6f97e660efbe9a0.zip
dev-db/etcd: Version bump to 3.2.13
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-db/etcd')
-rw-r--r--dev-db/etcd/Manifest1
-rw-r--r--dev-db/etcd/etcd-3.2.13.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index f981842ae878..21c5652dc6f9 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -1,3 +1,4 @@
DIST etcd-2.3.8.tar.gz 2206562 BLAKE2B 754930b4b5f0e90386b2b4765a9dbb6790ae509a81d3430c3f7c2c828d90318db3b01a2faea0c7075078096ce74302f2be7444245047534749f49d13a927851e SHA512 4268de32797cab23e9e47784d31d5abd6982068c53d3cc9735a06719740dba45b73f4e067cbc7aa8aef5ca7c56d8be067f1076685ac82f64012b760d8b7f2bfc
DIST etcd-3.2.11.tar.gz 3016255 BLAKE2B b57d70ab50e9b8c7bf11920c0bf18789975af7f4f1d66b0afb17ba1d4830250972ba2e276de4d67b80bec317cf9d35eac7f63f8ca7c7c25fce2947807dcc42f8 SHA512 e0a71d43d6595c0a08a6068addcf13c98d3d8bd6873c9b5ac39b6183daea34191c1b81a2c81f5c7ec98d587c85f3b1af8cd584d7a0857668f77fb80151858fdb
DIST etcd-3.2.12.tar.gz 3046578 BLAKE2B 7b7a071c6856a7f1b5b7ceb68a4efbac74fde6ed1211dabda7d715ea79cd4dc9c10b0f1345d70b8a21e52cb3ac6adfc37c232ea28ff88e5f401212b5a8610d73 SHA512 b672a35ba62efccffa09be6b3d2a84b99e8abcae87093539c705d82e13c0f985a9f07a3d885af7386595f12d433756176db107739749c301e7e5d096e85d018b
+DIST etcd-3.2.13.tar.gz 3047049 BLAKE2B f0ac987aef60fcc28636cfb60d5f4e00daee29a3d5167900599760090c3fa3d7932abb6224df5fb66ea5bdbc29a9ce7f7263a0e81522853ab190be94a6551ebc SHA512 4f3c5856ecf9e8a725d0ef80bb584e7b2edaf7215635a5c74fe32b175ce9f8d07ba57685586dfd79b893d04641d4169382d22f2eea442efc1112fa91c8175d45
diff --git a/dev-db/etcd/etcd-3.2.13.ebuild b/dev-db/etcd/etcd-3.2.13.ebuild
new file mode 100644
index 000000000000..34692b679e18
--- /dev/null
+++ b/dev-db/etcd/etcd-3.2.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/coreos/etcd"
+DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/coreos/etcd"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc"
+DEPEND=">=dev-lang/go-1.8:="
+RDEPEND="!dev-db/etcdctl"
+
+src_prepare() {
+ default
+ sed -e 's|GIT_SHA=.*|GIT_SHA=v${PV}|'\
+ -i "${S}"/src/${EGO_PN}/build || die
+}
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_compile() {
+ export GOPATH=${S}
+ pushd src/${EGO_PN} || die
+ ./build || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ insinto /etc/${PN}
+ doins "${FILESDIR}/${PN}.conf"
+ dobin bin/*
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ dodir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 0700 /var/lib/${PN}
+ dodir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 755 /var/log/${PN}
+ popd || die
+}
+
+src_test() {
+ pushd src/${EGO_PN} || die
+ ./test || die
+ popd || die
+}