summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-01-15 14:40:56 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-01-15 14:41:20 +0000
commit85d8313ed3c9c35edd30d58257227c9e580f3fce (patch)
treeb1f454e4c078b44648c848213d9d8d4e01f48676 /dev-db/timescaledb
parentmedia-radio/gpredict: Fix QA - add missing remote Id (diff)
downloadgentoo-85d8313ed3c9c35edd30d58257227c9e580f3fce.tar.gz
gentoo-85d8313ed3c9c35edd30d58257227c9e580f3fce.tar.bz2
gentoo-85d8313ed3c9c35edd30d58257227c9e580f3fce.zip
dev-db/timescaledb: add 2.13.1
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/timescaledb')
-rw-r--r--dev-db/timescaledb/Manifest1
-rw-r--r--dev-db/timescaledb/timescaledb-2.13.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/timescaledb/Manifest b/dev-db/timescaledb/Manifest
index dc31574d5781..2eb5db45ff4a 100644
--- a/dev-db/timescaledb/Manifest
+++ b/dev-db/timescaledb/Manifest
@@ -1,2 +1,3 @@
DIST timescaledb-2.12.2.tar.gz 7521115 BLAKE2B 2bc2d43e3185b95cd0b4bcfc852c0850959ac117e4a30cd3b30157a82e7ad7f8192e80cc9787474e169c5ae5476a146cd2510ab93d25f479dcc7d39fa45ae15c SHA512 cb39f632a8c2e02968045f459edaacc291abbda6e64962bfd05519b9c2c00ccaac5f520f2abf8a0b08f4bb740488df56295585c13bb83b82c0d1842a71ff7224
DIST timescaledb-2.13.0.tar.gz 8214444 BLAKE2B a03237608f64ca530fef1c4c667b4d392bf3a9d5811df4225866650d1c0e708355e22570aa512fb23040453d0f1d721c7088e5895e18f4fb3aacbc9c89483027 SHA512 640f969daf330b727f373a252b814288939d7935d03fa54cf24a2b49b9914009e253df6885355cc7e93f4d0eef5028719a98007e4d9a42c14228f922708ce1f7
+DIST timescaledb-2.13.1.tar.gz 8239930 BLAKE2B 60f56e6df0224aad61ee1468ae8231a2734c3fa84c1112a04cfe9dbc7ee0abb530b03587711ec50b72d9f0f074466c38f08c915b3f3cd7a27406be2727bff620 SHA512 4416d5a3693ebe20af95903abc4fbd54b13651acbb9a3b4a0eb5cbd69d00c54d73f2abcdfe195edd9f6d14a90667121dac5b3adea20b3efbe50e0318c340c8be
diff --git a/dev-db/timescaledb/timescaledb-2.13.1.ebuild b/dev-db/timescaledb/timescaledb-2.13.1.ebuild
new file mode 100644
index 000000000000..ec3d2f7794de
--- /dev/null
+++ b/dev-db/timescaledb/timescaledb-2.13.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 13 14 15 16 )
+POSTGRES_USEDEP="ssl"
+
+inherit postgres-multi cmake
+
+DESCRIPTION="Open-source time-series SQL database"
+HOMEPAGE="https://www.timescale.com/"
+SRC_URI="https://github.com/timescale/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="proprietary-extensions"
+LICENSE="POSTGRESQL Apache-2.0 proprietary-extensions? ( timescale )"
+
+KEYWORDS="~amd64"
+
+SLOT=0
+
+RESTRICT="test"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=yes
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+BUILD_DIR=${WORKDIR}/${P}
+
+src_prepare() {
+ postgres-multi_src_prepare
+ postgres-multi_foreach cmake_src_prepare
+}
+
+timescale_configure() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ local mycmakeargs=( "-DPG_CONFIG=/usr/bin/pg_config${MULTIBUILD_VARIANT}" "-DREGRESS_CHECKS=OFF" )
+
+ # licensing is tied to features, this useflag disables the non-apache2 licensed bits
+ if ! use proprietary-extensions ; then
+ mycmakeargs+=("-DAPACHE_ONLY=ON")
+ fi
+ cmake_src_configure
+}
+
+src_configure() {
+ postgres-multi_foreach timescale_configure
+}
+
+timescale_src_compile() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_compile
+}
+
+src_compile() {
+ postgres-multi_foreach timescale_src_compile
+}
+
+timescale_src_install() {
+ local CMAKE_USE_DIR=$BUILD_DIR
+ cmake_src_install
+}
+
+src_install() {
+ postgres-multi_foreach timescale_src_install
+}