summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 09:24:26 +0100
committerSam James <sam@gentoo.org>2023-04-18 09:24:26 +0100
commit36c975680bcd8b5605d8aa491bcad0c94dc14a06 (patch)
tree40766f956a6bf20d5b43360158698ef14ac00609 /dev-db
parentsci-libs/hdf5: add 1.14.0 (diff)
downloadgentoo-36c975680bcd8b5605d8aa491bcad0c94dc14a06.tar.gz
gentoo-36c975680bcd8b5605d8aa491bcad0c94dc14a06.tar.bz2
gentoo-36c975680bcd8b5605d8aa491bcad0c94dc14a06.zip
dev-db/percona-server: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895700 Closes: https://bugs.gentoo.org/895236 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/percona-server/files/percona-server-8.0.26.16-gcc-13.patch41
-rw-r--r--dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild4
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-db/percona-server/files/percona-server-8.0.26.16-gcc-13.patch b/dev-db/percona-server/files/percona-server-8.0.26.16-gcc-13.patch
new file mode 100644
index 000000000000..ce5844dfe9d5
--- /dev/null
+++ b/dev-db/percona-server/files/percona-server-8.0.26.16-gcc-13.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/895700
+--- a/plugin/group_replication/libmysqlgcs/include/mysql/gcs/gcs_logging.h
++++ b/plugin/group_replication/libmysqlgcs/include/mysql/gcs/gcs_logging.h
+@@ -24,6 +24,7 @@
+ #define GCS_LOGGING_INCLUDED
+
+ #include <atomic>
++#include <cstdint>
+ #include <string>
+
+ #include "plugin/group_replication/libmysqlgcs/include/mysql/gcs/gcs_types.h"
+--- a/plugin/group_replication/libmysqlgcs/include/mysql/gcs/gcs_types.h
++++ b/plugin/group_replication/libmysqlgcs/include/mysql/gcs/gcs_types.h
+@@ -23,6 +23,7 @@
+ #ifndef GCS_TYPES_INCLUDED
+ #define GCS_TYPES_INCLUDED
+
++#include <cstdint>
+ #include <map>
+ #include <string>
+ #include <vector>
+--- a/plugin/x/src/interface/document_id_generator.h
++++ b/plugin/x/src/interface/document_id_generator.h
+@@ -26,6 +26,7 @@
+ #define PLUGIN_X_SRC_INTERFACE_DOCUMENT_ID_GENERATOR_H_
+
+ #include <cstdio>
++#include <cstdint>
+ #include <string>
+
+ namespace xpl {
+--- a/sql/dd/impl/sdi.h
++++ b/sql/dd/impl/sdi.h
+@@ -23,6 +23,7 @@
+ #ifndef DD__SDI_INCLUDED
+ #define DD__SDI_INCLUDED
+
++#include <cstdint>
+ #include <functional>
+ #include "my_compiler.h"
+ #include "sql/dd/sdi_fwd.h" // RJ_Document
diff --git a/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild b/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
index 6cda9fcd379e..4548b9b63299 100644
--- a/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
+++ b/dev-db/percona-server/percona-server-8.0.26.16-r2.ebuild
@@ -47,7 +47,7 @@ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -riscv ~s390 ~sparc ~
# and we will run a mysql server during test phase
S="${WORKDIR}/mysql"
-# Be warned, *DEPEND are version-dependant
+# Be warned, *DEPEND are version-dependent
# These are used for both runtime and compiletime
# openldap < dep for bug #835647 (we need ldap_r)
COMMON_DEPEND="
@@ -177,6 +177,7 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}"/mysql-patches
eapply "${FILESDIR}"/${PN}-8.0.26.16-gcc-12.patch
+ eapply "${FILESDIR}"/${PN}-8.0.26.16-gcc-13.patch
# Avoid rpm call which would trigger sandbox, #692368
sed -i \
@@ -252,6 +253,7 @@ src_configure() {
# all the time for simplicity and to make sure it is actually correct.
-DSTACK_DIRECTION=$(tc-stack-grows-down && echo -1 || echo 1)
-DCMAKE_POSITION_INDEPENDENT_CODE=ON
+ -DUSE_LD_LLD=OFF
-DWITH_CURL=system
-DWITH_BOOST="${WORKDIR}/boost_$(ver_rs 1- _ ${MY_BOOST_VERSION})"
-DWITH_ROUTER=$(usex router ON OFF)