summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-15 16:10:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-15 16:21:47 +0200
commitef9b4a902a7f556b5eb72e47ffce109bf75f9253 (patch)
tree97683699afce41d7d3bcf8e139e7c680d35b0f99 /dev-db
parentdev-python/boto3: drop old versions (diff)
downloadgentoo-ef9b4a902a7f556b5eb72e47ffce109bf75f9253.tar.gz
gentoo-ef9b4a902a7f556b5eb72e47ffce109bf75f9253.tar.bz2
gentoo-ef9b4a902a7f556b5eb72e47ffce109bf75f9253.zip
dev-db/sqlitestudio: Fix build with Qt 5.11
Doing it myself then. Closes: https://bugs.gentoo.org/662968 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlitestudio/files/sqlitestudio-3.1.1-qt-5.11.patch21
-rw-r--r--dev-db/sqlitestudio/sqlitestudio-3.1.1.ebuild4
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-db/sqlitestudio/files/sqlitestudio-3.1.1-qt-5.11.patch b/dev-db/sqlitestudio/files/sqlitestudio-3.1.1-qt-5.11.patch
new file mode 100644
index 000000000000..0de9f4a6115a
--- /dev/null
+++ b/dev-db/sqlitestudio/files/sqlitestudio-3.1.1-qt-5.11.patch
@@ -0,0 +1,21 @@
+From 5972e777aeb7e8e127114476c031a681862f8852 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Pawe=C5=82=20Salawa?= <pawelsalawa@gmail.com>
+Date: Mon, 18 Jun 2018 23:12:18 +0200
+Subject: [PATCH] #3341 Fixed compilation with Qt 5.11.
+
+---
+ SQLiteStudio3/guiSQLiteStudio/mainwindow.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/SQLiteStudio3/guiSQLiteStudio/mainwindow.cpp b/SQLiteStudio3/guiSQLiteStudio/mainwindow.cpp
+index 643caa2d..4ca68bce 100644
+--- a/SQLiteStudio3/guiSQLiteStudio/mainwindow.cpp
++++ b/SQLiteStudio3/guiSQLiteStudio/mainwindow.cpp
+@@ -47,6 +47,7 @@
+ #include <QInputDialog>
+ #include <QProgressBar>
+ #include <QLabel>
++#include <QStyle>
+
+ CFG_KEYS_DEFINE(MainWindow)
+ MainWindow* MainWindow::instance = nullptr;
diff --git a/dev-db/sqlitestudio/sqlitestudio-3.1.1.ebuild b/dev-db/sqlitestudio/sqlitestudio-3.1.1.ebuild
index 5c183c9c63d5..529a1a6f5e40 100644
--- a/dev-db/sqlitestudio/sqlitestudio-3.1.1.ebuild
+++ b/dev-db/sqlitestudio/sqlitestudio-3.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -39,6 +39,8 @@ S="${WORKDIR}"
core_build_dir="${S}/output/build"
plugins_build_dir="${core_build_dir}/Plugins"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
src_prepare() {
xdg_src_prepare