summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-01 21:31:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-01 22:20:16 +0200
commit25e9f23a696a1721fdad54807683d3ad3aada862 (patch)
tree76d238ff19bae517498866ced7159c16dbf4d655 /dev-debug/lldb
parentsys-libs/compiler-rt: Remove old (diff)
downloadgentoo-25e9f23a696a1721fdad54807683d3ad3aada862.tar.gz
gentoo-25e9f23a696a1721fdad54807683d3ad3aada862.tar.bz2
gentoo-25e9f23a696a1721fdad54807683d3ad3aada862.zip
dev-debug/lldb: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-debug/lldb')
-rw-r--r--dev-debug/lldb/Manifest1
-rw-r--r--dev-debug/lldb/lldb-19.0.0_pre20240720.ebuild110
2 files changed, 0 insertions, 111 deletions
diff --git a/dev-debug/lldb/Manifest b/dev-debug/lldb/Manifest
index 10d69b98acd6..279925324291 100644
--- a/dev-debug/lldb/Manifest
+++ b/dev-debug/lldb/Manifest
@@ -9,4 +9,3 @@ DIST llvm-project-18.1.8.src.tar.xz 132067260 BLAKE2B a950492f1dbfb874dff63b1ffe
DIST llvm-project-18.1.8.src.tar.xz.sig 566 BLAKE2B 6ab0efc5b38d4483f4e32e8b85774b2edd5d88fdf29f23b88eb0b5130a7a7f0e80549612b025f927e92de4a08ff7c292cff224dbda91a5d598244e98f7ad0fbd SHA512 ddfd1e8a06756759af6cbe488c82a6d6a62ba91f3e8a0eb4cece561321824f5d165b08ed91010588790b76e19790931d2651b24dba8567e3b151d3cb43bec25b
DIST llvm-project-19.1.0-rc1.src.tar.xz 141259912 BLAKE2B e882ff54a96900b4948e572cf073c897df6b4ce159869a42c56a4c830187d83b8d9d9b3940dad22346f142f9674575191cc9d079312f0d9aa1105390c07f504f SHA512 9f43dbe8d5f1322f73fb1c638ce4fc7a8179c9ca33fdbfbb6d72632a3d6bf4bc4993f8f5ec827510af55f4f013fba8fe3d7d9e45f262eec16ecf9ab39296b4b8
DIST llvm-project-19.1.0-rc1.src.tar.xz.sig 438 BLAKE2B cc1acbd33440bb14f78c19cc3061a5c0cb3d9dbcd6f0d1516fe118ac02c500ba4df129f870ddf3fe1a52519feab4b631866413fce9c726272d52c3865a9eea27 SHA512 a3361992b55be13aeff5d91bb90a15e3a2ab89e486328fa4d9abc9efa3925aee70bea48449b003ae1926909d389bf71afcf6dc56d800ed2e0e3dbc65da6e4e92
-DIST llvm-project-72d8c2737bb557af9d0c735b9fa30b1b03485627.tar.gz 217324958 BLAKE2B d43c161ac98860e2ce03e7e2474c55766e7496200b090ebb1cb6dcf0c2ad3a32bae76249feca53cd8b56c63806a740c280e6306890cd28429c4a7e84cae5eada SHA512 af3b44ec3f96d636d919906cf20547eb91d0a83d07731c9db38f28311a52011d8ec66833422fad9bb89ca9ac546e308b02015a7b365086341bee1f3de1b6c5e2
diff --git a/dev-debug/lldb/lldb-19.0.0_pre20240720.ebuild b/dev-debug/lldb/lldb-19.0.0_pre20240720.ebuild
deleted file mode 100644
index c79bdcdf6f3d..000000000000
--- a/dev-debug/lldb/lldb-19.0.0_pre20240720.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake flag-o-matic llvm.org llvm-utils python-single-r1
-
-DESCRIPTION="The LLVM debugger"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0/${LLVM_SOABI}"
-IUSE="+debug debuginfod +libedit lzma ncurses +python test +xml"
-RESTRICT="test"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-DEPEND="
- debuginfod? (
- net-misc/curl:=
- dev-cpp/cpp-httplib:=
- )
- libedit? ( dev-libs/libedit:0= )
- lzma? ( app-arch/xz-utils:= )
- ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
- xml? ( dev-libs/libxml2:= )
- ~sys-devel/clang-${PV}
- ~sys-devel/llvm-${PV}[debuginfod=]
-"
-RDEPEND="
- ${DEPEND}
- python? (
- ${PYTHON_DEPS}
- )
-"
-BDEPEND="
- ${PYTHON_DEPS}
- python? (
- >=dev-lang/swig-3.0.11
- )
- test? (
- $(python_gen_cond_dep "
- ~dev-python/lit-${PV}[\${PYTHON_USEDEP}]
- dev-python/psutil[\${PYTHON_USEDEP}]
- ")
- sys-devel/lld
- )
-"
-
-LLVM_COMPONENTS=( lldb cmake llvm/utils )
-LLVM_TEST_COMPONENTS=( llvm/lib/Testing/Support third-party )
-llvm.org_set_globals
-
-src_configure() {
- llvm_prepend_path "${LLVM_MAJOR}"
-
- # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
- filter-lto
-
- # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
- use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
-
- local mycmakeargs=(
- -DLLDB_ENABLE_CURSES=$(usex ncurses)
- -DLLDB_ENABLE_LIBEDIT=$(usex libedit)
- -DLLDB_ENABLE_PYTHON=$(usex python)
- -DLLDB_ENABLE_LUA=OFF
- -DLLDB_ENABLE_LZMA=$(usex lzma)
- -DLLDB_ENABLE_LIBXML2=$(usex xml)
- -DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-
- -DLLDB_INCLUDE_TESTS=$(usex test)
-
- -DCLANG_LINK_CLANG_DYLIB=ON
- # TODO: fix upstream to detect this properly
- -DHAVE_LIBDL=ON
- -DHAVE_LIBPTHREAD=ON
-
- # normally we'd have to set LLVM_ENABLE_TERMINFO, HAVE_TERMINFO
- # and TERMINFO_LIBS... so just force FindCurses.cmake to use
- # ncurses with complete library set (including autodetection
- # of -ltinfo)
- -DCURSES_NEED_NCURSES=ON
-
- -DCLANG_RESOURCE_DIR="../../../clang/${LLVM_MAJOR}"
-
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DPython3_EXECUTABLE="${PYTHON}"
- )
- use test && mycmakeargs+=(
- -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="$(get_lit_flags)"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local -x LIT_PRESERVES_TMP=1
- cmake_build check-lldb-{shell,unit}
- # failures + hangs
- #use python && cmake_build check-lldb-api
-}
-
-src_install() {
- cmake_src_install
- find "${D}" -name '*.a' -delete || die
-
- use python && python_optimize
-}