summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-26 10:58:22 +0000
committerSam James <sam@gentoo.org>2024-12-26 10:58:22 +0000
commit8895b292f3036854c09770db6fec452009b94ecc (patch)
treecbf800ae3a8bef89ea2adbb8e0eb5eb01c91a5d9 /dev-debug
parentdev-libs/libkdumpfile: crank subslot for SONAME change (diff)
downloadgentoo-8895b292f3036854c09770db6fec452009b94ecc.tar.gz
gentoo-8895b292f3036854c09770db6fec452009b94ecc.tar.bz2
gentoo-8895b292f3036854c09770db6fec452009b94ecc.zip
dev-debug/drgn: drop 0.0.27-r2, 0.0.29
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/drgn/Manifest2
-rw-r--r--dev-debug/drgn/drgn-0.0.27-r2.ebuild72
-rw-r--r--dev-debug/drgn/drgn-0.0.29.ebuild61
-rw-r--r--dev-debug/drgn/files/drgn-0.0.27-bashism.patch33
4 files changed, 0 insertions, 168 deletions
diff --git a/dev-debug/drgn/Manifest b/dev-debug/drgn/Manifest
index 65fd86f12b15..1d33818fa1b2 100644
--- a/dev-debug/drgn/Manifest
+++ b/dev-debug/drgn/Manifest
@@ -1,3 +1 @@
-DIST drgn-0.0.27.tar.gz 1193358 BLAKE2B 9008c2784075dd2409d6a948474914f0b08bbd4ee0a7d537e77de5f9f34ebede20dab2fd371047708af5ded0ef395ae2361760edd5cbee2fac88140fcbb3d58e SHA512 fab4620eada3767184b48bf641fc700697b5897c9313ee15ff16aec1070d9e7e92a732e430d4a9d0d02d7071764961e7845b2f9ee6a87c661bdf0fc4d4ecb0f0
-DIST drgn-0.0.29.tar.gz 1242038 BLAKE2B a2f750ff9717f1990400d1e491bc83229d1ade87e32a6d14e395b889562088df32b3915ded97c3c6486bc7defdea7e1d58dbdccdcc3f6085dca12104569a71ef SHA512 2d13de5f4da2db106def4701b4de182c5a5781c12308bc169d6a9033f223b7c64fd4f83659c45a2861ac9aca56f31ba77d781452b9374bc29f50e1151a073741
DIST drgn-0.0.30.tar.gz 1268753 BLAKE2B 28fc686771f0eebca4c8be6a4552e0d8ca060ea1d39d656768d807f8115323ca00f1a9311d3aa5208d2a609fa296cda691f350e545b1e23b5ef0b200a9d6f77b SHA512 6c17052baf5c2295167e41e5b7fd9899c1ca90af6f83704034371827953f690c034415780c4f45d20e1235085c198cf69e8ee9bdbf8081e22e3f860d21e839e9
diff --git a/dev-debug/drgn/drgn-0.0.27-r2.ebuild b/dev-debug/drgn/drgn-0.0.27-r2.ebuild
deleted file mode 100644
index 48d3c3892ed1..000000000000
--- a/dev-debug/drgn/drgn-0.0.27-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit autotools distutils-r1 multiprocessing pypi toolchain-funcs
-
-DESCRIPTION="Programmable debugger"
-HOMEPAGE="
- https://github.com/osandov/drgn
- https://pypi.org/project/drgn/
- https://drgn.readthedocs.io/en/latest/
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="openmp"
-
-DEPEND="
- >=dev-libs/elfutils-0.165
- dev-libs/libkdumpfile
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( dev-libs/check )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.0.27-bashism.patch
-)
-
-distutils_enable_tests unittest
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_prepare() {
- distutils-r1_src_prepare
-
- cd libdrgn || die
- eautoreconf
-}
-
-src_configure() {
- tc-export AR CC OBJCOPY OBJDUMP PKG_CONFIG RANLIB STRIP
-
- cat >> setup.cfg <<-EOF || die
- [build_ext]
- parallel = $(makeopts_jobs)
- EOF
-
- # setuptools calls autotools (!)
- export CONFIGURE_FLAGS
- CONFIGURE_FLAGS="--disable-dependency-tracking --disable-silent-rules"
- CONFIGURE_FLAGS+=" --with-libkdumpfile"
- CONFIGURE_FLAGS+=" $(use_enable openmp)"
- CONFIGURE_FLAGS+=" --build=${CBUILD}"
- CONFIGURE_FLAGS+=" --host=${CHOST}"
- CONFIGURE_FLAGS+=" --target=${CTARGET}"
- distutils-r1_src_configure
-}
diff --git a/dev-debug/drgn/drgn-0.0.29.ebuild b/dev-debug/drgn/drgn-0.0.29.ebuild
deleted file mode 100644
index 466aac274efe..000000000000
--- a/dev-debug/drgn/drgn-0.0.29.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 multiprocessing pypi toolchain-funcs
-
-DESCRIPTION="Programmable debugger"
-HOMEPAGE="
- https://github.com/osandov/drgn
- https://pypi.org/project/drgn/
- https://drgn.readthedocs.io/en/latest/
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="openmp"
-
-DEPEND="
- >=dev-libs/elfutils-0.165
- dev-libs/libkdumpfile
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( dev-libs/check )
-"
-
-distutils_enable_tests unittest
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- tc-export AR CC OBJCOPY OBJDUMP PKG_CONFIG RANLIB STRIP
-
- cat >> setup.cfg <<-EOF || die
- [build_ext]
- parallel = $(makeopts_jobs)
- EOF
-
- # setuptools calls autotools (!)
- export CONFIGURE_FLAGS
- CONFIGURE_FLAGS="--disable-dependency-tracking --disable-silent-rules"
- CONFIGURE_FLAGS+=" --with-libkdumpfile"
- CONFIGURE_FLAGS+=" $(use_enable openmp)"
- CONFIGURE_FLAGS+=" --build=${CBUILD}"
- CONFIGURE_FLAGS+=" --host=${CHOST}"
- CONFIGURE_FLAGS+=" --target=${CTARGET}"
- distutils-r1_src_configure
-}
diff --git a/dev-debug/drgn/files/drgn-0.0.27-bashism.patch b/dev-debug/drgn/files/drgn-0.0.27-bashism.patch
deleted file mode 100644
index 7f7151c4d6bb..000000000000
--- a/dev-debug/drgn/files/drgn-0.0.27-bashism.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-https://github.com/osandov/drgn/pull/427
-
-From 4aad3f174ceaaa740728ba92181d9d156f70abac Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Tue, 27 Aug 2024 21:03:42 +0100
-Subject: [PATCH] libdrgn: fix bashism in M4 macro
-
-configure scripts need to be runnable with a POSIX-compliant /bin/sh.
-
-On many (but not all!) systems, /bin/sh is provided by Bash, so errors
-like this aren't spotted. Notably Debian defaults to /bin/sh provided
-by dash which doesn't tolerate such bashisms as '=='.
-
-This retains compatibility with bash.
-
-Signed-off-by: Sam James <sam@gentoo.org>
----
- libdrgn/m4/my_c_auto.m4 | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libdrgn/m4/my_c_auto.m4 b/libdrgn/m4/my_c_auto.m4
-index d38c72436..30f3221b5 100644
---- a/libdrgn/m4/my_c_auto.m4
-+++ b/libdrgn/m4/my_c_auto.m4
-@@ -12,7 +12,7 @@ if test "x$my_cv_c_auto" != xyes; then
- AC_CACHE_CHECK([for __auto_type], [my_cv_c___auto_type],
- [AC_COMPILE_IFELSE([AC_LANG_SOURCE([[__auto_type x = 1;]])],
- [my_cv_c___auto_type=yes], [my_cv_c___auto_type=no])])
-- if test "x$my_cv_c___auto_type" == xyes; then
-+ if test "x$my_cv_c___auto_type" = xyes; then
- AC_DEFINE([auto], [__auto_type])
- else
- AC_MSG_ERROR([no auto or __auto_type])