summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-16 23:29:30 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-17 00:13:33 +0100
commitd47ab5f3d39aecb97eaa4f4ab856f0625aebbed1 (patch)
tree9c31d74a42f776b14fc26ab08f916dea915965c1 /dev-dotnet/dotnet-sdk-bin
parentdev-dotnet/dotnet-sdk-bin: bump to 8.0.200 (diff)
downloadgentoo-d47ab5f3d39aecb97eaa4f4ab856f0625aebbed1.tar.gz
gentoo-d47ab5f3d39aecb97eaa4f4ab856f0625aebbed1.tar.bz2
gentoo-d47ab5f3d39aecb97eaa4f4ab856f0625aebbed1.zip
dev-dotnet/dotnet-sdk-bin: format; sync
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet/dotnet-sdk-bin')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild8
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild22
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild24
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild24
4 files changed, 54 insertions, 24 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild
index 0714019b2155..f3e305f5c58e 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.417-r4.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+SDK_SLOT="$(ver_cut 1-2)"
+RUNTIME_SLOT="${SDK_SLOT}.25"
+
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/
https://github.com/dotnet/dotnet/"
@@ -22,11 +25,8 @@ arm64? (
"
S="${WORKDIR}"
-SDK_SLOT="$(ver_cut 1-2)"
-RUNTIME_SLOT="${SDK_SLOT}.25"
-SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
-
LICENSE="MIT"
+SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
KEYWORDS="amd64 arm arm64"
# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
index 3e3f048ac1ab..5b132bbcc2c9 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-7.0.404-r4.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+SDK_SLOT="$(ver_cut 1-2)"
+RUNTIME_SLOT="${SDK_SLOT}.14"
+
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/
https://github.com/dotnet/dotnet/"
@@ -22,17 +25,25 @@ arm64? (
"
S="${WORKDIR}"
-SDK_SLOT="$(ver_cut 1-2)"
-RUNTIME_SLOT="${SDK_SLOT}.14"
-SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
-
LICENSE="MIT"
+SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
KEYWORDS="amd64 arm arm64"
# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
# bug https://bugs.gentoo.org/923430
RESTRICT="splitdebug strip"
+CURRENT_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
+"
+EXTRA_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-6.0.25
+"
+NUGETS_DEPEND="
+ ${CURRENT_NUGETS_DEPEND}
+ ${EXTRA_NUGETS_DEPEND}
+"
+
RDEPEND="
app-crypt/mit-krb5:0/0
dev-libs/icu
@@ -46,8 +57,7 @@ IDEPEND="
app-eselect/eselect-dotnet
"
PDEPEND="
- ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
- ~dev-dotnet/dotnet-runtime-nugets-6.0.25
+ ${NUGETS_DEPEND}
"
QA_PREBUILT="*"
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild
index 06710163ef35..fdbb81c6c024 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.100-r4.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+SDK_SLOT="$(ver_cut 1-2)"
+RUNTIME_SLOT="${SDK_SLOT}.0"
+
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/
https://github.com/dotnet/dotnet/"
@@ -22,17 +25,26 @@ arm64? (
"
S="${WORKDIR}"
-SDK_SLOT="$(ver_cut 1-2)"
-RUNTIME_SLOT="${SDK_SLOT}.0"
-SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
-
LICENSE="MIT"
+SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
KEYWORDS="amd64 arm arm64"
# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
# bug https://bugs.gentoo.org/923430
RESTRICT="splitdebug strip"
+CURRENT_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
+"
+EXTRA_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-6.0.25
+ ~dev-dotnet/dotnet-runtime-nugets-7.0.14
+"
+NUGETS_DEPEND="
+ ${CURRENT_NUGETS_DEPEND}
+ ${EXTRA_NUGETS_DEPEND}
+"
+
RDEPEND="
app-crypt/mit-krb5:0/0
dev-libs/icu
@@ -46,9 +58,7 @@ IDEPEND="
app-eselect/eselect-dotnet
"
PDEPEND="
- ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
- ~dev-dotnet/dotnet-runtime-nugets-6.0.25
- ~dev-dotnet/dotnet-runtime-nugets-7.0.14
+ ${NUGETS_DEPEND}
"
QA_PREBUILT="*"
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild
index 81675d234044..c12f37a86041 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-8.0.101-r3.ebuild
@@ -3,6 +3,9 @@
EAPI=8
+SDK_SLOT="$(ver_cut 1-2)"
+RUNTIME_SLOT="${SDK_SLOT}.1"
+
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/
https://github.com/dotnet/dotnet/"
@@ -22,17 +25,26 @@ arm64? (
"
S="${WORKDIR}"
-SDK_SLOT="$(ver_cut 1-2)"
-RUNTIME_SLOT="${SDK_SLOT}.1"
-SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
-
LICENSE="MIT"
+SLOT="${SDK_SLOT}/${RUNTIME_SLOT}"
KEYWORDS="~amd64 ~arm ~arm64"
# STRIP="llvm-strip" corrupts some executables when using the patchelf hack,
# bug https://bugs.gentoo.org/923430
RESTRICT="splitdebug strip"
+CURRENT_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
+"
+EXTRA_NUGETS_DEPEND="
+ ~dev-dotnet/dotnet-runtime-nugets-6.0.26
+ ~dev-dotnet/dotnet-runtime-nugets-7.0.15
+"
+NUGETS_DEPEND="
+ ${CURRENT_NUGETS_DEPEND}
+ ${EXTRA_NUGETS_DEPEND}
+"
+
RDEPEND="
app-crypt/mit-krb5:0/0
dev-libs/icu
@@ -46,9 +58,7 @@ IDEPEND="
app-eselect/eselect-dotnet
"
PDEPEND="
- ~dev-dotnet/dotnet-runtime-nugets-${RUNTIME_SLOT}
- ~dev-dotnet/dotnet-runtime-nugets-6.0.26
- ~dev-dotnet/dotnet-runtime-nugets-7.0.15
+ ${NUGETS_DEPEND}
"
QA_PREBUILT="*"