summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/notify-sharp/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/notify-sharp/files')
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch28
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch60
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
new file mode 100644
index 000000000000..44ff05881fb4
--- /dev/null
+++ b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
@@ -0,0 +1,28 @@
+diff -NrU5 notify-sharp-20080912.orig/configure.ac notify-sharp-20080912/configure.ac
+--- notify-sharp-20080912.orig/configure.ac 2008-11-26 21:56:02.000000000 +0100
++++ notify-sharp-20080912/configure.ac 2008-11-26 22:01:08.000000000 +0100
+@@ -34,16 +34,21 @@
+ if test "x$GACUTIL" = "xno"; then
+ AC_MSG_ERROR([You need to install gacutil])
+ fi
+ AC_SUBST(GACUTIL)
+
+-AC_ARG_ENABLE(docs, AC_HELP_STRING([--disable-docs],
+- [Do not build documentation]), with_docs=no, with_docs=yes)
++AC_ARG_ENABLE( [docs],
++ [AC_HELP_STRING( [--enable/disable-docs],
++ [Do (not) build documentation (default=yes)]
++ )],
++ [],
++ [enable_docs=yes]
++)
+
+ MONODOC_REQ_VERSION=1.1.18
+
+-if test "x$with_docs" = "xyes"; then
++if test "x$enable_docs" = "xyes"; then
+ PKG_CHECK_MODULES(MONODOC, monodoc >= $MONODOC_REQ_VERSION,,
+ [AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])])
+ AC_PATH_PROG(MONODOCER, monodocer, no)
+ if test "x$MONODOCER" = "xno"; then
+ AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
new file mode 100644
index 000000000000..28c6316dc5aa
--- /dev/null
+++ b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
@@ -0,0 +1,60 @@
+diff --git a/configure.ac b/configure.ac
+index d2ff635..7200f06 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -71,11 +71,11 @@ GTK_SHARP_REQ_VERSION=2.10.1
+ PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 >= $GTK_SHARP_REQ_VERSION)
+ AC_SUBST(GTK_SHARP_LIBS)
+
+-NDESK_DBUS_REQ_VERSION=0.4
+-NDESK_DBUS_GLIB_REQ_VERSION=0.3
+-PKG_CHECK_MODULES(NDESK_DBUS, ndesk-dbus-1.0 >= $NDESK_DBUS_REQ_VERSION \
+- ndesk-dbus-glib-1.0 >= $NDESK_DBUS_GLIB_REQ_VERSION)
+-AC_SUBST(NDESK_DBUS_LIBS)
++DBUS_SHARP_REQ_VERSION=0.7
++DBUS_SHARP_GLIB_REQ_VERSION=0.5
++PKG_CHECK_MODULES(DBUS_SHARP, dbus-sharp-1.0 >= $DBUS_SHARP_REQ_VERSION \
++ dbus-sharp-glib-1.0 >= $DBUS_SHARP_GLIB_REQ_VERSION)
++AC_SUBST(DBUS_SHARP_LIBS)
+
+ required_assemblies="Mono.Posix"
+
+diff --git a/src/Global.cs b/src/Global.cs
+index eedefbf..a0f80ed 100644
+--- a/src/Global.cs
++++ b/src/Global.cs
+@@ -24,7 +24,7 @@ using System;
+ using System.Reflection;
+ using System.Collections.Generic;
+
+-using NDesk.DBus;
++using DBus;
+ using org.freedesktop;
+ using org.freedesktop.DBus;
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3b39c23..50bbb39 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -7,7 +7,7 @@ CSFLAGS = \
+ LIBFLAGS = \
+ -r:Mono.Posix \
+ $(GTK_SHARP_LIBS) \
+- $(NDESK_DBUS_LIBS)
++ $(DBUS_SHARP_LIBS)
+
+ CSFILES = \
+ $(srcdir)/Global.cs \
+diff --git a/src/Notification.cs b/src/Notification.cs
+index 09ef83e..e2ab72f 100644
+--- a/src/Notification.cs
++++ b/src/Notification.cs
+@@ -28,7 +28,7 @@ using GLib;
+ using Gdk;
+ using Gtk;
+
+-using NDesk.DBus;
++using DBus;
+ using org.freedesktop;
+ using org.freedesktop.DBus;
+