summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/bitbake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/bitbake')
-rw-r--r--dev-embedded/bitbake/Manifest1
-rw-r--r--dev-embedded/bitbake/bitbake-1.17.0.ebuild39
-rw-r--r--dev-embedded/bitbake/bitbake-9999.ebuild39
-rw-r--r--dev-embedded/bitbake/metadata.xml8
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-embedded/bitbake/Manifest b/dev-embedded/bitbake/Manifest
new file mode 100644
index 000000000000..7018256caa66
--- /dev/null
+++ b/dev-embedded/bitbake/Manifest
@@ -0,0 +1 @@
+DIST bitbake-1.17.0.tar.gz 455029 SHA256 37b874a7fcefca03cc549b5ce7115aa31269da15c4d80427a0ce3347f305484b SHA512 2e01c6c48179ad09c0bd62e393c22bbfe9e35df4f3c014f279ee82bc38d61f1c0c7dc7442bad556d00cf1a46c33121d415ffa1ef522d42451a6752ba414580ea WHIRLPOOL 05a9da7cdf40676f45afc38eecd1e7c4a1381b3ba057a8aae92719664959fb6ac1c3b3ca946c7f304886e1a4f82cf36330c760c5a1b86466f9f5dd1004cf79fe
diff --git a/dev-embedded/bitbake/bitbake-1.17.0.ebuild b/dev-embedded/bitbake/bitbake-1.17.0.ebuild
new file mode 100644
index 000000000000..92efdbb58ab4
--- /dev/null
+++ b/dev-embedded/bitbake/bitbake-1.17.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 vcs-snapshot
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.openembedded.org/bitbake.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/openembedded/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ppc x86"
+fi
+
+DESCRIPTION="package management tool for OpenEmbedded"
+HOMEPAGE="http://git.openembedded.org/bitbake/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-python/ply
+ dev-python/progressbar"
+DEPEND="doc? ( dev-libs/libxslt )"
+
+src_prepare() {
+ if ! use doc ; then
+ sed -i -e 's:doctype = "html":doctype = "none":' \
+ -e 's:("share/doc/bitbake-%s/manual.*))::' setup.py || die
+ echo "none:" >> doc/manual/Makefile || die
+ else
+ sed -i -e "s:\(share/doc/bitbake-%s.* %\) __version__:\1 \"${PV}\":" setup.py || die
+ fi
+}
diff --git a/dev-embedded/bitbake/bitbake-9999.ebuild b/dev-embedded/bitbake/bitbake-9999.ebuild
new file mode 100644
index 000000000000..7b09cd5ac087
--- /dev/null
+++ b/dev-embedded/bitbake/bitbake-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 vcs-snapshot
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.openembedded.org/bitbake.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/openembedded/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="package management tool for OpenEmbedded"
+HOMEPAGE="http://git.openembedded.org/bitbake/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="dev-python/ply
+ dev-python/progressbar"
+DEPEND="doc? ( dev-libs/libxslt )"
+
+src_prepare() {
+ if ! use doc ; then
+ sed -i -e 's:doctype = "html":doctype = "none":' \
+ -e 's:("share/doc/bitbake-%s/manual.*))::' setup.py || die
+ echo "none:" >> doc/manual/Makefile || die
+ else
+ sed -i -e "s:\(share/doc/bitbake-%s.* %\) __version__:\1 \"${PV}\":" setup.py || die
+ fi
+}
diff --git a/dev-embedded/bitbake/metadata.xml b/dev-embedded/bitbake/metadata.xml
new file mode 100644
index 000000000000..5db9f42b508d
--- /dev/null
+++ b/dev-embedded/bitbake/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>embedded</herd>
+ <upstream>
+ <remote-id type="github">openembedded/bitbake</remote-id>
+ </upstream>
+</pkgmetadata>