summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-10-02 23:08:36 +0100
committerTony Vroon <chainsaw@gentoo.org>2015-10-02 23:08:36 +0100
commit2787244ca5f03ba51bc6daaddfba687694c85031 (patch)
tree96e46c3a29bf8c1d2ff75c6cc6f3dbe44734114d /dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild
parentsys-devel/gcc: marked stable for arm, bug #561844 c#5 (diff)
downloadgentoo-2787244ca5f03ba51bc6daaddfba687694c85031.tar.gz
gentoo-2787244ca5f03ba51bc6daaddfba687694c85031.tar.bz2
gentoo-2787244ca5f03ba51bc6daaddfba687694c85031.zip
dev-embedded/sunxi-tools: New addition. Ebuild by me, inspired by mkeyoverlay.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild')
-rw-r--r--dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild b/dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild
new file mode 100644
index 000000000000..4668be33cddc
--- /dev/null
+++ b/dev-embedded/sunxi-tools/sunxi-tools-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_PV="v${PV}"
+SRC_URI="https://github.com/linux-sunxi/sunxi-tools/archive/${MY_PV}.tar.gz"
+
+DESCRIPTION="Tools for Allwinner A10 devices."
+HOMEPAGE="http://linux-sunxi.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+DEPEND="virtual/libusb"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -std=c99 -D_POSIX_C_SOURCE=200112L -Iinclude/" all misc
+}
+
+src_install() {
+ dobin bin2fex bootinfo fel fex2bin fexc nand-part phoenix_info pio
+}