summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/goatee
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/goatee')
-rw-r--r--dev-games/goatee/Manifest2
-rw-r--r--dev-games/goatee/goatee-0.2.0-r1.ebuild28
-rw-r--r--dev-games/goatee/goatee-0.3.0.ebuild28
-rw-r--r--dev-games/goatee/metadata.xml15
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-games/goatee/Manifest b/dev-games/goatee/Manifest
new file mode 100644
index 000000000000..460d7af358e5
--- /dev/null
+++ b/dev-games/goatee/Manifest
@@ -0,0 +1,2 @@
+DIST goatee-0.2.0.tar.gz 76171 SHA256 288526218177cd340360c2861f03163ae9e1c1df6c937b5d4f010350766f1b53 SHA512 d731c6f96edef4717f137a37d73fe190a4620b9f328f1cf9ec50400bd74f7e6e0ef8a60d8e9b64472b66670789cab82a1ece8019eb0921d38644875fbfa59079 WHIRLPOOL cae7ab41dff84f5abab4190e37cf18dce44228fcebba265e3af1f0ddc95dba1a25b728cc59d9ffcc3e645b599759c74b0c122f321dee40dbd69a55962eabb66e
+DIST goatee-0.3.0.tar.gz 83679 SHA256 4d2ca32cf42161e18d3c528c24d0ac16a78b0e331759ce97714d5abcab65c0df SHA512 57c5340ba6aadbd4fd5d328702012e02a5e36c50be7f714bc1f8adedb3270c2174ad3c60d30dd7b93b93b4a3a3e6436ec9e5957561e13046dfde869b71ec2cd6 WHIRLPOOL bff45c30c33ea0e2e82fcf138d2b99de96b459c67fbdf952c4cc94e115e416b0733751dafeacfbd3738a7295dc99583449f2a56db9f50eb2a039de0981870eae
diff --git a/dev-games/goatee/goatee-0.2.0-r1.ebuild b/dev-games/goatee/goatee-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..00d0b9ca4d24
--- /dev/null
+++ b/dev-games/goatee/goatee-0.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A monadic take on a 2,500-year-old board game - library"
+HOMEPAGE="http://khumba.net/projects/goatee"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-libs/gmp-5:=
+ virtual/libffi:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3 )
+"
diff --git a/dev-games/goatee/goatee-0.3.0.ebuild b/dev-games/goatee/goatee-0.3.0.ebuild
new file mode 100644
index 000000000000..2f4bce7f2188
--- /dev/null
+++ b/dev-games/goatee/goatee-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A monadic take on a 2,500-year-old board game - library"
+HOMEPAGE="http://khumba.net/projects/goatee"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ >=dev-libs/gmp-5:=
+ virtual/libffi:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.3 )
+"
diff --git a/dev-games/goatee/metadata.xml b/dev-games/goatee/metadata.xml
new file mode 100644
index 000000000000..9288a81d788c
--- /dev/null
+++ b/dev-games/goatee/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <herd>haskell</herd>
+ <longdescription>
+ Goatee is a Go library and game editor, written in Haskell. It provides a
+ GUI for recording, studying, and editing game records. Underneath this is a
+ portable library for manipulating SGF files to build UIs and tools. Goatee
+ aims to be full-featured by supporting all of the SGF spec and allowing for
+ full and easy customization of the game records you create.
+
+ This package is the shared library.
+ </longdescription>
+</pkgmetadata>