summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Sabalenka <mechakotik@gmail.com>2024-09-26 11:38:00 +0300
committerConrad Kostecki <conikost@gentoo.org>2024-10-10 22:27:56 +0200
commit01940d91da2edcb99e1845efe080c6aac1618729 (patch)
treede4d93b1d2f96646a9ae8d8a0bb70db17c56527c /dev-games
parentdev-games/tiled: drop 1.8.6 (diff)
downloadgentoo-01940d91da2edcb99e1845efe080c6aac1618729.tar.gz
gentoo-01940d91da2edcb99e1845efe080c6aac1618729.tar.bz2
gentoo-01940d91da2edcb99e1845efe080c6aac1618729.zip
dev-games/tiled: remove useless patch
This was added to workaround "PYTHONHOME not set. The Python plugin will not be available" warning. Even though it prints this warning, it will still find Python using pkgconfig and build the plugin. Signed-off-by: Andrei Sabalenka <mechakotik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38795 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/tiled/files/tiled-1.11.0-python.patch55
-rw-r--r--dev-games/tiled/tiled-1.11.0.ebuild1
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-games/tiled/files/tiled-1.11.0-python.patch b/dev-games/tiled/files/tiled-1.11.0-python.patch
deleted file mode 100644
index f5407045e019..000000000000
--- a/dev-games/tiled/files/tiled-1.11.0-python.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff --git a/qbs/imports/PythonProbe.qbs b/qbs/imports/PythonProbe.qbs
-index 52eae7fc..93b4270c 100644
---- a/qbs/imports/PythonProbe.qbs
-+++ b/qbs/imports/PythonProbe.qbs
-@@ -7,7 +7,6 @@ import qbs.Utilities
- Probe {
- id: pythonDllProbe
-
-- property string pythonDir: pythonInstallDir // Input
- property string buildVariant: qbs.buildVariant // Input
- property string minVersion: "3.5" // Input
- property string fileNamePrefix // Output
-@@ -17,18 +16,9 @@ Probe {
- console.warn(msg + " The Python plugin will not be available.");
- }
-
-- if (!pythonDir) {
-- printWarning("PYTHONHOME not set.");
-- return;
-- }
-- if (!File.exists(pythonDir)) {
-- printWarning("The provided Python installation directory '" + pythonDir
-- + "' does not exist.");
-- return;
-- }
- var p = new Process();
- try {
-- var pythonFilePath = FileInfo.joinPaths(pythonDir, "python.exe");
-+ var pythonFilePath = "python";
- p.exec(pythonFilePath, ["--version"], true);
- var output = p.readStdOut().trim();
- var magicPrefix = "Python ";
-@@ -45,9 +35,7 @@ Probe {
- return;
- }
- if (Utilities.versionCompare(versionNumberString, minVersion) < 0) {
-- printWarning("The Python installation at '" + pythonDir
-- + "' has version " + versionNumberString + ", but " + minVersion + " or higher "
-- + "is required.");
-+ printWarning("The Python installation has version " + versionNumberString + ", but " + minVersion + " or higher " + "is required.");
- return;
- }
- found = true;
-diff --git a/src/plugins/python/python.qbs b/src/plugins/python/python.qbs
-index f1c959d3..8c43af9c 100644
---- a/src/plugins/python/python.qbs
-+++ b/src/plugins/python/python.qbs
-@@ -28,7 +28,6 @@ TiledPlugin {
-
- PythonProbe {
- id: pythonDllProbe
-- pythonDir: Environment.getEnv("PYTHONHOME")
- minVersion: "3.8"
- }
-
diff --git a/dev-games/tiled/tiled-1.11.0.ebuild b/dev-games/tiled/tiled-1.11.0.ebuild
index 373917dcb8ee..66a5a4df0232 100644
--- a/dev-games/tiled/tiled-1.11.0.ebuild
+++ b/dev-games/tiled/tiled-1.11.0.ebuild
@@ -49,7 +49,6 @@ qbs_format_flags() {
src_configure() {
if use python; then
- eapply "${FILESDIR}"/${P}-python.patch
QBS_PRODUCTS="${QBS_PRODUCTS},python"
fi
if ! use minimal; then