summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/go-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/go-tools')
-rw-r--r--dev-go/go-tools/Manifest2
-rw-r--r--dev-go/go-tools/go-tools-0_pre20150606.ebuild99
-rw-r--r--dev-go/go-tools/go-tools-9999.ebuild90
-rw-r--r--dev-go/go-tools/metadata.xml10
4 files changed, 201 insertions, 0 deletions
diff --git a/dev-go/go-tools/Manifest b/dev-go/go-tools/Manifest
new file mode 100644
index 000000000000..5a0a1c192d91
--- /dev/null
+++ b/dev-go/go-tools/Manifest
@@ -0,0 +1,2 @@
+DIST go-favicon.ico 1150 SHA256 d76ca702a6d81e20ddd31c8c5a4368130e7c68d990600316f6f1c9509bd38ba7 SHA512 194c4b3c360321a10f714b6755d9155de6129682b4070d19b52d0d5706fcbd1d244ea38c33fd77fe1dec85b3e39720dd0a62f5b126803036fbc8337a9d72fea6 WHIRLPOOL f55a84a28812bffd1fa38e098e6ba7d757bdefc0e20c3d8ef767fb1bc7d6e2cfbb8d1ae0593e81cce17c27f60e6aacf094e6c67b1f592c0546090feab9d3830f
+DIST go-tools-0_pre20150606.tar.gz 1625903 SHA256 d121fc152648283413bc0596a55edc229796a7640d2ba6e1fd31c4fc316bb32c SHA512 68904e9799f80c77b1ccda2483eea4dcb19825aaf94355f967d1b0c3547ebf85772c0e92d9b5ba2e492a8af1b4cd07037d121add3c42760d15ca41c05d1161ab WHIRLPOOL 2e5e51112b4ddf2f391c8131e0b84e4c73ddcfcedc46ee934700b45c9cac5c2ee6a4984c02fa80c2207bd39d6b903a68c72cddec0fabcdd14ec2c6a4c7c7f727
diff --git a/dev-go/go-tools/go-tools-0_pre20150606.ebuild b/dev-go/go-tools/go-tools-0_pre20150606.ebuild
new file mode 100644
index 000000000000..41cb121bba94
--- /dev/null
+++ b/dev-go/go-tools/go-tools-0_pre20150606.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go Tools"
+MY_PN=${PN##*-}
+GO_PN=golang.org/x/${MY_PN}
+HOMEPAGE="https://godoc.org/${GO_PN}"
+EGIT_COMMIT="ac303766f5f240c1796eeea3dc9bf34f1261aa35"
+SRC_URI="https://github.com/golang/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
+ http://golang.org/favicon.ico -> go-favicon.ico"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4
+ dev-go/go-net"
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+EGIT_CHECKOUT_DIR="${S}"
+STRIP_MASK="*.a"
+
+src_unpack() {
+ default
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die
+ cp "${DISTDIR}"/go-favicon.ico "${S}"/godoc/static/favicon.ico || die
+}
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestWeb(:_\0:' -i cmd/godoc/godoc_test.go || die
+ sed -e 's:TestVet(:_\0:' -i cmd/vet/vet_test.go || die
+ sed -e 's:TestImport(:_\0:' -i go/gcimporter/gcimporter_test.go || die
+ sed -e 's:TestImportStdLib(:_\0:' -i go/importer/import_test.go || die
+ sed -e 's:TestStdlib(:_\0:' -i go/loader/stdlib_test.go || die
+ sed -e 's:TestStdlib(:_\0:' -i go/ssa/stdlib_test.go || die
+ sed -e 's:TestGorootTest(:_\0:' \
+ -e 's:TestFoo(:_\0:' \
+ -e 's:TestTestmainPackage(:_\0:' \
+ -i go/ssa/interp/interp_test.go || die
+ sed -e 's:TestBar(:_\0:' \
+ -e 's:TestFoo(:_\0:' -i go/ssa/interp/testdata/a_test.go || die
+ sed -e 's:TestCheck(:_\0:' -i go/types/check_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -e 's:TestStdFixed(:_\0:' \
+ -e 's:TestStdKen(:_\0:' -i go/types/stdlib_test.go || die
+ sed -e 's:TestRepoRootForImportPath(:_\0:' -i go/vcs/vcs_test.go || die
+ sed -e 's:TestStdlib(:_\0:' -i refactor/lexical/lexical_test.go || die
+
+ # Add favicon to the godoc web interface (bug 551030)
+ sed -e 's:"example.html",:\0\n\t"favicon.ico",:' -i godoc/static/makestatic.go || die
+ sed -e 's:<link type="text/css":<link rel="icon" type="image/png" href="/lib/godoc/favicon.ico">\n\0:' -i \
+ godoc/static/godoc.html || die
+}
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ GOROOT="${WORKDIR}/goroot"
+ cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN}" \
+ "${GOROOT}/pkg/linux_${ARCH}/${GO_PN}" || die
+
+ # Generate static.go with favicon included
+ pushd godoc/static >/dev/null
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} go run makestatic.go || die
+ popd >/dev/null
+
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
+}
+
+src_test() {
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} \
+ go test -x -v ${GO_PN}/... || die $?
+}
+
+src_install() {
+ local x
+ exeinto /usr/lib/go/bin
+ doexe "${WORKDIR}"/bin/*
+
+ # godoc ends up in ${GOROOT}/bin
+ dodir /usr/bin
+ while read -r -d '' x; do
+ doexe "${x}"
+ ln "${ED}"usr/{lib/go/bin,bin}/${x##*/} || die
+ done < <(find "${GOROOT}/bin" -type f -print0)
+
+ # cover and vet end up in ${GOROOT}/pkg/tool/linux_amd64
+ exeinto /usr/lib/go/pkg/tool/linux_amd64
+ find "${GOROOT}/pkg/tool/linux_amd64" -type f -exec doexe {} \;
+
+ insinto /usr/lib/go
+ find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ doins -r "${WORKDIR}"/{pkg,src}
+}
diff --git a/dev-go/go-tools/go-tools-9999.ebuild b/dev-go/go-tools/go-tools-9999.ebuild
new file mode 100644
index 000000000000..3e1bc873aed2
--- /dev/null
+++ b/dev-go/go-tools/go-tools-9999.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN="golang.org/x/tools/..."
+EGO_SRC="golang.org/x/tools"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ EGIT_COMMIT="ac303766f5f240c1796eeea3dc9bf34f1261aa35"
+ ARCHIVE_URI="https://github.com/golang/tools/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go Tools"
+HOMEPAGE="https://godoc.org/golang.org/x/tools"
+SRC_URI="${ARCHIVE_URI}
+ http://golang.org/favicon.ico -> go-favicon.ico"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/go-net:="
+RDEPEND=""
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestWeb(:_\0:' \
+ -i src/${EGO_SRC}/cmd/godoc/godoc_test.go || die
+ sed -e 's:TestVet(:_\0:' \
+ -i src/${EGO_SRC}/cmd/vet/vet_test.go || die
+ sed -e 's:TestImport(:_\0:' \
+ -i src/${EGO_SRC}/go/gcimporter/gcimporter_test.go || die
+ sed -e 's:TestImportStdLib(:_\0:' \
+ -i src/${EGO_SRC}/go/importer/import_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -i src/${EGO_SRC}/go/loader/stdlib_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -i src/${EGO_SRC}/go/ssa/stdlib_test.go || die
+ sed -e 's:TestGorootTest(:_\0:' \
+ -e 's:TestFoo(:_\0:' \
+ -e 's:TestTestmainPackage(:_\0:' \
+ -i src/${EGO_SRC}/go/ssa/interp/interp_test.go || die
+ sed -e 's:TestBar(:_\0:' \
+ -e 's:TestFoo(:_\0:' \
+ -i src/${EGO_SRC}/go/ssa/interp/testdata/a_test.go || die
+ sed -e 's:TestCheck(:_\0:' \
+ -i src/${EGO_SRC}/go/types/check_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -e 's:TestStdFixed(:_\0:' \
+ -e 's:TestStdKen(:_\0:' \
+ -i src/${EGO_SRC}/go/types/stdlib_test.go || die
+ sed -e 's:TestRepoRootForImportPath(:_\0:' \
+ -i src/${EGO_SRC}/go/vcs/vcs_test.go || die
+ sed -e 's:TestStdlib(:_\0:' \
+ -i src/${EGO_SRC}/refactor/lexical/lexical_test.go || die
+
+ # Add favicon to the godoc web interface (bug 551030)
+ cp "${DISTDIR}"/go-favicon.ico "src/${EGO_SRC}/godoc/static/favicon.ico" ||
+ die
+ sed -e 's:"example.html",:\0\n\t"favicon.ico",:' \
+ -i src/${EGO_SRC}/godoc/static/makestatic.go || die
+ sed -e 's:<link type="text/css":<link rel="icon" type="image/png" href="/lib/godoc/favicon.ico">\n\0:' \
+ -i src/${EGO_SRC}/godoc/static/godoc.html || die
+}
+
+src_compile() {
+ # Generate static.go with favicon included
+ pushd src/golang.org/x/tools/godoc/static >/dev/null || die
+ go run makestatic.go || die
+ popd >/dev/null
+
+ golang-build_src_compile
+}
+
+src_install() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+
+ GOROOT="${T}/goroot" golang-build_src_install
+ dobin bin/* "${T}/goroot/bin/godoc"
+
+ exeinto "$(go env GOTOOLDIR)"
+ exeopts -m0755 -p # preserve timestamps for bug 551486
+ doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/cover"
+ doexe "${T}/goroot/pkg/tool/$(go env GOOS)_$(go env GOARCH)/vet"
+}
diff --git a/dev-go/go-tools/metadata.xml b/dev-go/go-tools/metadata.xml
new file mode 100644
index 000000000000..84be411994f1
--- /dev/null
+++ b/dev-go/go-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">golang/tools</remote-id>
+ </upstream>
+</pkgmetadata>