summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/bloomfilter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/bloomfilter')
-rw-r--r--dev-haskell/bloomfilter/Manifest2
-rw-r--r--dev-haskell/bloomfilter/bloomfilter-1.2.6.10-r2.ebuild39
-rw-r--r--dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild29
-rw-r--r--dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-ghc-7.7.patch46
-rw-r--r--dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-quickcheck-2.6.patch12
-rw-r--r--dev-haskell/bloomfilter/metadata.xml11
6 files changed, 139 insertions, 0 deletions
diff --git a/dev-haskell/bloomfilter/Manifest b/dev-haskell/bloomfilter/Manifest
new file mode 100644
index 000000000000..d895b653467d
--- /dev/null
+++ b/dev-haskell/bloomfilter/Manifest
@@ -0,0 +1,2 @@
+DIST bloomfilter-1.2.6.10.tar.gz 21533 SHA256 927420bcc1e1dec89ddfc1437d551fb2de325fd6bd01d79b207b3a84ca6152fc SHA512 c3bad38edf59bd59439c24385e300fab90f4ccd1b1faf7bea6c4b25b2bcabdfc806a7274d1cad40a711312b016d6fbb99a0ca9cf8b358ad874bbbabc14e1f454 WHIRLPOOL 2008461972b46dc1253972d7e31badb7e8e286556ee03e7bd7e0c7c35cdffccec801eea41cc6096beedc1cf40fb1fb4a84925efdab39202a1f869a80899d4e6d
+DIST bloomfilter-2.0.1.0.tar.gz 22100 SHA256 6c5e0d357d5d39efe97ae2776e8fb533fa50c1c05397c7b85020b0f098ad790f SHA512 1031cc28c5e5c1b7687355b709d436ebab1956ffd7591a010fa3852a1bc7412925a365f99937feeacf4b1a5d3c7b34bc0370707ad6e4533280dcac4ea3fa7c21 WHIRLPOOL 5e61ee5bcc0d68febbd13975524f09f9463cf108514396ceacf907124c5597ce17dc98b965900cea0faef7a923848cc77a07a4bcb150b8d09f90a0c612441325
diff --git a/dev-haskell/bloomfilter/bloomfilter-1.2.6.10-r2.ebuild b/dev-haskell/bloomfilter/bloomfilter-1.2.6.10-r2.ebuild
new file mode 100644
index 000000000000..0d2557ead55a
--- /dev/null
+++ b/dev-haskell/bloomfilter/bloomfilter-1.2.6.10-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Pure and impure Bloom Filter implementations"
+HOMEPAGE="https://github.com/bos/bloomfilter"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/quickcheck-2.4:2
+ <dev-haskell/quickcheck-2.8:2
+ dev-haskell/random
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2
+ )
+ >=dev-haskell/cabal-1.8"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck == 2.4.*' 'QuickCheck >= 2.4 && < 2.8'
+
+ if has_version ">=dev-haskell/quickcheck-2.5"; then
+ epatch "${FILESDIR}/${PN}-1.2.6.10-quickcheck-2.6.patch"
+ fi
+ epatch "${FILESDIR}/${PN}-1.2.6.10-ghc-7.7.patch"
+}
diff --git a/dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild b/dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild
new file mode 100644
index 000000000000..d5eacf015e55
--- /dev/null
+++ b/dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure and impure Bloom Filter implementations"
+HOMEPAGE="https://github.com/bos/bloomfilter"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.5
+ dev-haskell/random
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-ghc-7.7.patch b/dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-ghc-7.7.patch
new file mode 100644
index 000000000000..899fb4176aa2
--- /dev/null
+++ b/dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-ghc-7.7.patch
@@ -0,0 +1,46 @@
+diff --git a/Data/BloomFilter.hs b/Data/BloomFilter.hs
+index 69711ef..97a8348 100644
+--- a/Data/BloomFilter.hs
++++ b/Data/BloomFilter.hs
+@@ -93,7 +93,8 @@ import Control.Monad (liftM, forM_)
+ import Control.Monad.ST (ST, runST)
+ import Control.DeepSeq (NFData(..))
+ import Data.Array.Base (unsafeAt, unsafeRead, unsafeWrite)
+-import Data.Array.ST (STUArray, thaw, unsafeFreeze)
++import Data.Array.ST (STUArray, thaw)
++import qualified Data.Array.Unsafe as U (unsafeFreeze)
+ import Data.Array.Unboxed (UArray)
+ import Data.Bits ((.&.), (.|.))
+ import Data.BloomFilter.Array (newArray)
+@@ -336,7 +337,7 @@ notElemB elt ub = any test (hashesU ub elt)
+ -- occur. For a safer creation interface, use 'createB'.
+ unsafeFreezeMB :: MBloom s a -> ST s (Bloom a)
+ unsafeFreezeMB mb = B (hashMB mb) (shiftMB mb) (maskMB mb) `liftM`
+- unsafeFreeze (bitArrayMB mb)
++ U.unsafeFreeze (bitArrayMB mb)
+
+ -- | Copy an immutable Bloom filter to create a mutable one. There is
+ -- no non-copying equivalent.
+diff --git a/Data/BloomFilter/Array.hs b/Data/BloomFilter/Array.hs
+index e085bbe..5accde9 100644
+--- a/Data/BloomFilter/Array.hs
++++ b/Data/BloomFilter/Array.hs
+@@ -3,7 +3,8 @@
+
+ module Data.BloomFilter.Array (newArray) where
+
+-import Control.Monad.ST (ST, unsafeIOToST)
++import Control.Monad.ST (ST)
++import qualified Control.Monad.ST.Unsafe as U (unsafeIOToST)
+ import Data.Array.Base (MArray, STUArray(..), unsafeNewArray_)
+ #if __GLASGOW_HASKELL__ >= 704
+ import Foreign.C.Types (CInt(..), CSize(..))
+@@ -18,7 +19,7 @@ newArray :: forall e s. (MArray (STUArray s) e (ST s)) =>
+ {-# INLINE newArray #-}
+ newArray numElems numBytes = do
+ ary@(STUArray _ _ _ marr#) <- unsafeNewArray_ (0, numElems - 1)
+- _ <- unsafeIOToST (memset marr# 0 (fromIntegral numBytes))
++ _ <- U.unsafeIOToST (memset marr# 0 (fromIntegral numBytes))
+ return ary
+
+ foreign import ccall unsafe "memset"
diff --git a/dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-quickcheck-2.6.patch b/dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-quickcheck-2.6.patch
new file mode 100644
index 000000000000..0b27043aed2f
--- /dev/null
+++ b/dev-haskell/bloomfilter/files/bloomfilter-1.2.6.10-quickcheck-2.6.patch
@@ -0,0 +1,12 @@
+--- bloomfilter-1.2.6.10-orig/tests/QCSupport.hs 2012-06-16 09:59:56.000000000 +1000
++++ bloomfilter-1.2.6.10/tests/QCSupport.hs 2012-07-14 19:00:06.035731133 +1000
+@@ -20,9 +20,6 @@
+ arbitrary = choose (epsilon, 1 - epsilon)
+ where epsilon = 1e-6 :: P
+
+-instance Arbitrary Ordering where
+- arbitrary = oneof [return LT, return GT, return EQ]
+-
+ -- For some reason, MIN_VERSION_random doesn't work here :-(
+ #if __GLASGOW_HASKELL__ < 704
+ integralRandomR :: (Integral a, RandomGen g) => (a, a) -> g -> (a, g)
diff --git a/dev-haskell/bloomfilter/metadata.xml b/dev-haskell/bloomfilter/metadata.xml
new file mode 100644
index 000000000000..2eb68485816b
--- /dev/null
+++ b/dev-haskell/bloomfilter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Pure and impure Bloom Filter implementations.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bos/bloomfilter</remote-id>
+ </upstream>
+</pkgmetadata>