summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:06:37 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:21 +0100
commit3b19ec80ffa7d40037faa9c23c2dc15874cb8548 (patch)
treec22b45656285459b745bc764abfeee30d318c9ae /dev-haskell/cmdargs
parentdev-haskell/clock: add 0.8.3 (diff)
downloadgentoo-3b19ec80ffa7d40037faa9c23c2dc15874cb8548.tar.gz
gentoo-3b19ec80ffa7d40037faa9c23c2dc15874cb8548.tar.bz2
gentoo-3b19ec80ffa7d40037faa9c23c2dc15874cb8548.zip
dev-haskell/cmdargs: add 0.10.22
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/cmdargs')
-rw-r--r--dev-haskell/cmdargs/Manifest1
-rw-r--r--dev-haskell/cmdargs/cmdargs-0.10.22.ebuild36
-rw-r--r--dev-haskell/cmdargs/metadata.xml24
3 files changed, 40 insertions, 21 deletions
diff --git a/dev-haskell/cmdargs/Manifest b/dev-haskell/cmdargs/Manifest
index c6c327bc5b2f..20c948578523 100644
--- a/dev-haskell/cmdargs/Manifest
+++ b/dev-haskell/cmdargs/Manifest
@@ -1 +1,2 @@
DIST cmdargs-0.10.20.tar.gz 64550 BLAKE2B 08511df092c2a7010af94bc8d9b54b29c0e76c33be06a9521eccc85092b57a45ae9f9d22b0f8e81266073c81185b66266d1f2321c327ae730c6ccebea7f6d6cf SHA512 b9e270aa5dabd84eaaa47b95a450ef5b5f43cd19646f2a407579f855857d396e5ab9ca0038e1e876849a596ecb8cdc9964c45970825a0a95021d69b23699da79
+DIST cmdargs-0.10.22.tar.gz 65154 BLAKE2B a6f05c4a186dc4dbb9de3c754f9100138d3954b1537b1ecb81e2fec2c6bd293dd381a2a666dae0bcbbc631e9ab95d8a65d85d68d3e2c80bb2d6ad87baf9906b1 SHA512 571d9584769fdb5bb77a57607c2f432b365604a2ca2e9b5c044c319499004f7fcb12f2f6e61091a245f1bf6a5d321d38ade1a54d5bc86831136fa85b9b898faa
diff --git a/dev-haskell/cmdargs/cmdargs-0.10.22.ebuild b/dev-haskell/cmdargs/cmdargs-0.10.22.ebuild
new file mode 100644
index 000000000000..2ce0041ab470
--- /dev/null
+++ b/dev-haskell/cmdargs/cmdargs-0.10.22.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: testprog:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Command line argument processing"
+HOMEPAGE="https://github.com/ndmitchell/cmdargs#readme"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples +quotation"
+REQUIRED_USE="examples? ( quotation )"
+
+CABAL_CHDEPS=(
+ 'executable cmdargs' 'executable cmdargs-demo'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag quotation quotation) \
+ $(cabal_flag examples testprog)
+}
diff --git a/dev-haskell/cmdargs/metadata.xml b/dev-haskell/cmdargs/metadata.xml
index 4ba506a01472..4a2ade06e3ba 100644
--- a/dev-haskell/cmdargs/metadata.xml
+++ b/dev-haskell/cmdargs/metadata.xml
@@ -5,31 +5,13 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library provides an easy way to define command line parsers. Most users
- will want to use the "System.Console.CmdArgs.Implicit" module, whose
- documentation contains an example.
-
- * "System.Console.CmdArgs.Explicit" provides a way to write command line
- parsers for both single mode programs (most programs) and multiple
- mode programs (e.g. darcs or cabal). Parsers are defined by constructing
- a data structure.
-
- * "System.Console.CmdArgs.Implicit" provides a way to concisely define
- command line parsers, up to three times shorter than getopt. These parsers
- are translated into the Explicit data type.
-
- * "System.Console.CmdArgs.GetOpt" provides a wrapper allowing compatiblity
- with existing getopt parsers, mapping to the Explicit data type.
-
- For a general reference on what command line flags are commonly used,
- see &lt;http://www.faqs.org/docs/artu/ch10s05.html&gt;.
- </longdescription>
<use>
+ <flag name="examples">Build the cmdargs-demo program</flag>
<flag name="testprog">Build the test program</flag>
- <flag name="quotation">Build quote module</flag>
+ <flag name="quotation">Build the Quote module</flag>
</use>
<upstream>
+ <remote-id type="hackage">cmdargs</remote-id>
<remote-id type="github">ndmitchell/cmdargs</remote-id>
</upstream>
</pkgmetadata>