summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:15 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:02 +0100
commitb93e58cdad02628c0522230bb95dd47dc2eb8723 (patch)
treebc47e885ef01a9e61a5b2ffb260f9544d0288be8 /dev-haskell/hslua-repl
parentdev-haskell/isocline: new package, add 1.0.9 (diff)
downloadgentoo-b93e58cdad02628c0522230bb95dd47dc2eb8723.tar.gz
gentoo-b93e58cdad02628c0522230bb95dd47dc2eb8723.tar.bz2
gentoo-b93e58cdad02628c0522230bb95dd47dc2eb8723.zip
dev-haskell/hslua-repl: new package, add 0.1.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hslua-repl')
-rw-r--r--dev-haskell/hslua-repl/Manifest1
-rw-r--r--dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild32
-rw-r--r--dev-haskell/hslua-repl/metadata.xml15
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/hslua-repl/Manifest b/dev-haskell/hslua-repl/Manifest
new file mode 100644
index 000000000000..7df0ea685b8e
--- /dev/null
+++ b/dev-haskell/hslua-repl/Manifest
@@ -0,0 +1 @@
+DIST hslua-repl-0.1.1.tar.gz 4052 BLAKE2B cd7ca9277340a4708798144d6bd9da54e3b113a35f0896bdc8d08149677892f5fb1d5db0ed4f4ff2d2b29444be10ca737bcb1d18ec853f50284c07a7bb35b56d SHA512 c54c6bb7455d8f0cfd29812afc80d9617d0a100e94d4c3cd279b7579bf3be1fa3c1935785cb9eb4c664af345f1556e16a178049f3bd41823fdea56083d81bfdd
diff --git a/dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild b/dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild
new file mode 100644
index 000000000000..25501539d61c
--- /dev/null
+++ b/dev-haskell/hslua-repl/hslua-repl-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Isocline-based Lua REPL"
+HOMEPAGE="https://hslua.org/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/hslua-core-2.3.1:=[profile?] <dev-haskell/hslua-core-2.4:=[profile?]
+ >=dev-haskell/isocline-1.0:=[profile?] <dev-haskell/isocline-1.1:=[profile?]
+ >=dev-haskell/lua-2.3:=[profile?] <dev-haskell/lua-2.4:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}
diff --git a/dev-haskell/hslua-repl/metadata.xml b/dev-haskell/hslua-repl/metadata.xml
new file mode 100644
index 000000000000..aad2a20db55b
--- /dev/null
+++ b/dev-haskell/hslua-repl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="executable">Compile `luarepl` standalone executable.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">hslua-repl</remote-id>
+ <remote-id type="github">hslua/hslua</remote-id>
+ </upstream>
+</pkgmetadata>