summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:35 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:07 +0100
commit054ac33324852ff7f5212ee7ee42cc404ca65acc (patch)
tree5157151f6a2f2e9a13c4b301142eb6a2e71abf9a /dev-haskell/pandoc-lua-engine
parentdev-haskell/pandoc-lua-marshal: add 0.2.2 (diff)
downloadgentoo-054ac33324852ff7f5212ee7ee42cc404ca65acc.tar.gz
gentoo-054ac33324852ff7f5212ee7ee42cc404ca65acc.tar.bz2
gentoo-054ac33324852ff7f5212ee7ee42cc404ca65acc.zip
dev-haskell/pandoc-lua-engine: new package, add 0.2.1.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/pandoc-lua-engine')
-rw-r--r--dev-haskell/pandoc-lua-engine/Manifest2
-rw-r--r--dev-haskell/pandoc-lua-engine/metadata.xml12
-rw-r--r--dev-haskell/pandoc-lua-engine/pandoc-lua-engine-0.2.1.2.ebuild50
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-lua-engine/Manifest b/dev-haskell/pandoc-lua-engine/Manifest
new file mode 100644
index 000000000000..64df061cf7b0
--- /dev/null
+++ b/dev-haskell/pandoc-lua-engine/Manifest
@@ -0,0 +1,2 @@
+DIST pandoc-lua-engine-0.2.1.2-rev1.cabal 6835 BLAKE2B 70217c170c8eeb59571b208fab3ea34b7e1bcf30afad7365249fbd292a8c571910a3afe868f2b1fd68f8801eeeeb95f08810901f8dd5a32f511fdfc0ea665b98 SHA512 6c0fa6f266ab796f3c041f839a8fdb11f511dd76b88f2a48b6aa3df717e9a137a571ea204398a92be39bdc5e0d3a1e1e1814374192a9a9ea243c6303770ed4ae
+DIST pandoc-lua-engine-0.2.1.2.tar.gz 81179 BLAKE2B b6e8c29a754b093ebd17695a12a28a8755417033068668b6f8154f30ed649031b03c94f9a4ba262f7fa644b718f44c470273371cfa9866d1d7da1d5526fffc42 SHA512 4226463f889ae08fd6449ee3cc66b47830e3c0afee70cf897500461924176a62a2e7123cda8c1c2f8b47bcfdd67ae41502cc01cc04fc73f489c01dff6c897232
diff --git a/dev-haskell/pandoc-lua-engine/metadata.xml b/dev-haskell/pandoc-lua-engine/metadata.xml
new file mode 100644
index 000000000000..daccca3763a8
--- /dev/null
+++ b/dev-haskell/pandoc-lua-engine/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="hackage">pandoc-lua-engine</remote-id>
+ <remote-id type="github">jgm/pandoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/pandoc-lua-engine/pandoc-lua-engine-0.2.1.2.ebuild b/dev-haskell/pandoc-lua-engine/pandoc-lua-engine-0.2.1.2.ebuild
new file mode 100644
index 000000000000..b0b2b0d9301c
--- /dev/null
+++ b/dev-haskell/pandoc-lua-engine/pandoc-lua-engine-0.2.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Lua engine to power custom pandoc conversions"
+HOMEPAGE="https://pandoc.org"
+
+LICENSE="GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RESTRICT=test # requires network access to fetch .svg
+
+RDEPEND=">=dev-haskell/pandoc-3.1.4:=[profile?] <dev-haskell/pandoc-3.2:=[profile?]
+ dev-haskell/aeson:=[profile?]
+ >=dev-haskell/citeproc-0.8:=[profile?] <dev-haskell/citeproc-0.9:=[profile?]
+ >=dev-haskell/data-default-0.4:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
+ >=dev-haskell/doclayout-0.4:=[profile?] <dev-haskell/doclayout-0.5:=[profile?]
+ >=dev-haskell/doctemplates-0.11:=[profile?] <dev-haskell/doctemplates-0.12:=[profile?]
+ >=dev-haskell/hslua-2.3:=[profile?] <dev-haskell/hslua-2.4:=[profile?]
+ >=dev-haskell/hslua-module-doclayout-1.1:=[profile?] <dev-haskell/hslua-module-doclayout-1.2:=[profile?]
+ >=dev-haskell/hslua-module-path-1.1:=[profile?] <dev-haskell/hslua-module-path-1.2:=[profile?]
+ >=dev-haskell/hslua-module-system-1.1:=[profile?] <dev-haskell/hslua-module-system-1.2:=[profile?]
+ >=dev-haskell/hslua-module-text-1.1:=[profile?] <dev-haskell/hslua-module-text-1.2:=[profile?]
+ >=dev-haskell/hslua-module-version-1.1:=[profile?] <dev-haskell/hslua-module-version-1.2:=[profile?]
+ >=dev-haskell/hslua-module-zip-1.1:=[profile?] <dev-haskell/hslua-module-zip-1.2:=[profile?]
+ >=dev-haskell/hslua-repl-0.1.1:=[profile?] <dev-haskell/hslua-repl-0.2:=[profile?]
+ >=dev-haskell/lpeg-1.0.4:=[profile?] <dev-haskell/lpeg-1.1:=[profile?]
+ >=dev-haskell/pandoc-lua-marshal-0.2.2:=[profile?] <dev-haskell/pandoc-lua-marshal-0.3:=[profile?]
+ >=dev-haskell/pandoc-types-1.22:=[profile?] <dev-haskell/pandoc-types-1.24:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/sha-1.6:=[profile?] <dev-haskell/sha-1.7:=[profile?]
+ >=dev-haskell/text-1.1.1:=[profile?] <dev-haskell/text-2.2:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-golden
+ dev-haskell/tasty-hunit
+ >=dev-haskell/tasty-lua-1.1 <dev-haskell/tasty-lua-1.2 )
+"