summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-24 20:37:39 +1000
committerSam James <sam@gentoo.org>2022-07-24 18:10:57 +0100
commit9cdb9ebe2db0d22d65c8c757937c168d1f14722d (patch)
tree358dae45792ff1748331d18f6606a72b3371e00c /dev-haskell/regex-compat
parentprofiles: un-last-rite dev-haskell/vector-instances (diff)
downloadgentoo-9cdb9ebe2db0d22d65c8c757937c168d1f14722d.tar.gz
gentoo-9cdb9ebe2db0d22d65c8c757937c168d1f14722d.tar.bz2
gentoo-9cdb9ebe2db0d22d65c8c757937c168d1f14722d.zip
dev-haskell/regex-compat: add 0.95.2.1
Closes: https://bugs.gentoo.org/860501 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/regex-compat')
-rw-r--r--dev-haskell/regex-compat/Manifest1
-rw-r--r--dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/regex-compat/Manifest b/dev-haskell/regex-compat/Manifest
index a61e0cb61a88..d9747f54b05c 100644
--- a/dev-haskell/regex-compat/Manifest
+++ b/dev-haskell/regex-compat/Manifest
@@ -1 +1,2 @@
DIST regex-compat-0.95.2.0.tar.gz 4019 BLAKE2B 13825a59d2edaf5df3c4726f3b040d9354eaa95220cc907a74e5141aa95d2299107bfaa5037d327011bc3ccf3f0aeeb00ad9bd086e20b393eb898a19a46e5ca1 SHA512 8b1b421f5e7688a1d4a61711a255505a047e90e9f9283a8cf2ebfa9774631e8fb3a071d61877ab22548a0c63e30237603196f043dac9cb64da4df2fdc4422300
+DIST regex-compat-0.95.2.1.tar.gz 4285 BLAKE2B 5b1b7adf71c2903bf6647cc0bfefae230f59dbd3ab655a03083f279e7557b533ab745c15e36c51dcd6c4da9239e49a85c64a37a50458ee1a20e0d33a5abecc38 SHA512 87a671729dcdb2c89ce079fbb124cd2f16407f2dca0ed5d0d898a9cf06f893b82c184566efe80d966afbc7dde2cab1693b81516adc4832a9c65283a65fecd919
diff --git a/dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild b/dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild
new file mode 100644
index 000000000000..f554a29f8648
--- /dev/null
+++ b/dev-haskell/regex-compat/regex-compat-0.95.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +newbase,+splitbase
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Replaces/enhances \"Text.Regex\""
+HOMEPAGE="https://wiki.haskell.org/Regular_expressions"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/regex-base-0.94:=[profile?] <dev-haskell/regex-base-0.95:=[profile?]
+ >=dev-haskell/regex-posix-0.96:=[profile?] <dev-haskell/regex-posix-0.97:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=newbase \
+ --flag=splitbase
+}