summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:39 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:06 +0100
commit745bb48a49735df9f04843e0c1f0f045b644d03e (patch)
tree2f5111de6bcf8110545078ef34a8d40f1bbd2fa9 /dev-haskell/some/some-1.0.5.ebuild
parentdev-haskell/simple-sendfile: add 0.2.30-r1 (diff)
downloadgentoo-745bb48a49735df9f04843e0c1f0f045b644d03e.tar.gz
gentoo-745bb48a49735df9f04843e0c1f0f045b644d03e.tar.bz2
gentoo-745bb48a49735df9f04843e0c1f0f045b644d03e.zip
dev-haskell/some: new package, add 1.0.5
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/some/some-1.0.5.ebuild')
-rw-r--r--dev-haskell/some/some-1.0.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/some/some-1.0.5.ebuild b/dev-haskell/some/some-1.0.5.ebuild
new file mode 100644
index 000000000000..e5083536c7cc
--- /dev/null
+++ b/dev-haskell/some/some-1.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Existential type: Some"
+HOMEPAGE="https://github.com/haskellari/some"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+newtype-unsafe"
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag newtype-unsafe newtype-unsafe)
+}