summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-08-07 22:37:36 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-08-07 22:38:40 +0100
commitac2afc0709118651239c6f105670320420c7afac (patch)
tree82cde71ae2248a482f8fe098a3b2b9b5239a04fa /dev-haskell/stack-bin/stack-bin-1.5.1.ebuild
parentdev-util/ctags: regenerate Manifest file. (diff)
downloadgentoo-ac2afc0709118651239c6f105670320420c7afac.tar.gz
gentoo-ac2afc0709118651239c6f105670320420c7afac.tar.bz2
gentoo-ac2afc0709118651239c6f105670320420c7afac.zip
dev-haskell/stack-bin: added binary version of stack, bug #627282
Initial version of ebuild is written by Jeff Parent. Bug: https://bugs.gentoo.org/627282 Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-haskell/stack-bin/stack-bin-1.5.1.ebuild')
-rw-r--r--dev-haskell/stack-bin/stack-bin-1.5.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/stack-bin/stack-bin-1.5.1.ebuild b/dev-haskell/stack-bin/stack-bin-1.5.1.ebuild
new file mode 100644
index 000000000000..624ecf2f7aa6
--- /dev/null
+++ b/dev-haskell/stack-bin/stack-bin-1.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The Haskell Tool Stack (Binary)"
+HOMEPAGE="https://github.com/commercialhaskell/stack"
+
+uri() {
+ echo "https://github.com/commercialhaskell/stack/releases/download/v${PV}/stack-${PV}-linux-$1.tar.gz"
+}
+
+SRC_URI="
+ arm? ( $(uri arm) )
+ x86? ( $(uri i386) )
+ amd64? ( $(uri x86_64) )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-libs/zlib
+ dev-libs/gmp:0
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="/usr/bin/stack-bin"
+QA_PRESTRIPPED="/usr/bin/stack-bin"
+
+src_prepare() {
+ default
+
+ mv stack-${PV}-*/doc doc || die
+ mv stack-${PV}-*/stack stack-bin || die
+}
+
+src_install() {
+ dodoc doc/*
+ dobin stack-bin
+}