summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:24 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:04 +0100
commit702d214f97e1f857ff8b2eb35d0cf5542a3173fa (patch)
tree288957d1ecc0c1f89cb95a8d919d5beafbb28e99 /dev-haskell/tasty-lua
parentdev-haskell/hslua: add 2.3.0 (diff)
downloadgentoo-702d214f97e1f857ff8b2eb35d0cf5542a3173fa.tar.gz
gentoo-702d214f97e1f857ff8b2eb35d0cf5542a3173fa.tar.bz2
gentoo-702d214f97e1f857ff8b2eb35d0cf5542a3173fa.zip
dev-haskell/tasty-lua: add 1.1.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/tasty-lua')
-rw-r--r--dev-haskell/tasty-lua/Manifest1
-rw-r--r--dev-haskell/tasty-lua/metadata.xml4
-rw-r--r--dev-haskell/tasty-lua/tasty-lua-1.1.0.ebuild30
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/tasty-lua/Manifest b/dev-haskell/tasty-lua/Manifest
index 0586dfcaf616..47e2ad2ef58d 100644
--- a/dev-haskell/tasty-lua/Manifest
+++ b/dev-haskell/tasty-lua/Manifest
@@ -1 +1,2 @@
DIST tasty-lua-1.0.2.tar.gz 10413 BLAKE2B 78d09b1c70b53b23264ee5d2b76d32be43e55e3df551792a51626201e405cd25be267cbe2c55dee2c16851877b90c30cbd8bd8b34fd341ce9024ae75e423e5f9 SHA512 0b572e4dbb793c573d28a9e3516926e7f7cba7e962e48de29c24b4da9c2656407cf3a2db21b2db56fa149ef13a70e318f44b3b5de2041863510d31e1bd621857
+DIST tasty-lua-1.1.0.tar.gz 10420 BLAKE2B d771834f6386a93767193998a0136b16cdf84dc07e273265942e3af160560e24d8b1077958c909fa7a9162323f9fb4c42ad52802292b6d8ab17128f060591f01 SHA512 22f002ef8cda5069947f144aaa03d0f17c9edfc3358238de29980244c18cc61058d799d3e156cd40c90e20569c3cae279a3fe264b766e1d179576886404e90fb
diff --git a/dev-haskell/tasty-lua/metadata.xml b/dev-haskell/tasty-lua/metadata.xml
index 937381521944..01584748d5c0 100644
--- a/dev-haskell/tasty-lua/metadata.xml
+++ b/dev-haskell/tasty-lua/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">tasty-lua</remote-id>
+ <remote-id type="github">hslua/hslua</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/tasty-lua/tasty-lua-1.1.0.ebuild b/dev-haskell/tasty-lua/tasty-lua-1.1.0.ebuild
new file mode 100644
index 000000000000..16250ccc7505
--- /dev/null
+++ b/dev-haskell/tasty-lua/tasty-lua-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Write tests in Lua, integrate into tasty"
+HOMEPAGE="https://github.com/hslua/hslua"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/file-embed-0.0:=[profile?] <dev-haskell/file-embed-0.1:=[profile?]
+ >=dev-haskell/hslua-core-2.3:=[profile?] <dev-haskell/hslua-core-2.4:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.0:=[profile?] <dev-haskell/hslua-marshalling-2.4:=[profile?]
+ >=dev-haskell/lua-arbitrary-1.0:=[profile?] <dev-haskell/lua-arbitrary-1.1:=[profile?]
+ >=dev-haskell/quickcheck-2.9:2=[profile?] <dev-haskell/quickcheck-2.15:2=[profile?]
+ >=dev-haskell/tasty-1.2:=[profile?] <dev-haskell/tasty-1.5:=[profile?]
+ >=dev-haskell/text-1.2:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-haskell/tasty-hunit )
+"