summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:14 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:14 +0100
commitbc4bbf92a3de943a429d2de15e98a8b889a68875 (patch)
tree681e75ab065f3fdf460bc531c2dcf21da5a1d0bb /dev-haskell/th-lift-instances
parentdev-haskell/th-compat: add 0.1.4 (diff)
downloadgentoo-bc4bbf92a3de943a429d2de15e98a8b889a68875.tar.gz
gentoo-bc4bbf92a3de943a429d2de15e98a8b889a68875.tar.bz2
gentoo-bc4bbf92a3de943a429d2de15e98a8b889a68875.zip
dev-haskell/th-lift-instances: add 0.1.20
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/th-lift-instances')
-rw-r--r--dev-haskell/th-lift-instances/Manifest1
-rw-r--r--dev-haskell/th-lift-instances/metadata.xml8
-rw-r--r--dev-haskell/th-lift-instances/th-lift-instances-0.1.20.ebuild25
3 files changed, 30 insertions, 4 deletions
diff --git a/dev-haskell/th-lift-instances/Manifest b/dev-haskell/th-lift-instances/Manifest
index 44755e478e62..af5ed5344418 100644
--- a/dev-haskell/th-lift-instances/Manifest
+++ b/dev-haskell/th-lift-instances/Manifest
@@ -1 +1,2 @@
DIST th-lift-instances-0.1.19.tar.gz 6113 BLAKE2B 75cfd2a7f8c80fe3cd03e66c8c6fa104f79167de1ed75db9b46e94d27c93c5650be13068c3273fa7d9e401f6017306796acb8806a055a856176be0a88bb0d5ba SHA512 d8a38531a9a61dce426c43807e3764abbe22102e8886d9d23e76d27735bace672e10472b77b27dbe2fbb74bf6e32a5d528d690a608a81d8dce9963721fad6349
+DIST th-lift-instances-0.1.20.tar.gz 6721 BLAKE2B 178c00ffa942787aef063f87e1714f0625e68c9cdb6aad113da04db4113fd39813ed3082bbc6f5db774dd33833602464c73151bb1485d80593427d4347bb33eb SHA512 bb43b13df8fb939a79a3fc1099900fcaa8741eb61b8f5574b7d7b68c220acc0cbb9fa7517b22ad34f006da7a1c25c08d1237309f8f98d79ca4d00dad345b28cb
diff --git a/dev-haskell/th-lift-instances/metadata.xml b/dev-haskell/th-lift-instances/metadata.xml
index 929b58cd63b5..817b6339b275 100644
--- a/dev-haskell/th-lift-instances/metadata.xml
+++ b/dev-haskell/th-lift-instances/metadata.xml
@@ -5,8 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Most data types in haskell platform do not have Lift instances. This package provides orphan instances
- for containers, text, bytestring and vector.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">th-lift-instances</remote-id>
+ <remote-id type="github">bennofs/th-lift-instances</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/th-lift-instances/th-lift-instances-0.1.20.ebuild b/dev-haskell/th-lift-instances/th-lift-instances-0.1.20.ebuild
new file mode 100644
index 000000000000..e42707a54751
--- /dev/null
+++ b/dev-haskell/th-lift-instances/th-lift-instances-0.1.20.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Lift instances for template-haskell for common data types"
+HOMEPAGE="https://github.com/bennofs/th-lift-instances/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/th-lift-0.8:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/quickcheck-2.6 )
+"