summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-19 12:31:23 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-19 12:32:39 -0700
commit2feaf6caf827123788b3e1d1eacac2a6001f2d00 (patch)
treeca6776296bad89dbdba5fdac861988a1ef3972ba /dev-java/openjfx/files
parentgnome-base/gnome-keyring: Port to python3 (diff)
downloadgentoo-2feaf6caf827123788b3e1d1eacac2a6001f2d00.tar.gz
gentoo-2feaf6caf827123788b3e1d1eacac2a6001f2d00.tar.bz2
gentoo-2feaf6caf827123788b3e1d1eacac2a6001f2d00.zip
dev-java/openjfx: add 8.999 version
it's last tip version of publicly available openjfx-8 with security and reliability patches backported. it's possible to toggle avplugin build independently of media now, but it's still behind media useflag for now. also switched to gradle-4.10.3 patches taken from https://github.com/jschwartzenberg/openjfx8 Bug: https://bugs.gentoo.org/547918 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-java/openjfx/files')
-rw-r--r--dev-java/openjfx/files/8/don-t-force-msse.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/openjfx/files/8/don-t-force-msse.patch b/dev-java/openjfx/files/8/don-t-force-msse.patch
new file mode 100644
index 000000000000..2f5d56718cca
--- /dev/null
+++ b/dev-java/openjfx/files/8/don-t-force-msse.patch
@@ -0,0 +1,51 @@
+From 6483d73551590e8036cd5ec6d317e8114b403f36 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Sun, 26 Apr 2020 20:57:39 -0700
+Subject: [PATCH] don't force msse
+
+---
+ .../main/native/gstreamer/projects/linux/avplugin/Makefile | 1 -
+ .../native/gstreamer/projects/linux/fxplugins/Makefile | 1 -
+ .../media/src/main/native/jfxmedia/projects/linux/Makefile | 1 -
+ modules/web/src/main/native/Tools/Scripts/webkitdirs.pm | 7 -------
+ 4 files changed, 10 deletions(-)
+
+diff --git a/modules/media/src/main/native/gstreamer/projects/linux/avplugin/Makefile b/modules/media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
+index df9f7f21..f82f0537 100644
+--- a/modules/media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
++++ b/modules/media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
+@@ -28,7 +28,6 @@ CFLAGS = -fPIC \
+ -Wformat-security \
+ -Werror=implicit-function-declaration \
+ -fstack-protector \
+- -msse2 \
+ -fbuiltin \
+ -DHAVE_STDINT_H \
+ -DLINUX \
+diff --git a/modules/media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile b/modules/media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
+index fd3847d0..3887ac6d 100644
+--- a/modules/media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
++++ b/modules/media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
+@@ -25,7 +25,6 @@ CFLAGS = -fPIC \
+ -Wformat-security \
+ -Werror=implicit-function-declaration \
+ -fstack-protector \
+- -msse2 \
+ -fbuiltin \
+ -DHAVE_STDINT_H \
+ -DLINUX \
+diff --git a/modules/media/src/main/native/jfxmedia/projects/linux/Makefile b/modules/media/src/main/native/jfxmedia/projects/linux/Makefile
+index 3d089501..10fad68f 100644
+--- a/modules/media/src/main/native/jfxmedia/projects/linux/Makefile
++++ b/modules/media/src/main/native/jfxmedia/projects/linux/Makefile
+@@ -44,7 +44,6 @@ ifdef HOST_COMPILE
+ -Wformat-security \
+ -fstack-protector \
+ -Werror=implicit-function-declaration \
+- -msse2 \
+ -DGSTREAMER_LITE
+
+ INCLUDES = $(BASE_INCLUDES) \
+--
+2.26.2
+