summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/simplyhtml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/simplyhtml')
-rw-r--r--dev-java/simplyhtml/Manifest1
-rw-r--r--dev-java/simplyhtml/metadata.xml8
-rw-r--r--dev-java/simplyhtml/simplyhtml-0.13.1.ebuild51
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/simplyhtml/Manifest b/dev-java/simplyhtml/Manifest
new file mode 100644
index 000000000000..02965b8538fd
--- /dev/null
+++ b/dev-java/simplyhtml/Manifest
@@ -0,0 +1 @@
+DIST SimplyHTML_src_0_13_1.tar.gz 473258 SHA256 34ad16951e1165261e81f1a23ba6791e8391888749b19429d7f067e3ca1300dd SHA512 e37140ef7461f2c741f43ce14518e224cb41ddb42c4d396f8f934476a5fbbe4d121950dc3186ba1ae603068e81832a92240e99cd25d3778574c0d3f370d501ac WHIRLPOOL 3f29e95d3b5369507f5e769501b01084667125f1a4744f24275168cc417c1d7ab48f6f5e4ea9f1ef17c933a94d868b9de79562ae8bc6db72b16da0bb03474ea8
diff --git a/dev-java/simplyhtml/metadata.xml b/dev-java/simplyhtml/metadata.xml
new file mode 100644
index 000000000000..39c18d820a9d
--- /dev/null
+++ b/dev-java/simplyhtml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">simplyhtml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/simplyhtml/simplyhtml-0.13.1.ebuild b/dev-java/simplyhtml/simplyhtml-0.13.1.ebuild
new file mode 100644
index 000000000000..2b8d08c61569
--- /dev/null
+++ b/dev-java/simplyhtml/simplyhtml-0.13.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2 versionator
+
+MY_PN="SimplyHTML"
+MY_PV="$(replace_all_version_separators _)"
+#MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Text processing application based on HTML and CSS files"
+HOMEPAGE="http://${PN}.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_src_${MY_PV}.tar.gz"
+#SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+COMMON_DEP="dev-java/javahelp
+ dev-java/gnu-regexp"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${PN}-${MY_PV}/src"
+
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+java_prepare() {
+ # it wants to copy lib jars
+ sed -i '/copy file/d' build.xml || die
+}
+
+src_compile() {
+ local cp="$(java-pkg_getjars javahelp,gnu-regexp-1)"
+ eant -Dclasspath="${cp}" jar $(use_doc)
+}
+
+src_install() {
+ cd ..
+ java-pkg_dojar dist/lib/${MY_PN}*.jar
+
+ dodoc readme.txt || die
+
+ use doc && java-pkg_dojavadoc dist/api
+ use source && java-pkg_dosrc src/com src/de
+}