summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/nqc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/nqc')
-rw-r--r--dev-lang/nqc/Manifest1
-rw-r--r--dev-lang/nqc/files/nqc-3.1_p6-flags.patch73
-rw-r--r--dev-lang/nqc/files/nqc-3.1_p6-gcc-4.7.patch15
-rw-r--r--dev-lang/nqc/metadata.xml8
-rw-r--r--dev-lang/nqc/nqc-3.1_p6.ebuild56
5 files changed, 153 insertions, 0 deletions
diff --git a/dev-lang/nqc/Manifest b/dev-lang/nqc/Manifest
new file mode 100644
index 000000000000..8933fec78a4a
--- /dev/null
+++ b/dev-lang/nqc/Manifest
@@ -0,0 +1 @@
+DIST nqc-3.1.r6.tgz 329410 SHA256 bfd5e654f639af7a588cfdef4d22bd5efcfff547b10a56cebebde58ef2bfe766 SHA512 7ec7015861b5f8e063e3a2567f5c6ff7e5c6a65b60fab9bef71411d59b13a588f284ee3a8d06b9325748c209e21f9480b9792bc605148e2a4af64b90f872e2aa WHIRLPOOL 72c2dcb63bbdc1a1d35e0bb17c1c2838f688c69ef48d0958663c99c48855454b99a586603309b238e23eb6adc87edff40800c9ff1f81c12829d61d7e95b0a757
diff --git a/dev-lang/nqc/files/nqc-3.1_p6-flags.patch b/dev-lang/nqc/files/nqc-3.1_p6-flags.patch
new file mode 100644
index 000000000000..a27d1e454a03
--- /dev/null
+++ b/dev-lang/nqc/files/nqc-3.1_p6-flags.patch
@@ -0,0 +1,73 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Aug 21 18:14:15 UTC 2012
+Subject: build system
+
+respect flags
+
+--- Makefile
++++ Makefile
+@@ -67,7 +67,7 @@
+
+ # CFLAGS
+ #CFLAGS = -pipe -Iplatform -Ircxlib -Inqc -Icompiler -Wall -Wstrict-prototypes -Wmissing-prototypes
+-CFLAGS += -Iplatform -Ircxlib -Inqc -Icompiler -Wall
++CXXFLAGS += -Iplatform -Ircxlib -Inqc -Icompiler -Wall
+
+ USBOBJ = rcxlib/RCX_USBTowerPipe_none.o
+
+@@ -87,20 +87,20 @@
+ # Linux
+ # uncomment this next line if you have the USB tower library installed
+ # USBOBJ = rcxlib/RCX_USBTowerPipe_linux.o
+- CFLAGS += -I/usr/local/include/LegoUSB -Wno-deprecated
++ CXXFLAGS += -I/usr/include/LegoUSB -Wno-deprecated
+ else
+ ifneq (,$(findstring $(OSTYPE), SunOS))
+ # Solaris
+- CFLAGS += -DSOLARIS
++ CXXFLAGS += -DSOLARIS
+ else
+ ifneq (,$(strip $(findstring $(OSTYPE), FreeBSD)))
+ # FreeBSD
+ USBOBJ = rcxlib/RCX_USBTowerPipe_fbsd.o
+ DEFAULT_SERIAL_NAME = "/dev/cuad0"
+- CFLAGS += -Wno-deprecated
++ CXXFLAGS += -Wno-deprecated
+ else
+ # default Unix build without USB support
+- CFLAGS += -O6
++ CXXFLAGS += -O6
+ endif
+ endif
+ endif
+@@ -113,7 +113,7 @@
+ ifndef DEFAULT_SERIAL_NAME
+ DEFAULT_SERIAL_NAME = "/dev/ttyS0"
+ endif
+-CFLAGS += -DDEFAULT_SERIAL_NAME='$(DEFAULT_SERIAL_NAME)'
++CXXFLAGS += -DDEFAULT_SERIAL_NAME='$(DEFAULT_SERIAL_NAME)'
+
+ #
+ # Object files
+@@ -164,10 +164,10 @@
+ $(MKDIR) bin
+
+ bin/nqc : compiler/parse.cpp $(OBJ)
+- $(CXX) -o $@ $(OBJ) $(LIBS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
+
+ bin/mkdata : mkdata/mkdata.cpp nqc/SRecord.cpp
+- $(CXX) -o bin/mkdata -Inqc/ -Iplatform/ mkdata/mkdata.cpp nqc/SRecord.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o bin/mkdata -Inqc/ -Iplatform/ mkdata/mkdata.cpp nqc/SRecord.cpp
+
+ #
+ # clean up stuff
+@@ -227,7 +227,7 @@
+ # general rule for compiling
+ #
+ .cpp.o:
+- $(CXX) -c $(CFLAGS) $< -o $*.o
++ $(CXX) -c $(CXXFLAGS) $< -o $*.o
+
+
+ #
diff --git a/dev-lang/nqc/files/nqc-3.1_p6-gcc-4.7.patch b/dev-lang/nqc/files/nqc-3.1_p6-gcc-4.7.patch
new file mode 100644
index 000000000000..73a96abef293
--- /dev/null
+++ b/dev-lang/nqc/files/nqc-3.1_p6-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ compiler/lexer.cpp | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/compiler/lexer.cpp b/compiler/lexer.cpp
+index 14e6d92..274b1a7 100755
+--- a/compiler/lexer.cpp
++++ b/compiler/lexer.cpp
+@@ -10,6 +10,7 @@
+ #define YY_FLEX_MAJOR_VERSION 2
+ #define YY_FLEX_MINOR_VERSION 5
+
++#include <unistd.h>
+ #include <stdio.h>
+
+ #if defined(__MWERKS__) && !__MACH__ && !YY_NEVER_INTERACTIVE
diff --git a/dev-lang/nqc/metadata.xml b/dev-lang/nqc/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/dev-lang/nqc/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-lang/nqc/nqc-3.1_p6.ebuild b/dev-lang/nqc/nqc-3.1_p6.ebuild
new file mode 100644
index 000000000000..cc855704a87f
--- /dev/null
+++ b/dev-lang/nqc/nqc-3.1_p6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Not Quite C - C-like compiler for Lego Mindstorms"
+HOMEPAGE="http://bricxcc.sourceforge.net/nqc/"
+SRC_URI="http://bricxcc.sourceforge.net/nqc/release/${P/_p/.r}.tgz"
+
+LICENSE="MPL-1.0"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="usb"
+
+DEPEND="usb? ( dev-libs/legousbtower )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ tc-export CXX
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{gcc-4.7,flags}.patch
+}
+
+src_configure() {
+ if use usb; then
+ sed -i Makefile -e 's|#.*USBOBJ =|USBOBJ =|g' || die "sed usb"
+ fi
+}
+
+src_install() {
+ dobin bin/*
+ newman nqc-man-2.1r1-0.man nqc.1
+ dodoc history.txt readme.txt scout.txt test.nqc
+}
+
+pkg_postinst() {
+ elog "To change the default serial name for nqc (/dev/ttyS0) set"
+ elog "the environment variable RCX_PORT or use the nqc command line"
+ elog "option -S to specify your serial port."
+ if use usb; then
+ echo
+ elog "You have enabled USB support. To use usb on the"
+ elog "command line use the -Susb command line option"
+ else
+ echo
+ elog "You have not enabled usb support and will be unable"
+ elog "to use the usb IR tower. To enable USB use the usb use flag"
+ fi
+}