summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-lang/ruby
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ruby-2.4.9.ebuild11
-rw-r--r--dev-lang/ruby/ruby-2.5.7.ebuild11
-rw-r--r--dev-lang/ruby/ruby-2.6.5.ebuild13
3 files changed, 16 insertions, 19 deletions
diff --git a/dev-lang/ruby/ruby-2.4.9.ebuild b/dev-lang/ruby/ruby-2.4.9.ebuild
index 855960b6f5cf..8f8e27dd860f 100644
--- a/dev-lang/ruby/ruby-2.4.9.ebuild
+++ b/dev-lang/ruby/ruby-2.4.9.ebuild
@@ -143,16 +143,15 @@ src_configure() {
$(use_with static-libs static-linked-ext) \
$(use_enable debug) \
${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
+ --enable-option-checking=no
}
src_compile() {
- emake V=1 EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake V=1 EXTLDFLAGS="${LDFLAGS}"
}
src_test() {
- emake -j1 V=1 test || die "make test failed"
+ emake -j1 V=1 test
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -187,7 +186,7 @@ src_install() {
done
export LD_LIBRARY_PATH RUBYLIB
- emake V=1 DESTDIR="${D}" install || die "make install failed"
+ emake V=1 DESTDIR="${D}" install
# Remove installed rubygems and rdoc copy
rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
@@ -204,7 +203,7 @@ src_install() {
doins -r sample
fi
- dodoc ChangeLog NEWS doc/NEWS* README* || die
+ dodoc ChangeLog NEWS doc/NEWS* README*
if use rubytests; then
pushd test
diff --git a/dev-lang/ruby/ruby-2.5.7.ebuild b/dev-lang/ruby/ruby-2.5.7.ebuild
index e63ff54b17b1..992d04bc501d 100644
--- a/dev-lang/ruby/ruby-2.5.7.ebuild
+++ b/dev-lang/ruby/ruby-2.5.7.ebuild
@@ -138,16 +138,15 @@ src_configure() {
$(use_with static-libs static-linked-ext) \
$(use_enable debug) \
${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
+ --enable-option-checking=no
}
src_compile() {
- emake V=1 EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake V=1 EXTLDFLAGS="${LDFLAGS}"
}
src_test() {
- emake -j1 V=1 test || die "make test failed"
+ emake -j1 V=1 test
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -182,7 +181,7 @@ src_install() {
done
export LD_LIBRARY_PATH RUBYLIB
- emake V=1 DESTDIR="${D}" install || die "make install failed"
+ emake V=1 DESTDIR="${D}" install
# Remove installed rubygems and rdoc copy
rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
@@ -199,7 +198,7 @@ src_install() {
doins -r sample
fi
- dodoc ChangeLog NEWS doc/NEWS* README* || die
+ dodoc ChangeLog NEWS doc/NEWS* README*
if use rubytests; then
pushd test
diff --git a/dev-lang/ruby/ruby-2.6.5.ebuild b/dev-lang/ruby/ruby-2.6.5.ebuild
index 57bd24dcd4f5..563576964c50 100644
--- a/dev-lang/ruby/ruby-2.6.5.ebuild
+++ b/dev-lang/ruby/ruby-2.6.5.ebuild
@@ -142,19 +142,18 @@ src_configure() {
$(use_with static-libs static-linked-ext) \
$(use_enable debug) \
${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
+ --enable-option-checking=no
# Makefile is broken because it lacks -ldl
rm -rf ext/-test-/popen_deadlock || die
}
src_compile() {
- emake V=1 EXTLDFLAGS="${LDFLAGS}" MJIT_CFLAGS="${CFLAGS}" MJIT_OPTFLAGS="" MJIT_DEBUGFLAGS="" || die "emake failed"
+ emake V=1 EXTLDFLAGS="${LDFLAGS}" MJIT_CFLAGS="${CFLAGS}" MJIT_OPTFLAGS="" MJIT_DEBUGFLAGS=""
}
src_test() {
- emake -j1 V=1 test || die "make test failed"
+ emake -j1 V=1 test
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -194,7 +193,7 @@ src_install() {
local gem_home="${EPREFIX}/usr/$(get_libdir)/ruby/gems/${RUBYVERSION}"
mkdir -p "${D}/${gem_home}" || die "mkdir gem home failed"
- emake V=1 DESTDIR="${D}" GEM_DESTDIR=${gem_home} install || die "make install failed"
+ emake V=1 DESTDIR="${D}" GEM_DESTDIR=${gem_home} install
# Remove installed rubygems and rdoc copy
rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
@@ -203,7 +202,7 @@ src_install() {
rm -rf "${ED}/usr/bin/"{bundle,bundler,ri,rdoc}"${MY_SUFFIX}" || die "rm rdoc bins failed"
if use doc; then
- emake DESTDIR="${D}" GEM_DESTDIR=${gem_home} install-doc || die "make install-doc failed"
+ emake DESTDIR="${D}" GEM_DESTDIR=${gem_home} install-doc
fi
if use examples; then
@@ -211,7 +210,7 @@ src_install() {
doins -r sample
fi
- dodoc ChangeLog NEWS doc/NEWS* README* || die
+ dodoc ChangeLog NEWS doc/NEWS* README*
if use rubytests; then
pushd test